2 Replies Latest reply on Jul 11, 2017 8:32 PM by sbierwagen

    ArduinoPersonFollower: frame [detection_data] does not exist?

    sbierwagen

      The readme for the Arduino person follower scenario indicates that it publishes /person_follower/marker for use in rviz. (Actually, it says /depth_follower/marker, which I'm guessing is a copy-paste error from the readme for the depth follower)

       

      However, if you subscribe to that topic in rviz, it throws the error "For frame [detection_data]: Frame [detection_data] does not exist".

       

      Is there a different frame it wants us to use?

        • 1. Re: ArduinoPersonFollower: frame [detection_data] does not exist?
          BolousAbuJaber

          Hello sbierwagen,

           

          I ran the same scenario and got the same error, it is a bug in the Person Follower Node, i see you have two possible fixes:

           

          Full Fix:

               1) Clone the Person Follower package

               2) Change the frame_id in the published topic to camera_depth_frame

               3) Compile in the catkin_ws

               4) Should work immediately

           

          Quick Fix:

               You can actually publish a new fixed frame_id relative the camera_depth_frame.

           

               rosrun tf static_transform_publisher 0 0 0 0 0 0 camera_depth_frame detection_data 0

           

               this actually registers a new frame_id(detection_data) which is relative of camera_depth_frame with a 0 transformation.

           

          * This was added to our bugs list, will fix it ASAP

           

          Best of luck,

          Bolous

          • 2. Re: ArduinoPersonFollower: frame [detection_data] does not exist?
            sbierwagen

            The static transform works great, thank you.

             

            I was interested in doing the full fix, because I wanted to make other changes to follower_nodelet.cpp. (The x-axis scaling seems off on the /goal topic, only ever going from 0.1 to 0.2. This has the effect that the robot never turns to keep the subject in the center of the frame)

             

            However, when recompiled with catkin_make and started with roslaunch, it only starts up the person follower nodelet. Without the cameras or the robot control nodes running, it doesn't... work. Starting the arduino follower scenario with rosservice run_scenario seems to start the stock person follower, not the modified version in catkin_ws.

             

            How do I invoke the modified version so that it also starts up all the required nodes?