1 Reply Latest reply on Jul 8, 2017 3:06 AM by MartyG

    R200 camera no IR image uvcvideo patch failed

    campfire

      Hi,

       

      I am new to RealSense and purchased a robotic development kit (R200 camera + up board). I followed the instruction in the official quick start guide: installed latest Ubuntu 16.04 LTS, Linux-upboard kernel 4.4.0.2-upboard, installed ros and realsense packages. However, when I launched the r200_nodelet_default.launch, all I can get are colored image and depth image, no IR image. /camera/ir/image_raw with image_view gives me empty window, while /camera/depth/image_raw and /camera/color/image_raw give me proper image feed.

       

      I tried dmesg and got error message uvcvideo: Failed to query (SET_CUR) UVC control 1 on unit 7: -32 (exp. 2) So I looked it up online, and people are talking about the uvcvideo patch not properly installed. So I ran the script provided in librealsense: patch-uvcvideo-ubuntu-mainline.sh  , but it failed at the patching step showing that Hunk #1 failed. At this point, I have tried the entire installation process starting with a clean system twice to make sure I did not get any step wrong, and I could not really find any way to fix the uvcvideo issue.

       

      If anyone could help me with the issue, it will be really appreciated.