1 Reply Latest reply on Jul 25, 2017 9:07 PM by Intel Corporation

    Issue with X710 and XL710 on Dell PowerEdge server + RedHat 7.2

    MikaelE

      Hi Intel comunity,

      We have serious problem with intel cards (X710 and XL170). 

      The linux server (Dell Power Edge 630) don’t see them completely under RedHat 7.2. I dont see the interfaces under linux ifconfig -a.

      I have installed the last drivers (ixgbe-5.1.3 and i40e-2.0.26) but didnt succedded to update the firmware (if it is the problem).

       

      Here below the output of my server:

      • From "modinfo" I get the following output:

       

      [root@TBOS ~]# modinfo i40e

      filename: /lib/modules/3.10.0-327.el7.x86_64/updates/drivers/net/ethernet/intel/i40e/i40e.ko

      version: 2.0.26

      license: GPL

      description: Intel(R) 40-10 Gigabit Ethernet Connection Network Driver

      author: Intel Corporation, <e1000-devel@lists.sourceforge.net>

      rhelversion: 7.2

      srcversion: F49696A466EC36F89F8FE86

      alias: pci:v00008086d0000158Bsv*sd*bc*sc*i*

      alias: pci:v00008086d0000158Asv*sd*bc*sc*i*

      alias: pci:v00008086d000037D3sv*sd*bc*sc*i*

      alias: pci:v00008086d000037D2sv*sd*bc*sc*i*

      alias: pci:v00008086d000037D1sv*sd*bc*sc*i*

      alias: pci:v00008086d000037D0sv*sd*bc*sc*i*

      alias: pci:v00008086d000037CFsv*sd*bc*sc*i*

      alias: pci:v00008086d000037CEsv*sd*bc*sc*i*

      alias: pci:v00008086d0000374Csv*sd*bc*sc*i*

      alias: pci:v00008086d00001588sv*sd*bc*sc*i*

      alias: pci:v00008086d00001587sv*sd*bc*sc*i*

      alias: pci:v00008086d00001589sv*sd*bc*sc*i*

      alias: pci:v00008086d00001586sv*sd*bc*sc*i*

      alias: pci:v00008086d00001585sv*sd*bc*sc*i*

      alias: pci:v00008086d00001584sv*sd*bc*sc*i*

      alias: pci:v00008086d00001583sv*sd*bc*sc*i*

      alias: pci:v00008086d00001581sv*sd*bc*sc*i*

      alias: pci:v00008086d00001580sv*sd*bc*sc*i*

      alias: pci:v00008086d00001574sv*sd*bc*sc*i*

      alias: pci:v00008086d00001572sv*sd*bc*sc*i*

      depends: ptp,vxlan

      vermagic: 3.10.0-327.el7.x86_64 SMP mod_unload modversions

      parm: debug:Debug level (0=none,...,16=all) (int)

      [root@TBOS ~]#

       

      • From ifconfig –a, we don’t see the port at all !!!

       

      • When I want to update the firmware, I get
          • [root@TBOS Linux_x64]# ./nvmupdate64e

      Intel(R) Ethernet NVM Update Tool

      NVMUpdate version 1.28.19.4

      Copyright (C) 2013 - 2016 Intel Corporation.

      WARNING: To avoid damage to your device, do not stop the update or reboot or power off the system during this update.

      Inventory in progress. Please wait [*|........]

      Num Description Ver. DevId S:B    Status

      === ======================================== ===== ===== ====== ===============

      01) Intel(R) Ethernet Converged Network 1572 00:004 Access error

      Adapter X710

      Tool execution completed with the following status: Device not found

      Press any key to exit.

       

      • Dmesg output:

      [root@TBOS ~]# dmesg| grep i40

      [ 3.549403] i40e: Intel(R) 40-10 Gigabit Ethernet Connection Network Driver - version 2.0.26

      [ 3.549405] i40e: Copyright(c) 2013 - 2017 Intel Corporation.

      [ 3.578751] i40e 0000:04:00.0: fw 4.33.31377 api 1.2 nvm 4.41 0x80001869 16.5.10

      [ 3.578754] i40e 0000:04:00.0: The driver for the device detected an older version of the NVM image than expected. Please update the NVM image.

      [ 3.822134] i40e 0000:04:00.0: MAC address: 3c:fd:fe:0c:cb:e0

      [    3.835115] i40e 0000:04:00.0: Query for DCB configuration failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_EPERM

      [ 3.835118] i40e 0000:04:00.0: DCB init failed -53, disabled

      [ 3.835166] i40e 0000:04:00.0: irq 91 for MSI/MSI-X

      …..

      [ 3.836118] i40e 0000:04:00.0: irq 148 for MSI/MSI-X

      [ 4.050907] i40e 0000:04:00.0: Added LAN device PF0 bus=0x04 dev=0x00 func=0x00

      [ 4.050912] i40e 0000:04:00.0: PCI-Express: Speed 8.0GT/s Width x8

      [ 4.080877] i40e 0000:04:00.0: Features: PF-id[0] VFs: 32 VSIs: 34 QP: 48 RSS FD_ATR FD_SB NTUPLE CloudF VxLAN Geneve NVGRE PTP VEPA

      [ 4.094861] i40e 0000:04:00.1: fw 4.33.31377 api 1.2 nvm 4.41 0x80001869 16.5.10

      [ 4.094864] i40e 0000:04:00.1: The driver for the device detected an older version of the NVM image than expected. Please update the NVM image.

      [ 4.339689] i40e 0000:04:00.1: MAC address: 3c:fd:fe:0c:cb:e2

      [    4.349612] i40e 0000:04:00.1: Query for DCB configuration failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_EPERM

      [ 4.349615] i40e 0000:04:00.1: DCB init failed -53, disabled

      [ 4.349684] i40e 0000:04:00.1: irq 150 for MSI/MSI-X

      ……

      [ 4.350710] i40e 0000:04:00.1: irq 207 for MSI/MSI-X

      [ 4.499464] i40e 0000:04:00.1: Added LAN device PF1 bus=0x04 dev=0x00 func=0x01

      [ 4.499469] i40e 0000:04:00.1: PCI-Express: Speed 8.0GT/s Width x8

      [ 4.529440] i40e 0000:04:00.1: Features: PF-id[1] VFs: 32 VSIs: 34 QP: 48 RSS FD_ATR FD_SB NTUPLE CloudF VxLAN Geneve NVGRE PTP VEPA

      [ 4.543425] i40e 0000:04:00.2: fw 4.33.31377 api 1.2 nvm 4.41 0x80001869 16.5.10

      [ 4.543427] i40e 0000:04:00.2: The driver for the device detected an older version of the NVM image than expected. Please update the NVM image.

      [ 4.989984] i40e 0000:04:00.2: MAC address: 3c:fd:fe:0c:cb:e4

      [ 5.000011] i40e 0000:04:00.2: Query for DCB configuration failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_EPERM

      [ 5.000014] i40e 0000:04:00.2: DCB init failed -53, disabled

      [ 5.000085] i40e 0000:04:00.2: irq 208 for MSI/MSI-X

      …..

      [ 5.001379] i40e 0000:04:00.2: irq 265 for MSI/MSI-X

      [ 5.228749] i40e 0000:04:00.2: Added LAN device PF2 bus=0x04 dev=0x00 func=0x02

      [ 5.228754] i40e 0000:04:00.2: PCI-Express: Speed 8.0GT/s Width x8

      [ 5.263716] i40e 0000:04:00.2: Features: PF-id[2] VFs: 32 VSIs: 34 QP: 48 RSS FD_ATR FD_SB NTUPLE CloudF VxLAN Geneve NVGRE PTP VEPA

      [ 5.277703] i40e 0000:04:00.3: fw 4.33.31377 api 1.2 nvm 4.41 0x80001869 16.5.10

      [ 5.277705] i40e 0000:04:00.3: The driver for the device detected an older version of the NVM image than expected. Please update the NVM image.

      [ 5.566417] i40e 0000:04:00.3: MAC address: 3c:fd:fe:0c:cb:e6

      [ 5.576408] i40e 0000:04:00.3: Query for DCB configuration failed, err I40E_ERR_ADMIN_QUEUE_ERROR aq_err I40E_AQ_RC_EPERM

      [ 5.576411] i40e 0000:04:00.3: DCB init failed -53, disabled

      [ 5.576487] i40e 0000:04:00.3: irq 266 for MSI/MSI-X

      ……

      [ 5.577839] i40e 0000:04:00.3: irq 323 for MSI/MSI-X

      [ 5.725374] i40e 0000:04:00.3: Added LAN device PF3 bus=0x04 dev=0x00 func=0x03

      [ 5.725383] i40e 0000:04:00.3: PCI-Express: Speed 8.0GT/s Width x8

      [ 5.755339] i40e 0000:04:00.3: Features: PF-id[3] VFs: 32 VSIs: 34 QP: 48 RSS FD_ATR FD_SB NTUPLE CloudF VxLAN Geneve NVGRE PTP VEPA

      [   67.004064] i40e 0000:04:00.0: removed PHC from p2p1

      [   67.040316] i40e 0000:04:00.0: Deleted LAN device PF0 bus=0x04 dev=0x00 func=0x00

      [   70.039865] i40e 0000:04:00.1: removed PHC from p2p2

      [   70.070096] i40e 0000:04:00.1: Deleted LAN device PF1 bus=0x04 dev=0x00 func=0x01

      [   73.240777] i40e 0000:04:00.2: removed PHC from p2p3

      [   73.279308] i40e 0000:04:00.2: Deleted LAN device PF2 bus=0x04 dev=0x00 func=0x02

      [   74.650315] i40e 0000:04:00.3: removed PHC from p2p4

      [   74.690215] i40e 0000:04:00.3: Deleted LAN device PF3 bus=0x04 dev=0x00 func=0x03

      [root@TBOS ~]#

       

      • From lspci| egrep -i "Network|Ethernet" we see the following output:
        • 04:00.0 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)
        • 04:00.1 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)
        • 04:00.2 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)
        • 04:00.3 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

       

      Please help ...

       

      Thanks