1 Reply Latest reply on Jun 30, 2017 11:50 AM by Al Hill

    Help needed to debug Intel HD Graphics 4600 GT2 driver (VEN_8086&DEV_0412) for Intel Haswell, Core i5-4690K 3.50GHz (Win XP SP3)

    aquila_xp

      Hi Intel Community,

       

      I really need help to make the driver for Intel Haswell HD Graphics 4600 GT2 DEV_0412 - Win XP SP3 to work with my hardware configuration.

      My current configuration:

      Desktop PC

      Motherboard: Gigabyte GA-Z97-HD3 revision 2.1 (SOCKET 1150) - Intel 9 Series Chipsets

      CPU: Intel Haswell Refresh, Core i5-4690K 3.50GHz (4th Generation Intel Core Processor Family)

      Graphics: Intel Haswell HD Graphics 4600 GT2 DEV_0412

      Display: Samsung SyncMaster 795DF, 17" (monitor CRT)

      OS: Windows XP Professional 32-bit Service Pack 3 (NT5x)

       

      Working drivers for Win XP SP3:

      network card driver - Realtek RTL8111F-VL

      Sata AHCI driver - driver modded by Fernando

      Intel Display Audio - driver v5.14.0.3090

      Realtek High Definilion Audio ALC887

      Display adapter - Video Controller (vga.dll, vga.sys) 5.01.2600.0000 of Win XP - 1024x768x32 resolution

       

      Drivers that does not work or unavailable:

      Intel HD 4600 HDMI video driver

      Intel HD 4600 HDMI audio driver

      Intel Haswell HD Graphics 4600 GT2 DEV_0412

       

      I tested these video drivers: 6.14.10.5441 (14.56.0.5441), 6.14.10.5445 (14.56.0.5445), 6.14.10.5449 (14.56.0.5449) in Windows XP SP3 and all resulted in BSOD. The dump files mentioned SYSTEM_THREAD_EXCEPTION_NOT_HANDLED with igxpmp32.sys.

       

      I know Intel discontinued support for Windows XP and latest drivers released for my graphic was in 2013. In the specification of these drivers mentioned above include support also for Device Instance ID: VEN_8086&DEV_0412.

      What can I do?