5 Replies Latest reply on Jun 28, 2017 1:25 AM by MartyG

    can't build to run 1st example test for "realSense" camera, r200

    M_Hawana

      Hello, I’m trying to install the “RealSense” camera to run one of the basic “hello world” example, but I’m running into build issues on my laptop. it seems to be a missing library... I would appreciate some help on this matter (PS: my ultimate goal is to use realSense with the NUC computer, but before I use it on that platform, I figured to try out the RealSense camera on my laptop first to bring up this simple program).

       

      I'm using visual studio 17, and I'm following the getting started document  https://software.intel.com/sites/default/files/Getting_Started_0.pdf

        • Section “run the app” …this is where I’m stuck... I can’t build the application.

      I get this error:

       

      Details:

      Severity

      Code

      Description

      Project

      File

      Line

      Suppression State

      Error

      LNK1104

      cannot open file 'libpxcutilsmd_d.lib'

      ConsoleApplication3

      C:\Users\mahawana\Documents\Visual Studio 2017\Projects\ConsoleApplication3\ConsoleApplication3\LINK

      1

       

       

      I'm not sure where to find this library, and why it's not part of the SW that I've installed.

       

      here is the info on my environment:

      • RealSense R200
      • My system is using Windows 10
      • I’m using visual studio 2017.
      • For my RealSense installation, I installed all the items on this page:

      https://software.intel.com/en-us/intel-realsense-sdk/download (R200 Camera driver, which includes the DCM, and installed all items in the SDK components download).

       

      thank you in advance.

        • 1. Re: can't build to run 1st example test for "realSense" camera, r200
          MartyG

          To use the RealSense camera with a new project in Visual Studio, you need to set up a RealSense development environment, depending on which language you are using (C++ or C#).  Have you completed this step, please?

           

          C++

          Intel® RealSense™ SDK 2016 R3 Documentation

           

          C#

          Intel® RealSense™ SDK 2016 R3 Documentation

          • 2. Re: can't build to run 1st example test for "realSense" camera, r200
            M_Hawana

            Hello MartyG,

            yes. I already completed this step before I sent out the request for help.

            • 3. Re: can't build to run 1st example test for "realSense" camera, r200
              MartyG

              I read your original message again and realized that you seem to be using the R200 camera with the 2016 R3 modular SDK.  R3 does not support R200, as support for that camera ended at the '2016 R2' SDK.  So you should uninstall R3, then download and install R2.

               

              Alternatively, the open source Librealsense SDK still supports the R200.

               

              You should be able to launch a download of R2 from this link.

               

              https://communities.intel.com/external-link.jspa?url=http%3A%2F%2Fregistrationcenter-download.intel.com%2Fakdlm%2Firc_na…

              • 4. Re: can't build to run 1st example test for "realSense" camera, r200
                M_Hawana

                Hello Marty,

                I followed your suggestion above, and un-installed the R3 software, and re-installed the R2 version you provided.

                Unfortunately, the problem remained the same.

                However, I solved the problem by noticing that the exact path to the missing filename is incorrect:

                     $(RSSDK_DIR)/sample/common/lib/$(PlatformName)/$(PlatformToolset)

                where, after following the setup steps and sourced the properties supplied in the release into visual studio, the $(PlatformToolset) resolves to a directory name of "v141" which does not exist.    

                 

                In looking at that directory, I noticed that there is a "v140" directory. Once I changed the last letter from 1 to 0, now I'm able to finish the build and run the "hello world"

                         C:\Program Files (x86)\Intel\RSSDK\/sample/common/lib/Win32/v141

                 

                while I'm now able to compile and run the above application, the above example does not really interact with the camera in any visible way. However, I wanted to run one of the demos that I can interact with. So, I chose to build the "face tracking & recognition". Unfortunately, when doing that, I run into this error build problem below:

                SeverityCodeDescriptionProjectFileLineSuppression State
                Error (active)E0393pointer to incomplete class type is not allowedConsoleApplication5c:\Users\mahawana\Documents\Visual Studio 2017\Projects\ConsoleApplication5\ConsoleApplication5\ConsoleApplication5.cpp73

                 

                my interaction with you caused me to ask these questions:

                              1) the documentation does not make any reference to the fact R200 camera is not supported by R3, and I could not find the R2 version of the SW on any of the sites I visited. I had to rely on your reply in this post to get that link. Why is this version not reflected on any of the websites used in the documentation ?

                              2) now that I'm using the R2 version of the software, to load the facial recognition demo, I found the website below, but all the SW on this site I think is related to R3 (as it says in the banner during the install step of each of the demo). So, how do I get this demo to be compatible with my R2 version of the software ?

                       I used this site for the demos:   Intel® RealSense™ SDK | Intel® Software  

                 

                your help is much appreciated. thank you.

                • 5. Re: can't build to run 1st example test for "realSense" camera, r200
                  MartyG

                  Thank you very much for your detailed information on how you got your installation working, which is sure to be helpful to others.

                   

                  1.  On the downloads page, the cameras supported are listed at the top of the Release Notes document that is opened by clicking on the Release Notes link in the Essentials module section.  You are correct however that this information is not visibly conveyed on the main downloads page, and you are certainly not the only person who has installed R3 without knowing that it will not work with their R200 camera.  So there may be a need for Intel to update the information on the page to make this non-compatibility clear.

                   

                  I also notice that there is a 'buy a camera' link for the R200 right at the bottom of the R3 download page, even though R3 cannot use the R200.  This is an item that should probably be removed.  the presence of the R200 camera driver on the page may also create confusion.  I will feed these thoughts back to Intel.

                   

                  2.  R3 was the first SDK to split the SDK into multiple modules to reduce the amount of disk space used, so people could only install the features that they needed for their project.  R2 has everything installed in one large program, so there is no need for individual modules to be supplied for it - with R2, you have all the features already installed with a single download.