9 Replies Latest reply on Jun 26, 2017 2:28 PM by Intel Corporation

    System Event log hundreds of Event id 4 after enabling optane

    XinteriX

      Here's my hardware I'm using:

       

      chipset: Z270 (Asus Mark 1 MB)

      cpu: 7700K (running at default specs)

      I have two m2 socket 3 w/ M Key, both are in PCIe mode

      One has the intel optane 32GB ssd running at x2

      It's accelerating an Sata Intel 168GB SSDSC2CT180CGN with firmware 300i which contain

      OS Windows 10 Enterprise version 1703 completely updated.

      The other M2 socket contain a Kingston HyperX 240GB ssd in PCIe mode running at x4

       

      Anyhow basically everything is setup as instructed for optane acceleration.

      Prior to enabling the optane the windows event logs has none of these errors which I'm about to describe.

      Once it's all enabled and the system rebooted, Everything appears to be functioning as expected except for the errors in the Windows system event log.

       

      Exact text of error message:

       

      File System Filter 'iaStorAfs' (Version 10.0, 2017-03-17T07:32:40.000000000Z) failed to attach to volume '\Device\Harddisk2\DR2'.  The filter returned a non-standard final status of 0xC000000D.  This filter and/or its supporting applications should handle this condition.  If this condition persists, contact the vendor.

       

       

      The errors are repeated hundreds of times with the only differences being which volume that it failed to attached to.

      '\Device\Harddisk1\DR1'

      '\Device\Harddisk2\DR2'

      '\Device\Harddisk1\DR1'. 

      '\Device\Harddisk3\DR3'

      ...

      ...

      ...etc.

       

      My system also contains 2 regular old SATA drives and 1 Samsung 500GB SSD (sata mode).

       

      Like I said the errors only appear after successfully enabling optane.

       

      Any thoughts on what's going on???

        • 1. Re: System Event log hundreds of Event id 4 after enabling optane
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello XinteriX,

          We understand you are seeing some event log errors after enabling Intel® Optane™ Memory. We would like to gather some information to better assist you, so could you please send us the log by following these instructions:

           

          - Step 1: Clear your system event logs.
           

          Clear.jpg

          Clear 2.jpg



          - Step 2: Reproduce the situation.



          - Step 3: Re-enter the event log and save the logs.

          Save.jpg


          Once you have the file please attach it to the thread. (Please use the advanced editor button).


          Also, we would like to know:

          -What issues are you experiencing in relation to this error? (Besides those IDs events)
          -Could you please also attach the Intel® Optane™ Memory logs (C:\Users\yourusername\Intel\Logs) - Please attach everything that is related to Intel® Optane™ Memory.
          -Go to this link and also attach the file to get the full system information.

          Regards,
          Nestor C

          • 2. Re: System Event log hundreds of Event id 4 after enabling optane
            XinteriX

            Hi,

             

            I cleared my system event log and reproduced the errors by simply launching the Intel Rapid Storage program via the small icon in the notification area.  In that small time period of probably about 10 seconds , there was over 55 of those events generated...

             

            The file you requested is attached.

             

            Thanks,

             

            Tim

            • 3. Re: System Event log hundreds of Event id 4 after enabling optane
              XinteriX

              As to your other questions, the system appears to be operating normally. If I hadn't looked in the event log, I never would known there was a problem.

               

              Attached is all the log files from both the intel directory in the root and the intel directory in my user folder.

              • 4. Re: System Event log hundreds of Event id 4 after enabling optane
                XinteriX

                And finally the generated file from the SSU tool.

                • 5. Re: System Event log hundreds of Event id 4 after enabling optane
                  XinteriX

                  You may notice in the intel log files that I had disabled optane and uninstalled the Intel RST package. It was my first attempt at correcting the problem. I had originally downloaded it directly from Intel and in an effort to fix the problem I thought maybe I should download it directly from Asus drivers for my exact model. Well it didn't work. After reinstalling I successfully once again got the optane volume setup and running, but still those errors.

                   

                  I was thinking maybe the issue is related to the other M2 socket that contains the Kingston, I was not able to put it into Sata mode because the bios only let's switch both M2 slots at once, can't have one running sata and the other PCIe.

                  • 6. Re: System Event log hundreds of Event id 4 after enabling optane
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello XinteriX,

                    Thanks for all the complete information you have shared. We'd like to review all of this and get back to you with suggestions for this event warnings. We'll keep you posted once we have an update.

                    Regards,
                    Nestor C

                    • 7. Re: System Event log hundreds of Event id 4 after enabling optane
                      XinteriX

                      Thought I would include some more details and some of things that I've tried.

                      The event error message does not refer any drive in particular or type, it's just completely random and I've seen Event messages identical to the one I described but occasionally it refers to a volume rather instead of the physical drive itself (see below).

                       

                      File System Filter 'iaStorAfs' (Version 10.0, 2017-03-17T07:32:40.000000000Z) failed to attach to volume '\Device\HarddiskVolume14'.  The filter returned a non-standard final status of 0xC000000D.  This filter and/or its supporting applications should handle this condition.  If this condition persists, contact the vendor.

                       

                      Also have seen it refer to '\Device\Mup'.  From further examining event logs I've noticed that all my PC's other 'file system filters' are loading and working properly except for Microsoft's Windows Cloud Files Filter Driver (CldFlt)  which won't even load. Also the service 'User Data Access' won't start . Maybe a third party driver is preventing iaStorAfs from ooperating normally. I'm pretty certain the issue is not hardware related. I installed on a freshly installed Windows which I completely updated afterwards. The only other software I've added is Kapersky Total Security, Office 2016, and a few games using MS store.

                      • 8. Re: System Event log hundreds of Event id 4 after enabling optane
                        XinteriX

                        Ok so here's what I did to fix the problem. Although I don't know why it worked.

                         

                        I followed the directions given to me in another thread (How to access an Optane enabled SATA from within WinPE) and was able to inject the F6 floppy drivers into a Windows 10 recovery environment iso (Gandalf's Win10 x64) which allowed me to access the files using WinPE. After noticing that the errors were not occurring while running in the Recovery Environment, I decided to copy couple drivers. I copied the iaStorAfs.sys and the iaStorAV.sys files from the WinPE's system32\drivers directory and replaced the ones in the drivers directory of my Windows 10 OS with the F6 one's. I rebooted into normal OS and everything working fine, no errors anymore.

                        • 9. Re: System Event log hundreds of Event id 4 after enabling optane
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hello XinteriX,

                          Thank you for sharing your fix, we are positive that this may help some other with this situation.
                          As of why it worked, we believe that the files from the image could be corrupted and that's why it worked fine when you "injected" those manually.

                          Thanks again and we hope you have a nice week.

                          Regards,
                          Nestor C