4 Replies Latest reply on Jun 26, 2017 8:20 AM by cvare

    NUC DN2820FYKH & Windows 10 1703 (Creator's Update) Error 0x80070057

    JamesU

      Hello,

       

      I have a NUC DN2820FYKH that was running an activated copy of Windows 10 (1607, 64bit).  I allowed Windows Update to install the Creator's Update (1703), and upon completion, I get this error when trying to perform Windows Updates now (Error 0x80070057).

       

      I left the unit on for a week, hoping it would resolve itself and retry, but it never improved.

       

      So tonight, I did a fresh install of Windows 10 1703 64bit from a USB Stick made with the Media Creation Tool from Microsoft.  The install went painlessly.  I then added the necessary/latest drivers for Chipset, Video, WiFi, etc. until all the hardware devices were discovered in Device Manager.  I now get the same error in Windows Update (Error 0x80070057), but it is also now compounded by the same error showing up in Windows Activation, saying that Windows cannot reach the Microsoft Activation Servers, and my install is no longer activated.

       

      I did a little web searching prior to posting, and I found another user with the same comments on the same NUC system in Windows 10 forum on the web.

       

      I am using the latest BIOS 0057, and it is set to Windows 8/10 compatibility.

       

      Thanks

        • 1. Re: NUC DN2820FYKH & Windows 10 1703 (Creator's Update) Error 0x80070057
          lw1948

          Hello JamesU

          I did also web research and founded possible solution for the problem you have described:  After installing creator update, NUC failed with 0x80070057 on Win - Microsoft Community

          You will need to use Intel Integrator Toolkit  to change in Bios system manufacturer and the system product.

          The all process is well described in the referenced post.

           

          And finally may be Intel will update bios to meet Windows 10 requirements?

           

          Hope this will fix this error. 

          Leon

          • 2. Re: NUC DN2820FYKH & Windows 10 1703 (Creator's Update) Error 0x80070057
            JamesU

            Thanks Leon.

             

            This did fix the issues.  The NUC is now is activated and can run Windows Updates (again).  I'm going to elaborate a little on the solution, just so folks reading here can get an idea of what this entails.

             

            1) Download the Intel Integrator Toolkit.  At the time of this writing, the current version was 6.1.6.

            2) Unzip the package and Copy the 'ITK6.efi' file to a FAT32 formatted USB Flash Drive.  For ease of typing and getting the following commands correct the first time, I put the two commands needed in a .txt file and named it 'commands.nsh'.  Those commands, for me, were:

             

            ITK6.efi -s -t system -f manufacturer -v "Intel Corporation"

            ITK6.efi -s -t system -f product -v DN2820FYKH

             

            This .nsh file runs like a batch file in the EFI Shell environment.  I copied this .nsh file I made to the USB Flash Drive, too.  Put the USB Flash Drive in the NUC (if you were doing this on a different machine like I was).

            3) Reboot the NUC and hit F2 to get into the BIOS Settings.  In my case, the NUC runs the BIOS default settings, so I had to dig through the Boot Configuration stuff and find the switch to enable the EFI Shell as a boot option.  It is OFF by default.  Turn it ON, save and exit.

            4) At the next boot cycle, choose F10 for the boot options to appear.  You should see the EFI Shell as a choice.  Pick it.

            5) You'll be presented with a funny Yellow and White text, DOS-like environment.  You need to navigate to the USB Flash Drive.  For me, this showed up as 'fs4', so at the command prompt I typed 'fs4:' to change to that drive.  I then typed 'ls' to list the files and make sure I was on the USB Stick.  Once confirmed, I typed the name of the .nsh file and it executed the two stored commands - both returned an acknowledgement that they executed successfully.  Then I typed 'exit' to get out of the EFI Shell, and the unit rebooted.

            6) Once back in Windows 10, I ran Windows Update successfully, and I could see the OS was Activated.

             

            It would save customers a lot of effort if Intel would update the BIOS to fix this.  In my opinion, this fix goes beyond the comfort level of an average user.

             

            Thanks,

            James

            2 of 2 people found this helpful
            • 3. Re: NUC DN2820FYKH & Windows 10 1703 (Creator's Update) Error 0x80070057
              cvare

              I have re-created this and have opened a bug fix request.

               

              I'll let you know when I have a status update.

              • 4. Re: NUC DN2820FYKH & Windows 10 1703 (Creator's Update) Error 0x80070057
                cvare

                Due to this model being end of life, this won't be fixed, but I will post these instructions as a sticky on the appropriate page.  Thanks for the heads up JamesU.

                1 of 1 people found this helpful