5 Replies Latest reply on Jun 26, 2017 6:09 PM by Intel Corporation

    Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?

    Corin

      Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?

       

      I install Intel 8260 Bluetooth driver 19.60.0.3, 4/7/2017 on Windows 10 RS1 with New KB

      I also disable "Allow the computer to turn off this device to save power", however the response time is still over 1500ms.

       

      I try to use Windows 10 RS1 Pure OS with this driver, look like response time will within 100ms always.

       

      My question, does anyone know where registry or setting I could modify let Intel Bluetooth could speed up or not go to sleep mode?

        • 1. Re: Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Corin,

          We understand that you're experiencing some latency issues with your Intel® Dual Band Wireless-AC 8260. In order to better assist you we would like some more information:

          1. What tool or method are you using to measure your Bluetooth* response time?
          2. Is this an OEM installed wireless adapter or an upgrade part?
          3. Is there a reason behind using Windows® 10 RS1 as opposed to the latest release of the OS?
          4. Have you engaged your computer's manufacturer in regards to this concern?

          Additionally, please download and run the Intel® System Support Utility. This application will run on your system and save a report containing your current hardware configuration and settings. You may then attach this file by switching over to the "advanced editor" while replying.

          We look forward to hearing back from you.

          Best regards,
          Carlos A.

          • 2. Re: Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?
            Corin

            Hello Carlos

             

            Thanks your question,

             

            1. What tool or method are you using to measure your Bluetooth* response time?

             

            I developed a sample app to get response time. Because My Bluetooth device is support Bluetooth Serial Port.

            So I captured the start time at Send command to device and captured the receive time after my app got response from Bluetooth device.

            and then use receive time - start time to get response time.

             

             

             

            2. Is this an OEM installed wireless adapter or an upgrade part?

             

            I don't know this question, but Intel AC 8260 combo card is installed in unit. and I used card to connect Bluetooth device.

             

             

            3. Is there a reason behind using Windows® 10 RS1 as opposed to the latest release of the OS?

             

            I tried TH2, RS2 also has this problem. Only Pure RS1 and no install Microsoft KB without this problem.

            The reason is I need response time < 100 ms, at least <1000ms

            I have tried another USB dongle Bluetooth device without this problem.

            Only Intel 8260 will get this response time over 1000 ms, even more than 2000ms

            So that's why I post question here there is anyone get same problem before.

             

            4. Have you engaged your computer's manufacturer in regards to this concern?

             

            YES, but I have tried another vendor NB, it has same problem.

            • 3. Re: Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Corin,

               

              Thank you for your response.

               

              We understand you need assistance changing the settings on your Bluetooth* behavior so that it reacts faster or does not allow the connection to idle or sleep, which increases the response time between your app and device.

               

              Please keep in mind that some settings are not controlled by our driver, but by Windows® 10. Because of this, we can't guarantee we'll be able to provide a solution.

               

              While it's possible that another poster may be able to share suggestions in regards to this, our Resource and Design Center may be better equipped to answer your questions.

               

              We're currently looking into this issue. If we have any more questions or suggestions we'll update your thread.

               

              Best regards,
              Carlos A.

              • 4. Re: Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello Corin,

                Aside from disallowing your computer to turn off your Bluetooth* module, we have the following recommendations for you:

                1. Enable Automatic Bluetooth Services.
                    1. Open the run box (windows* key + r), type "services.msc" and press OK.
                    2. Locate the "Bluetooth* Support Service."
                    3. Right click on this service and choose Properties.
                    4. Look for the "Startup type" entry under General, set this to "Automatic."
                2. Modify your power plan
                    1. Right click on the start menu icon, select Power Options off the pop up list.
                    2. Click on the option to "Change plan settings" next to your current power plan.
                    3. Select to "Change advanced power settings," this will open a Power Options dialog box.
                        1. Note: You may need to repeat the following steps manually as settings are independent to each power plan.
                    4. USB settings +> USB selective suspend setting +> Set both "on battery" and "plugged in" to disabled.
                    5. (Optional) Wireless Adapter Settings +> Power Saving Mode +> Set both to "Maximum Performance."
                    6. (Optional) PCI Express* +> Link State Power Management +> Set both to "Maximum Performance"
                    
                We hope these steps help. If not, do let us know.

                Best regards,
                Carlos A.

                • 5. Re: Why,Intel,8260,Bluetooth,connect,to,device,via,PP,,the,response,time,will,over,themselves,~,B2B,after,idle,over,20,sec?
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hello Corin,

                  We have not heard back from you in a while, has you issue been resolved?

                  Best regards,
                  Carlos A.