3 Replies Latest reply on Jun 15, 2017 12:28 PM by Chang1

    How to SSH to the Euclid through it hotspot?

    Chang1

      I tried to SSH to 10.42.0.1, but port 22 connection refused, which I think was caused bu the web interface. I wonder whether there is a way to turn off the web interface temporarily to allow SSH?

        • 1. Re: How to SSH to the Euclid through it hotspot?
          MartyG

          This error message is not unique to Euclid.  It is associated with Linux, and my research indicated that there can be a number of causes, including:

           

          1.  Port 22 is blocked by your firewall and you should set up a rule in your firewall to allow that port if this is the case.

          2.  There is an IP conflict, with another device that is already claiming Port 22.

          3.  The device you are using to make the connection is not listening for port 22 and so cannot access it.

          4.  You should be using a static setting on your network adapter instead of DCHP.

          5.  SSH Server is not installed, only SSH Client.

           

          Googling the term 'port 22 connection refused' without mentioning euclid specifically may yield you further leads to follow up on, assuming there isn't an easy answer someone on the forum can provide.  Good luck!

          1 of 1 people found this helpful
          • 2. Re: How to SSH to the Euclid through it hotspot?
            Sheikware

            Hi,

             

            SSH is not enabled by default. You need to install openssh-server (sudo apt-get install openssh-server, assuming you connect to Wifi) and then restart ssh service (systemctl restart ssh).

             

            These tasks can be done over VNC, or by running in local mode (monitor and keyboard).

            2 of 2 people found this helpful
            • 3. Re: How to SSH to the Euclid through it hotspot?
              Chang1

              Great! Thank you both very much.

              I did this:

              sudo apt-get update
              sudo apt-get install openssh-server
              sudo ufw allow 22

              It works straight away.