11 Replies Latest reply on Jul 19, 2017 1:51 PM by Flying_Kiwi

    Asus Maximus Viii Impact MB Ethernet Issue

    Grizzledmoe

      Hi Everyone, Im trying to track down an issue with my LAN port,,My motherboard uses a Intel i219V controller and this is a new htpc mini itx build.

      So far Ive looked over a few things such as downloading the latest drivers for the chipset and updating the bios on the asus board,,from the very first post

      I have been skeptical of a hardware issue due to a lack of any port activity via the normal lights one expects to see from the ethernet port, in my limited experience

      I usually see a light in or near the port no matter if it is active or not, this boards port has been silent of any lights so far,,however I thought i might run this by the

      community here just in case someone else might have encountered a lan issue with this controller or a problem with Asus ROG products in respect to the network

      controller, i am open to suggestions and have a fair amount experience with PC hardware and sometimes do repairs for friends and family.

       

      any troubleshooting suggestions ? I hope maybe I would be so lucky as to have missed an option in the bios setup, but I havent looked into that yet,

      Wireless on the asus board appears to work well and uses a qualcomm Atheros Dual band adapter and antenna. So far it performs well in any part of my home

      but I prefer old school wired networking if at all possible,

       

      This was motherboard number 2 as the first board came with some bent pins and had signs of being an open box,,this board however came packaged sealed and everything

      checked out ok, first post went well after breadboarding it just to confirm it wasnt DOA,,anyone who has built into a small form factor case knows how much trouble this can save you.

      So is the i219v have any current issues that might cause a ethernet port to appear dead ?

        • 1. Re: Asus Maximus Viii Impact MB Ethernet Issue
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Grizzledmoe,

          Thank you for posting in Wired Ethernet Community.

          You can try to use the Diagnostic utility (DIAGS.EXE) that's included in the Administrator Tools for Intel(R) Network adapters to further test your I219-V. This utility provides capability to test the adapter, view the configuration and identify the adapter by blinking LED.

          Download link:
          https://downloadcenter.intel.com/download/4237/Ethernet-Administrative-Tools-for-Intel-Network-Adapters?v=t

          Filename = PROADMIN.exe

          Once you've downloaded the file, kindly extract it to your desired folder. The DIAGS.EXE is located in PROADMIN\APPS\TOOLS directory. Copy the DIAGS.EXE to your MS-DOS bootable USB key and boot up your system.

          Kindly refer to diag.htm located in PROADMIN\APPS\TOOLS\DOCS folder for details.

          Hope this helps.

          regards,
          Vince

          • 2. Re: Asus Maximus Viii Impact MB Ethernet Issue
            Grizzledmoe

            Hi Vince, thank you for taking a moment to help me track down this issue, i tried running the diagnostic tool and it gets to no flashing LEDs during the indentify portion or option i should say, running test appears to be on a endless loop when after 15 minutes it didnt appear to progressing really,,it states test 1 of 1 pass but the port appears dead and events continue to show this item has a problem cannot start code 10, uninstalling the device in device manager and restarting gets me back to  caution sign next to the adapter controller i219v and updating the drivers failed after download due to device cannot start. Another bad board perhaps ? after going through 2 of asus more pricey motherboards, im really starting to wonder how high their failure rates are for hardware quality control, as any board costing close to 300 bucks should least have a working Lan port, makes me wonder if they test them or just ship as is. I suppose i could try  a manual driver install maybe but ive been looking into this awhile and i may just change out this board for a gigabyte with slightly less bells and whistles and send the Asus maximus viii impact back with an explanation of how their failed product impacted any further hardware purchases i will make when building or recommending components, if anything else comes to mind, please feel free to suggest it,,,thx

             

            Grizz

            • 3. Re: Asus Maximus Viii Impact MB Ethernet Issue
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Grizz, when you run the "test adapter" option, does it pass all the tests (Device Registers, FIFOs, EEPROM, Interrupt and Loopback Test(s))?

              I've tried the diagnostic utility on I219-V (different Asus board) and the LAN LED flashes during the "identify adapter" option. The adapter also works properly in Windows operating system.

              Code 10 error would normally indicate the need to install driver or there's hardware problem. If you've tried to install the latest driver and still encounters "This device cannot start" issue. I'd suggest to contact Asus for further troubleshooting.


              regards,
              Vince

              • 4. Re: Asus Maximus Viii Impact MB Ethernet Issue
                Grizzledmoe

                Hi Vince, yea the test doesnt really appear to complete in my opinion it seems to just be searching as you can see the progress dots and the small icon working but this appears to go on indefinitely,After multiple driver installations im fairly sure this is just a bad port, I could be wrong but ive tried installing those drivers using both the installer and manual methods,,the one thing that puzzles me is how this connection is listed as (connection)2 like this is some duplicate,, i find that a bit odd to be honest, I normally dont see anything in windows listed that way unless i have a duplicate folder or something and certainly not in my ethernet connections on any of my other builds so far,

                 

                I asked for help in the Asus forums as well using the asus rog site but that tends to be a more gaming minded community and tech support and knowledge is a bit harder to pin down,some replies were less helpful than i would have liked but a lack of more in depth troubleshooting knowledge is something to be expected in some forums. I will try swapping out the motherboard sometime soon,,but since this is a htpc small form factor case, it isnt a quick swap out, those mini itx designs are nice until you need to go back in and then become a bit of a pita tbh, since i get no port activity via lights,,I think this is hardware,,the Maximus VIII impact comes with a easy to read code sequence but i havent looked up those parameters yet for any telling codes as everything else appears to work fine and after going through the rma process on the first board I was hoping to avoid that a second time if possible, Im fairly certain the extra motherboard i have (Gigabyte H270N) should be a good replacement as it was ordered to also work in this build in the event of problem just like this one. That code 10 is really too generic, I wish windows was more specific with such things,

                 

                thx for your reply

                Grizz

                • 5. Re: Asus Maximus Viii Impact MB Ethernet Issue
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Grizz, In case you would encounter the (connection)2 on your new board, you can try out the workaround found in this thread - https://communities.intel.com/thread/115431.

                  Please let us know if you still need assistance regarding I219-V.

                  regards,
                  Vince

                  • 6. Re: Asus Maximus Viii Impact MB Ethernet Issue
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi Grizz, 

                    Please let us know if you still need assistance regarding I219-V.

                    regards,
                    Vince

                    • 7. Re: Asus Maximus Viii Impact MB Ethernet Issue
                      Flying_Kiwi

                      Hi Grizzledmoe,

                       

                      One other thing I'd try (which you shouldn't have to but which may help) is to disable the WiFi Adapter in the motherboards BIOS when you want to use the wired Ethernet port. The reason why I suggest trying this is simply based on my experience with Windows 10 and multiple network connections. I have the Asus Z170 Pro Gaming board with Win 10 but it only has the one Ethernet port (I know what you mean about the Asus community BTW - I too came here as first preference) - I started the Thread Vince linked to. I also have a Windows 10 equipped tablet which has both a WiFi and Cellular data connection (neither of which are Intel BTW) but I find they don't like working alongside each other and I often have problems getting the Cellular/Mobile connection to work reliably and display properly in Win10 even when the WiFi is turned off in Win 10. Turning off the WiFi capability in the BIOS eliminates one possible conflict in network related (or other eg power) resources and I always believe in simplifying things as much as possible to try and get to the bottom of problems.

                      • 8. Re: Asus Maximus Viii Impact MB Ethernet Issue
                        Grizzledmoe

                        Hey thx for replying, yea I might try that at some point in the future, although im fairly certain this is a hardware issue it couldnt hurt to try and yes Windows 10 can really be buggy with networking and has bit me once or twice through updates and such, even getting so bad as requiring a restore at one point on my older machine. The Spare motherboard i have,,a Gigabyte H270N has 2 ports supposedly for better bandwidth management and it too uses intel tech but I think it runs a different controller setup/drivers than the i219,,I haven't gone as far as changing out the boards yet., but Im not very impressed with the asus impact mb so far, considering it was over twice the cost of my spare and doesnt add alot bells and whistles that the cheaper board doesn't have. I have experienced some wireless networking issues too here lately where the asus fails to connect after a restart I can usually resolve them but still find windows 10 annoyingly bad at networking in general, but then again i run alot insider builds and i expect a bug now and then. If I get around to replacing my MB with the spare, hopefully the duel port design will ensure at least one working port for the sake of bad luck,,lol wich is pretty much how i ended up here,,I will be back to update with the results. ty

                        • 9. Re: Asus Maximus Viii Impact MB Ethernet Issue
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hi Grizz, in case you haven't tried loading the NIC driver that's included in the driver DVD of your ASUS board, please try it out. 

                          regards,
                          Vince

                          • 10. Re: Asus Maximus Viii Impact MB Ethernet Issue
                            Grizzledmoe

                            Ok Vince ill give that a shot tomorrow pretty sure i kept that dvd or got another on the second one after the return,,im curious though what made you think of that,, well it will only take a moment to try I will let you know if it works. Went back to Win 7 on this old sandybridge unit im on now this build has been running 24/7 at a pretty good clip for over 6 years now i think, hasent had more than a good dusting needed during that time and the old girl was just a cheap old atx acer i threw a few parts in,, back then i remember thinking how much that reminded me of slipping a hemi into old junkers or cramming 350s into those little opals well im an old cuss from another time but fast is fun no matter what your running.

                            • 11. Re: Asus Maximus Viii Impact MB Ethernet Issue
                              Flying_Kiwi

                              Also before assuming its an Intel released driver issue, some OEMs do use LAN hardware provided chipsets in 'non-standard' ways so the OEMs own driver MAY be the only truly compatible solution. My tablets WiFi drivers do have OEM specific customised hardware ID values so its quite common. As you have an IPX/Small form factor board, this is prime territory for OEMs to customise things to suit their needs.

                               

                              How did you get on with testing the wired LAN while the WiFi is disabled in the BIOS? Have you also gone to 'non-insider' builds of Win10? I used to be an 'insider' but after some time in the 'fast ring' decided things just weren't stable enough for me and I went back to just release versions. Again, these are some steps to take in order to help simplify things and narrow down the culprit so the 'results' of such tests will be useful.