2 Replies Latest reply on Jun 13, 2017 7:10 PM by Jared-B

    Iris 5100 driver update fails for Macbook (late 2014 model)

    SDGundamX

      Hi,

       

      As the title says, I've got a late 2014 Macbook (bootcamped with Win 7 64-bit) that I haven't updated drivers for since purchase.  I recently ran into a problem while playing a video game that, according to the game support forums, could easily be solved by updating my graphics driver.  So I began trying to update the drivers for the onboard Iris 5100 graphics chip with the latest release drivers (specifically Ver. 15.40.34.4624. which was released March of this year).  The problem is, every time I tried to update, the update failed with the error message "This computer does not meet the minimum requirements for installing the software."  I've tried updating from the .exe, from the .zip, and from the Intel Driver Update Utility (which recommended 15.40.34.4624) and get the same message every time.

       

      Oddly, I WAS able to update to an older driver from 2015 (the original driver I had was from 2013).  This fixed the video game problem I was having but I am a bit uneasy at the fact that I cannot update to the latest version of the Iris drivers.

       

      Any ideas on how to update to the latest drivers? Or am I stuck with the 2015 drivers forever? Thanks in advance for your help.

       

      Message was edited by: J B Added OS info

        • 1. Re: Iris 5100 driver update fails for Macbook (late 2014 model)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello SDGundamX,
           
          I’m sorry Apple has requested that all questions regarding Apple systems and software be addressed directly with Apple support. I recommend checking the link below for troubleshooting assistance on your Apple computer:
           
          http://www.apple.com/support/imac/intel/   
           
          http://www.apple.com/support/mac/n
           
          https://www.apple.com/support/macbook/
           
          http://www.apple.com/support/macmini/
           
           
          Regards,
           
          Ivan U.
           

          • 2. Re: Iris 5100 driver update fails for Macbook (late 2014 model)
            Jared-B

            Well, I kinda understand where Apple is coming from since they have modified the chip for use with the Mac.  On the other hand since Intel is the actual chip manufacturer it does seem a bit silly not to provide support to all who use it in their computers.

             

            Anyways, here is the actual solution for anyone who stumbles across this thread looking for answers.  Although it is counter-intuitive, the Windows drivers for a boot camped Macbook need to be updated from within OSX.  You will need a USB formatted in FAT32 in order to update the drivers.  Here's a step-by-step of what you need to do:

             

            1) Boot your Macbook into OSX.

            2) Use Finder to find the program "Boot Camp Assistant" (by default it should be in your "Utilities" folder)

            3) Run Boot Camp Assistant and only check the box entitled "Download the latest Windows support software from Apple." Leave the other boxes unchecked.

            4) Stick you formatted (FAT32) USB into a USB port on your Macbook.

            5) Click "Continue."

            6) Select "Save a copy to an external drive," choose your USB from the dropdown menu, and click "Continue."

            7) Once the drivers are downloaded and saved to the USB, reboot your Macbook into Windows.

            8) Open your USB in Windows and select and run "Setup.exe."

            9) Select the option to repair the drivers (not remove)

            10) Reboot your computer after the drivers install

             

            It should be noted that Apple drivers tend to lag behind the releases by Intel and other manufacturers, sometimes by months and in rare cases by years.  In most cases, there are ways of tricking your Macbook into using the original manufacturer drivers but I don't recommend it as it can cause stability problems and is something only advanced users should attempt.