6 Replies Latest reply on Jun 9, 2017 8:38 AM by FGT

    Not able to upload sketched to Galileo from Arduino IDE

    rahulmodi8812

      Hi there,

       

      I am struggling to upload sketch to the Galileo Gen2 from Arduino IDE 1.6.x version.

       

      The board and the port are correct and I have already verified that. Port is : /dev/ttyACM0

      I am able to login to Galileo via ssh using root user but not able to upload sketch.

       

      The below error I am getting:

       

      sketchuploaderror.png

       

      Please help. I will really appreciate it.

        • 1. Re: Not able to upload sketched to Galileo from Arduino IDE
          FGT

          Hi rahulmodi8812,

           

          I think one of the problems maybe due to the old Arduino IDE version you are using. Please let us know if you have followed the step-by-step guide starting at IoT - Step 1: Make a bootable micro SD card | Intel® Software. Also, please tell us if you are going to use the Intel Galileo Gen2 either with or without SD card.

           

          Fernando.

          • 2. Re: Not able to upload sketched to Galileo from Arduino IDE
            rahulmodi8812

            Hi Fernando, Thanks for your reply.

             

            I had followed the step-by-step guide to make bootable SD card. But I was getting different errors that time hence I removed Yocto image from Galileo and installed Debian on it.

             

            After installing Debian on Galileo I was able to upload sketches to Galileo with the same IDE (1.6.0) and the sketches were working as well. This activity I did around a month back. But 2 days back I uploaded sketches to  Arduino 101 board on my system with the same port /dev/ttyACM0 and got succeed. But today I am trying to upload sketch on Galileo with the same port but bot able to do.

             

            Now, Arduino is assigned to the new port /dev/ttyACM1 and I confirmed that as of now Arduino 101 is working successfully on the port /dev/ttyACM1 and Galileo connected to /dev/ttyACM0 but not able to upload sketches.

             

            What should I do ? upgrade Arduino IDE ?

             

            And, yes, I am using Galileo with SD card.

            • 3. Re: Not able to upload sketched to Galileo from Arduino IDE
              FGT

              rahulmodi8812 wrote:

               

              Hi Fernando, Thanks for your reply.

               

              I had followed the step-by-step guide to make bootable SD card. But I was getting different errors that time hence I removed Yocto image from Galileo and installed Debian on it.

               

              After installing Debian on Galileo I was able to upload sketches to Galileo with the same IDE (1.6.0) and the sketches were working as well. This activity I did around a month back. But 2 days back I uploaded sketches to Arduino 101 board on my system with the same port /dev/ttyACM0 and got succeed. But today I am trying to upload sketch on Galileo with the same port but bot able to do.

               

              Now, Arduino is assigned to the new port /dev/ttyACM1 and I confirmed that as of now Arduino 101 is working successfully on the port /dev/ttyACM1 and Galileo connected to /dev/ttyACM0 but not able to upload sketches.

               

              What should I do ? upgrade Arduino IDE ?

              Hmm... I'd not change the IDE if it worked fine before... did you set the board as Intel Gailieo Gen2 besides changing the port? (I use to forget changing that detail...)

               

              HTH,

               

              Fernando.

              • 4. Re: Not able to upload sketched to Galileo from Arduino IDE
                rahulmodi8812

                Yes, I changed the board as well.

                As in the attached image, it is showing "Galileo Gen2" in the right bottom.

                • 5. Re: Not able to upload sketched to Galileo from Arduino IDE
                  rahulmodi8812

                  Hey Fernando,

                   

                  The issue is solved !

                   

                  I was running Galileo not with Yocto image but with Debian OS and every time I was trying to upload the sketch while SD card inserted in.

                   

                  I just removed the SD card and restarted Galileo by switching on/off power supply then I was able to upload the sketch in once only.

                   

                  From the above finding it infers that the sketches will not upload if you are booting Galileo with Debian OS or other than Yocto image.

                   

                  Thanks for your time on this !

                  • 6. Re: Not able to upload sketched to Galileo from Arduino IDE
                    FGT

                    You're welcome,

                     

                    It's good to know you have your system up&running,

                     

                    Fernando.