1 Reply Latest reply on Jun 7, 2017 3:08 PM by Intel Corporation

    Windows 7 x64 - USB 3.0 Drivers Don't Load Properly (Z97 Chipset)

    bobrocks95

      Hi,

       

      My USB 3.0 Drivers don't load properly most of the time.  I will boot into Windows with no functioning mouse or keyboard.  From what I can tell, this is a problem with the USB 3.0 driver, given my results with my motherboard's xHCI modes below.

      At the same time only one of my front USB ports works now.  I suppose that could be pin header related, since I rearranged the wiring for the front panel connector, but given my other USB problems it could very well be related.

       

      I have 4 xHCI mode options in my BIOS, and as I understand them, this is how each works (please correct me if I'm wrong):

       

      • Auto-               POST/BIOS always use USB 2.0 mode, 3.0 driver loaded when OS loads.
      • Smart Auto-     POST/BIOS will use USB 3.0 if the OS has loaded the 3.0 drivers previously
      • Enabled-          USB 3.0 drivers always loaded, including during POST/BIOS
      • Disabled-         USB 3.0 disabled completely, all ports run in 2.0 mode

       

      On disabled, things work as expected sans the non-working front port.  On enabled, nothing works at all, implying a problem with my USB 3.0 driver.

       

      On auto, USB works during POST and then stops working once Windows loads, and on Smart Auto, if I completely unplug my power supply, and then boot Windows TWICE, USB 3.0 seems to work.  On the first boot Windows seems to fail to load the drivers, it's always on the second boot that it works.  I'm not sure if the ports are running at 3.0 speed, or if maybe a failsafe kicks in on the second boot and they're running in 2.0 mode.

       

      Here is a picture of my device manager after a second Smart Auto boot that would seem to imply the USB 3.0 xHCI drivers are at least working to some degree (though I have an unusually large number of USB devices listed, which seems concerning)

      Device Manager.png

       

      What I've done already:

      • Made sure my motherboard was on the most recent BIOS version (version 2081)
      • Installed the most recent chipset drivers provided by ASUS for my motherboard (https://www.asus.com/us/Motherboards/Z97A/helpdesk_download/) (V10.1.1.7)
      • Installed the most recent USB 3.0 drivers provided by ASUS (V3.0.1.41)
      • Tried installing the most recent USB 3.0 drivers available from Intel (V5.0.3.42) ("4th generation Intel(R) Core(TM) Processors" includes Haswell, right?)

       

      What else can I try?

      Is there a good way to cleanly wipe the chipset and USB 3.0 drivers and start fresh to see if that helps?

      Should I get the latest chipset and USB 3.0 drivers straight from Intel instead of from my motherboard manufacturer?

       

      Relevant System Specs:

       

      Windows 7 Ultimate 64-bit

      ASUS Z97-A

      i5 4690K

       

      Thanks in advance.