8 Replies Latest reply on Aug 17, 2017 10:29 AM by A-A-Rawn

    Cannot connect to Euclid via browser

    ianholl

      Initially I could connect to Euclid via my browser after connecting to the Euclid hotspot.  Yesterday I connected Euclid to my monitor and booted into Ubuntu desktop and poked around the OS (did not make any changes to the system).  This morning when I boot up the Euclid I do not get the chimes sound indicating Euclid is ready.  However I can connect to the Euclid hotspot and browse to 10.42.0.1.  However all I see is the spinner and loading Scenarios...

       

      Did going into the Ubuntu desktop break something and if so how do I fix it.  If I need to reset/reinstall is it possible to download an ISO of the original software image or is there a recovery procedure.

        • 1. Re: Cannot connect to Euclid via browser
          amitmoran

          Hi,

           

          Connecting the device via HDMI isn't breaking it.

           

          does the problem persists after restart?

           

          Thanks,

          Amit

          (Intel)

          • 2. Re: Cannot connect to Euclid via browser
            ianholl

            Yes the issue persists after restarting, I am no longer getting the startup sound when the Euclid boots up.  Playing around some more I am able to get to the page on the web app that shows memory and CPU utilization and it looks like there is no data being sent from the device for the page (the gauges don't move anymore).  I’m guessing that some other service needed by the web app is not starting up at boot time.  Unfortunately I have no idea what is supposed to be starting up or why it’s not starting.

             

            If you can point me in the direction of what logs or what services need to be running that would be a great start.  Unfortunately there is not a huge amount of documentation on the device available right now.

             

            Finally, should there be a need for me to factory reset the device (now or in the future) how would I go about doing that and getting all the necessary software.

            • 3. Re: Cannot connect to Euclid via browser
              amitmoran

              Please start a terminal and run:

              sudo services oobe-init restart-oobe

              and share the output.

               

              for the image, we will publish soon.

              • 4. Re: Cannot connect to Euclid via browser
                ianholl

                This is the combined output of stdout and stderr.  I added bold to illustrate a couple of errors that seem to point to a malformed url.

                 

                The line 'Couldn't find an AF_INET address for [http]' continues to be reported on stderr forever until I kill off the process.

                 

                Thanks for the help.

                 

                Ian

                 

                sudo service oobe-init restart-oobe

                 

                Stopping ..

                Error: ERROR: Unable to communicate with master!

                roscore: no process found

                rosmaster: no process found

                Stoping startup

                Stopping service: /intel/euclid/oobe-services/startup_services/S2WebServer/stop.sh

                Stopping service: /intel/euclid/oobe-services/startup_services/S6FeedbackServer/stop.sh

                Error stopping: sigkill to standalone_nodelet

                ERROR: Unable to communicate with master!

                ERROR: Unable to communicate with master!

                Done stopping service

                Stoping monitor

                Stopping service: /intel/euclid/oobe-services/monitor_services/S0ConnectionMonitor/stop.sh

                Done stopping service

                Running startup

                -I- Running startup scripts

                -I- running service: /intel/euclid/oobe-services/startup_services/S0Init/init.sh

                Startup - S0 Init running!

                -I- running service: /intel/euclid/oobe-services/startup_services/S1Network/init.sh

                -I- running service: /intel/euclid/oobe-services/startup_services/S2WebServer/init.sh

                -I- running service: /intel/euclid/oobe-services/startup_services/S6FeedbackServer/init.sh

                -I- Done running startup scripts

                Running monitor scripts

                -I- Running Mon scripts

                -I- running service: /intel/euclid/oobe-services/monitor_services/S0ConnectionMonitor/init.sh

                -I- Done running monitor scripts

                Running oobe

                -I- running OOBE scripts

                -I- running service: /intel/euclid/oobe-services/ros_services/S1ROS/init.sh

                [31minvalid master URI: http://http://localhost:11311:11311/ [0m

                [31mThe traceback for the exception was written to the log file [0m

                -I- running service: /intel/euclid/oobe-services/ros_services/S2ConfigModule/init.sh

                -I- running service: /intel/euclid/oobe-services/ros_services/S3ROSBridge/init.sh

                the rosdep view is empty: call 'sudo rosdep init' and 'rosdep update'

                -I- running service: /intel/euclid/oobe-services/ros_services/S4WebVideoServer/init.sh

                [31minvalid master URI: http://http://localhost:11311:11311/ [0m

                [31mThe traceback for the exception was written to the log file [0m

                Couldn't find an AF_INET address for [http]

                Couldn't find an AF_INET address for [http]

                [31m[ERROR] [1491068292.926881316]: [registerPublisher] Failed to contact master at [http:0].  Retrying... [0m

                -I- Done running OOBE scripts

                Couldn't find an AF_INET address for [http]

                Couldn't find an AF_INET address for [http]

                Couldn't find an AF_INET address for [http]

                Couldn't find an AF_INET address for [http]

                • 5. Re: Cannot connect to Euclid via browser
                  MajdS

                  Hi,

                   

                  I see what's your problem, please open terminal and edit the file /intel/euclid/config/settings.ini

                   

                  edit the ROS_MASTER_URI, and change it to http://localhost:11311

                   

                  and restart the service again (or Euclid) it should work

                   

                  Best,

                  Majd (Intel)

                  • 6. Re: Cannot connect to Euclid via browser
                    ianholl

                    Thanks Majd, that fixed the issue.  I'm back up and running again.  Not sure what caused the uri to get changed but glad to see the fix was easy.

                     

                    Thanks again,

                    Ian

                    • 7. Re: Cannot connect to Euclid via browser
                      A-A-Rawn

                      When I run the restart oobe script, it hangs up at this line:

                       

                      -I- running service: /intel/euclid/oobe-services/startup_services/S1Network/init.sh

                      • 8. Re: Cannot connect to Euclid via browser
                        A-A-Rawn

                        I did this

                         

                        $ export ROS_HOSTNAME=localhost

                        $ export ROS_MASTER_URI=http://localhost:11311

                         

                        And restarted, and it started working.