3 Replies Latest reply on May 29, 2017 6:15 PM by MelanieS

    No login prompt

    MelanieS

      I am having issues with starting Edison in screen mode via sudo screen /dev/tty.usbserial-* 115200

       

      After entering my computer's password, terminal goes to a white screen like it is trying to access the Edison but when I press enter, either nothing happens or pressing enter actually inserts blank lines like I am typing. White screen seems to remain forever. I was able to finally get the login prompt for root once when I left my Mac on for an entire night but I have no idea how it worked and can't replicate it again

       

      The Edison has two data cables plugged into UART and OTG to USB ports on my Mac OS X Yosemite V10.10.5. I am also able to see Edison in finder but still no luck getting login prompt. Any help would be greatly appreciated!

        • 1. Re: No login prompt
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi MelanieS,

          Thanks for your interest in the Intel® Edison Platform.

          The issue is related to the way you are trying to set up the serial terminal with the Edison board. Normally, on Mac* OS X* the serial port looks like cu.usbserial and that is the one you need to use to set up the serial terminal, we’d like to suggest you to follow these steps:

           

          1.     Check if both USB ports are recognized in your PC:


                    Agents-Mac-mini:~ agent$ ls /dev/cu.usb*
                    /dev/cu.usbmodem1413                              OTG port
                    /dev/cu.usbserial-A502LRS6                       Serial port

           

          2.     Run the command screen –L /dev/cu.usbserial-A502LRS6 115200 –L to log in. In case you get an error saying: “Sorry, could not find a PTY” (see picture below), you can try unplugging and plugging USB serial cable.

           

          mac.png


          Additionally, you can take a look at Setting up a serial terminal on a system with MAC* OS X* for more details.

          Let me know if this information helps. Have a nice day.

          Regards,
          -Yermi A.

          • 2. Re: No login prompt
            MelanieS

            Thanks! So I took these steps and ended up back to the same situation. It gets to a white screen and when I press enter, I'm still not getting a prompt to login to root. Why could this be?

            • 3. Re: No login prompt
              MelanieS

              You know what, all it took was turning the Edison on and off. I didn't kill the screen the last time I was using terminal and maybe that was causing the issue. Thank you so much!!!!