5 Replies Latest reply on May 29, 2017 6:41 PM by Intel Corporation

    No Signal to Monitor from onboard graphics

    TehSeraphim

      A while back I bought an ASUS Z270I (mini itx) motherboard, and am running an Intel i7-7700k from the spring deal. I've also been running an Nvidia GTX 970 - and for the last few months it's been flawless. I want to sell my graphics card to help finance a new card purchase, so today I decided to take out the card and just run off the onboard intel graphics. The motherboard has HDMI and DisplayPort output.

       

      Here's the problem. I plug into the motherboard from my monitor (HDMI) and I get nothing. I reboot plugged into the motherboard, nothing - not even the motherboard splash logo. Nada. I removed the dedicated graphics card. Still nothing. I reinstalled the dedicated card and plug into that; works fine. I checked UEFI and found nothing related to graphics in there - nothing to enable or disable. I boot into the OS (Windows 10 Pro) and theres no Intel card under device manager -> displays. Odd? I go to ASUS website to install the drivers just in case - both software packages that are available from ASUS won't run - say the computer doesn't meet the system requirements to run the software. Under Programs and Features I can see the Intel GMA drivers installed but the computer just doesn't see the Intel chip at all.

       

      I've no idea where to go from here - is my motherboard defective? Do I need to RMA?

        • 1. Re: No Signal to Monitor from onboard graphics
          Stefan3D

          Check your BIOS manual: http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/STRIX_Z270I_GAMING/E12496_STRIX_Z270I_GAMING_BIOS_EM_WEB.pdf

          Looks like you need to enable "advanced mode" to configure graphics

           

          1.6.3

          System Agent (SA) Configuration

          ...

          Graphics Configuration

          Allows you to select a primary display from CPU, PCIE and PCI graphical devices.

          Primary Display [Auto]

          Allows you to select the primary display from CPU, PCIE and PCI graphics devices

          Configuration options: [Auto] [CPU Graphics] [PCIE] [PCI]

          iGPU Multi-Monitor [Disabled]

          This item allows you to empower both integrated and discrete graphics devices for the

          multi-monitor output. The CPU graphics shared system memory size is fixed at 64 MB.

          Configuration options: [Disabled] [Enabled]

          • 2. Re: No Signal to Monitor from onboard graphics
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Thank you very much to for the information posted above.
             
            : Thank you very much for joining the Intel® Graphics communities.
             
            I hope the information posted before was useful for you, please let us know the results of trying the steps provided previously .
             
            Any further questions, please let me know.
             
            Regards,
            Alberto R
             

            • 3. Re: No Signal to Monitor from onboard graphics
              TehSeraphim

              So that's fixed step one I suppose.

               

              I enabled iGPU Multi-Monitor and now my graphics display adapter shows up in device manager.  Additionally, I can run the software from Intel to update the driver whereas before it told me the system didn't meet the requirements (presumably because it saw no device in the device manager for it).  Despite whether choosing CPU only or Auto, I still get nothing out of the onboard card when I boot from the onboard GPU or if I switch the monitor over to it while the PC is running.  I can't test it without the graphics card in as I won't be able to even see the machine POST or see UEFI to make changes, even if I wanted to.  I actually had to reset the BIOS as when I set it to CPU only, I still only got an image out of the Nvidia card and couldn't see UEFI anymore - I only got an image when booting into Windows.

               

              It was set to Auto previously - shouldn't it automatically detect and utilize the onboard GPU if there's no dedicated card detected?  I feel like there's something wrong here if I'm going through hoops just to get the onboard card to work, unless I'm missing something?

               

              Thanks for the help - if you have any more suggestions I'd truly appreciate it.

              • 4. Re: No Signal to Monitor from onboard graphics
                Stefan3D

                Personally i have a stubborn LG monitor that must be powered on before the computer to get a signal.

                 

                Try to connect via display port instead of HDMI.

                 

                Ask for further advice at ASUS Republic of Gamers [ROG] | The Choice of Champions – Overclocking, PC Gaming, PC Modding, Support, Guides, Advice

                • 5. Re: No Signal to Monitor from onboard graphics
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Thank you very much to for the suggestions provided on this thread.

                   

                  : In this case, if it does the same with the display port, then the problem could be related to the processor or motherboard, most of the times this issue is related to the board. The next step if you have the option will be to swap parts, either to test your board with a different processor or test the processor in a different board.

                   

                  To get in contact with ASUS directly is also a good thing to try, to get further technical or warranty assistance, they might have further suggestions to try to fix this problem:

                  https://www.asus.com/us/support/


                  Remember that the Intel processor has 3 years of warranty just in case there is a problem with it.

                   

                  Any questions, please let me know.

                   

                  Regards,
                  Alberto R