1 Reply Latest reply on May 17, 2017 2:29 PM by Intel Corporation

    Compile issue on Joule work area

    BigMo

      I'm running into a compile issue when I run a bitbake full-image -c populate_sdk command on a Joule work area (Log attached below for reference.).

      This issue is impacting my productivity severely so any assistance you could offer would be gratefully received.

      Log
      ===

      | DEBUG: Executing python function sysroot_cleansstate
      | DEBUG: Python function sysroot_cleansstate finished
      | DEBUG: Executing shell function do_configure
      | -- The C compiler identification is unknown
      | -- The CXX compiler identification is unknown
      | -- The ASM compiler identification is unknown
      | -- Found assembler: x86_64-refossdk-linux-gcc
      | CMake Error at CMakeLists.txt:54 (project):
      |   The CMAKE_C_COMPILER:
      |
      |     x86_64-refossdk-linux-gcc
      |
      |   is not a full path and was not found in the PATH.
      |
      |   Tell CMake where to find the compiler by setting either the environment
      |   variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to
      |   the compiler, or to the compiler name if it is in the PATH.
      |
      |
      | CMake Error at CMakeLists.txt:54 (project):
      |   The CMAKE_CXX_COMPILER:
      |
      |     x86_64-refossdk-linux-g++
      |
      |   is not a full path and was not found in the PATH.
      |
      |   Tell CMake where to find the compiler by setting either the environment
      |   variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
      |   to the compiler, or to the compiler name if it is in the PATH.
      |
      |
      | CMake Error at CMakeLists.txt:54 (project):
      |   The CMAKE_ASM_COMPILER:
      |
      |     x86_64-refossdk-linux-gcc
      |
      |   is not a full path and was not found in the PATH.
      |
      |   Tell CMake where to find the compiler by setting either the environment
      |   variable "ASM" or the CMake cache entry CMAKE_ASM_COMPILER to the full path
      |   to the compiler, or to the compiler name if it is in the PATH.
      |
      |
      | -- Warning: Did not find file Compiler/-ASM
      | -- Configuring incomplete, errors occurred!
      | See also "/home/mark/work/ref-os-iot/build/tmp-glibc/work/x86_64-nativesdk-refossdk-linux/nativesdk-clang/3.8.0+gitAUTOINC+06cf4b238f_9fd77bd681-r0/build/CMakeFiles/CMakeOutput.log".
      | See also "/home/mark/work/ref-os-iot/build/tmp-glibc/work/x86_64-nativesdk-refossdk-linux/nativesdk-clang/3.8.0+gitAUTOINC+06cf4b238f_9fd77bd681-r0/build/CMakeFiles/CMakeError.log".
      | WARNING: exit code 1 from a shell command.
      | ERROR: Function failed: do_configure (log file is located at /home/mark/work/ref-os-iot/build/tmp-glibc/work/x86_64-nativesdk-refossdk-linux/nativesdk-clang/3.8.0+gitAUTOINC+06cf4b238f_9fd77bd681-r0/temp/log.do_configure.26763)