1 2 Previous Next 16 Replies Latest reply on May 23, 2017 10:40 AM by lw1948

    Intel NUC6i7KYK - USB failures

    danielgindi

      Hi!

       

      I just got my brand new NUC Skull Canyon.

      It's all nice and smooth - except one big problem: The USB is failing.

       

      What happens is:

      1. An external Samsung SSD drive connected with USB is failing after a while, and by failing I mean suddenly there's no writing to the disk, then there are errors, and if disconnecting from USB and reconnecting - it all continues just fine.

      2. When looking at the device manager, I see the list refreshing every few seconds! Even when the external drive is disconnected.

       

      My setup:

       

      * Intel NUC6i7KYK

      * Kingston HyperX 1x16GB 2133MHz (HX421S13IBK2/16) - Was first installed in the higher slot, moved to the lower slot - no change.

      * 2 x Samsung EVO 960 250GB M.2

      * Logitech wireless keyboard + mouse, connected with one USB "unifying" adapter

      * 1 Asus HD (1920x1080) monitor connected via HDMI

       

      * Windows 10 Pro - Latest build, all updated

      * All drivers updated from Intel site (Except for the Realtek Audio drivers which I downloaded from Realtek site. Intel's version is antique, and must be a mistake).

       

      Anyone else experiencing this?

      Any ideas from Intel support?

       

      Thanks!

      Daniel

        • 1. Re: Intel NUC6i7KYK - USB failures
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello danielgindi,

          Thank you for contacting Intel Communities.

          I am sorry to hear you are having issues with the USB.

          Can you please provide the following information to better assist you?

          • BIOS version:
          • Does this happen with any USB device you connect to the Intel® NUC or it is only related to this Samsung SSD?
          • Does this happen when the external drive is connected to a specific USB port or it happens when connected to any USB?
          • Was the OS installed in UEFI boot mode?
          I hope to hear from you soon.

          Best Regards,
          JC
          • 2. Re: Intel NUC6i7KYK - USB failures
            danielgindi

            Well the BIOS was updated two days ago from your website, latest version. 0046.

             

            I don't have that many USB devices to test with, but they are all working fine on my old PC, same OS...

             

            It happens with any USB port, tried that already... Also tried the yellow one, thought maybe it was loosing power.

             

            I don't really know which boot mode the OS chose. I inserted a USB to install from - and it installed, no questions asked.

             

            I noticed that when disconnecting the Logitech Unifying device (no keyboard, no mouse), the refreshes in Device Manager stop. But that also doesn't happen at all on other PCs.

             

            I have just now tried something:

            Logitech wireless - disconnected: no refreshes.

            Connected, but not touching the mouse - no refreshes. Counting to 10, 15, nothing.

            Moving the mouse - counting to 1 - refresh. Leaving for 5 secs, nothing. Moving the mouse a bit - counting to 1 - refresh.

            I tried this in constant and dynamic patterns - and it has 100% correlation with moving the mouse.

            So basically any action from that USB device generates some signal that tells Windows to refresh Device Manager. Although there's no connect/disconnect sound, and nothing in the Event Viewer under System or Hardware.

             

            I'm thinking maybe there's a generic problem with the USB, or whatever's going wrong when the mouse moves- drives the whole USB controller crazy and disrupts whatever the external SSD is doing.

            • 3. Re: Intel NUC6i7KYK - USB failures
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello danielgindi,
               

              Thank you for the information.

              This could be also a compatibility issue between the USB keyboard/mouse, you can check this list for further information.

              I would recommend testing the Intel® NUC with different keyboard & mouse, maybe going to a computer repair shop so you don't have to get new ones.

              Please let me know how it goes.

              Best Regards,
              JC

              • 4. Re: Intel NUC6i7KYK - USB failures
                danielgindi

                Well I don't want to just drag it around with me. This thing is expensive, especially with all the stuff that's in it.

                 

                But I did take the Logitech Wireless Mouse T620 with me somewhere, let Windows 10 install the drivers and then install SetPoint like I did on the NUC - and this phenomenon did not occur.

                It happens only on the NUC.

                 

                Also the external SSD connected with the Transcend adapter - still has issues.

                When the mouse is disconnected (I use RDP to control the computer), the Device Manager refreshes do not happen,

                and the external drive failures occur less frequently, as I manage to write a big file to it, and then wait a little before it fails.

                 

                So it seems like removing the mouse helps - but USB still has issues. Removing the external drive does not help with the refresh issues.

                 

                This looks like an overall USB problem.

                Judging from all the other complaints here about USB and Thunderbolt in this NUC - I have to ask:

                Are you, the Intel guys, absolutely certain that the USB on the Skull Canyon is properly installed and operational?

                Are you aware of the USB issues?

                 

                Blaming compatibility problems doesn't sound professional to me, as USB is a standard, and this should just work.

                • 5. Re: Intel NUC6i7KYK - USB failures
                  lw1948

                  Hello Daniel,

                  I'm sorry that you have problems with your NUC. Please try the following:

                  1. In addition to SetPoint software, download and install Logitech Unifying Software: Touch Mouse T620 - Logitech Support .  Run this software. In Advanced mode, you can check your device status and you can update firmware version of your Unifying Receiver, keyboard and mouse with the latest firmware.

                  2. I agree with Intel that before you decide that there is a problem with NUC, you shall try to work with an other keyboard + mouse set. Try with wired one.

                  3. If the problem exists also with wired set, you shall address a request to Intel service to give you RMA and replace your NUC.

                   

                  Leon

                  • 6. Re: Intel NUC6i7KYK - USB failures
                    danielgindi

                    I will try the Unifying Software later today, thank you. I'll post an update.

                    I did try with a BT mouse, the Apple Magic Mouse, and it works just fine.

                     

                    Also - the external drive slowing down and giving errors after a while is also an indicator of a faulty USB for me.

                    I don't believe that just every USB peripheral I have and worked great in my previous setup, has compatibility issues with the NUC.

                    • 7. Re: Intel NUC6i7KYK - USB failures
                      danielgindi

                      It says it is up to date. A different mouse on BT works. I don't have a wired mouse.

                      • 8. Re: Intel NUC6i7KYK - USB failures
                        lw1948

                        Hello Daniel

                        I understand that you have successfully tested your mouse and keyboard on an other PC. Was the Unified Receiver installed in USB2 or USB3 port? As you know, NUC is equipped with USB3 ports only. Some time there can be problem using 2.4 GHz Devices connected to USB 3.0. Detailed explanation you can read here: USB 3.0* Radio Frequency Interference on 2.4 GHz Devices  . In order to avoid radio frequency interference on your Unified Receiver, install this receiver on USB extension cable in some distance from NUC USB port.

                         

                        Leon

                        • 9. Re: Intel NUC6i7KYK - USB failures
                          danielgindi

                          Well it was a USB 2.0, but the Unified is connected with an extension.

                          Tried all ports with or without the extension cable. They are about 40-50 cm apart.

                          I should mention again that the keyboard connected to the same Unified do not cause trouble,

                          and that the same Unified with the keyboard and mouse do not cause any trouble on other PCs.

                           

                          And still the external drive also has trouble - on this NUC specifically.

                           

                          Is there any special USB setting I'm missing? Maybe something about power management?

                          I prefer really finding a solution than having to return the unit. I have invested too much time in this.

                          • 10. Re: Intel NUC6i7KYK - USB failures
                            danielgindi

                            Okay so I brought home the Logitech MX Master. Wonderful product. It's not touch-based like the T620 - but the vertical scrolling got its own wheel!

                             

                            So at first - after the short pairing - the symptoms were the same. Refreshes - but in a lower frequency.

                            SetPoint then told me that I should download Logitech Options - which supports this mouse. So I have uninstalled SetPoint and downloaded Options.

                            The mouse works great - with no side effects!

                             

                            I've then installed SetPoint for being able to customize the Keyboard, but without pairing the mouse to it.

                            Everything keyboard-mouse related works 100% now!

                             

                            Of course Logitech should support the keyboard in the new software and that would be ideal.

                             

                            --------------

                             

                            Now there's just one issue: The external SSD.

                            I will monitor it's behavior now after the changes, and post an update here.

                            • 11. Re: Intel NUC6i7KYK - USB failures
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi danielgindi,

                              I am glad to hear the issue with the keyboard/mouse is fixed now.

                              Regarding the external SSD, can you please provide the model number of the device and the part number of the cable you have?
                              Have you tried using a different USB-C to USB-A cable or from USB-C to USB-C cable?

                              Regards,
                              JC

                              • 12. Re: Intel NUC6i7KYK - USB failures
                                danielgindi

                                Regarding the mouse, I just got a reply from Logitech, finally, stating that "The problem you are facing might be related to the lack of compatibility of this mouse with Windows 10, that got more noticeable since the latest update on the OS.".

                                They refer to the dreaded Creators Update which comes with fresh Windows 10 installations, which explains the difference in behavior in other Windows 10 PCs.

                                 

                                The external SSD is Samsung EVO 850 250GB and the adapter is Transcend 2.5" USB 3.0 25CK3 adapter.

                                The Transcend is the only model that I've found in stores (or online) that has a rubber shock absorber.

                                This unit work great on other computers (or my previous PC)...

                                The cable is actually Type-A on one side, and a weird one (USB 3.0 Micro-B 10 pin) on the adapter's side.

                                 

                                If you think that the problem I'm describing can be related to the cable - I'll go buy another cable and try that.

                                But you should know that if I'm transferring a lot of files, or one giant files, around 50GB - it goes straight without hesitation.

                                But if I do very little or nothing, but come after a few hours and try to read a file - it could be stuck, then throwing fault errors in the Event Viewer, sometimes raising weird error Message Boxes.

                                • 13. Re: Intel NUC6i7KYK - USB failures
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hi danielgindi,

                                  The answer provided by Logitech confirmed the compatibility issues with the OS, then we can discard any issues with the USB ports on the Intel® NUC.

                                  Regarding the intermittent issues with the external drive, I would say this is related to the enclosure. As part of the troubleshooting steps, I recommend testing a different cable or enclosure.

                                  I hope that helps.

                                  Regards,
                                  Juan V.

                                  • 14. Re: Intel NUC6i7KYK - USB failures
                                    danielgindi

                                    Well, after a few days:

                                     

                                    1. The Logitech MX Master works perfectly, and it is actually an amazing mouse. So I really like my older touch mouse - but I'm happy with it...

                                     

                                    2. The external Samsung SSDs with the Transcend enclosure - I've come to a conclusion that it is most probably a Windows 10/Creators Update issue.

                                        What I did was turn off the "selective suspend" of usb devices under advanced power management settings - and it's been two days with the drives working as expected.

                                        Could be a problem with the enclosure but I have two of them working fine on other PCs and wrong on this one, where the only difference is the Creators Update.

                                     

                                    What I don't understand is how Microsoft encourages people to avoid this update now, but are still offering it - and hasn't release a hotfix yet.

                                     

                                    Thank you very much Juan and Leon for your help!

                                     

                                    Daniel

                                    1 2 Previous Next