14 Replies Latest reply on Jun 30, 2017 2:57 PM by Intel Corporation

    Intel N-7260 very poor performance after 19.XX driver update

    NikRiaz

      If anyone do experience "new" problems after recent updates?

      I used Lenovo X240 for couple of years and even didn't know that something wrong with N-7260 (as revealed after reading this forum).

       

      After recent Lenovo autoupdate (seems to the latest v. 19.50) I've got severe problems on 2,4Ghz: disconnections (every 1-4 hours), speed decreased down to 0,1-4Mbit/s (sometimes peaks to 12-20) and very uneven, Wireless display doesn't work anymore (slow motion and disconnection after 1 min).

      5 Ghz works good.

       

      Damn, I don't know what was my good, old version.

      What I did: cleaned up this drivers, rolled up to couple of random old versions , reinstalled latest generic drivers along with newest BT drivers, tried to change advanced adapter settings (in different combinations), nothing help. Too much old versions, I can't try everyone. If someone can advice which one is the best one?

        • 1. Re: Intel N-7260 very poor performance after 19.XX driver update
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello NikRiaz,

          We understand your system is having slow performance after some system/driver updates. In this case, we advise you to check with Lenovo Support, and perform a clean install of their recommended driver. Keep in mind that there are different sources where you can obtain the drivers, the first option is the OEM (Lenovo), second is the generic version from Intel, and also, there is the Windows* Inbox driver (from Windows* updates or Windows* installation).

          Here are some steps that may help you go back to the old driver you had:

          - Uninstall Intel® PROSet/Wireless Software from the Programs menu.
          - Go to Device Manager, right click on the wireless adapter and then uninstall the existing wireless driver, make sure you check the option to delete the driver. This will remove the current driver from your PC, so if you scan for hardware changes, or reboot the system; Windows will look for and install another driver version (probably the one had before). At this point, check if the issue persists.

          * Uninstalling and deleting the driver can be done as many times as necessary to remove previous versions, until you reach the Windows* inbox driver which cannot be deleted.

          If you prefer, you can check if Windows* detects an updated working driver automatically

          Additionally, you can check if your system has a restore point that you can go back to, this would undo the recent updates.

          It is also recommended to check with the Access point manufacturer and make sure you are using the latest firmware for it.

          If the issue persists, please provide the following information:

          - Download Intel® System Support Utility, run the tool, and use it to create a report with all sections, once the report is created, click on the "Next" button. In the following screen, save the report to a file. Then use the Advanced editor options to add the resulting file to your post as an attachment.
          - Access point model and firmware version.

          Regards,
          Jonathan B.

          • 2. Re: Intel N-7260 very poor performance after 19.XX driver update
            NikRiaz

            Hello, I appreciate your involvement and thank you for suggestions.

            Yes, I did most of steps you mentioned but did not achieve positive results. I suspect that either the wireless adapter itself was somehow changed (NVRAM?) or some combination of settings matters.

             

            The "main" access point is HPE MCM410, there is latest firmware installed (6.6.7.0-23302). I know that this AP is specifically bad with Intel WLAN, but now I experience unusual slow performance on all other places (with many different APs).

            I also made a cross-post on HPE support forum.

             

            The weird log entries are:

            • AP received a deauthenticate request from client (mac='7C:7A:91:...') on interface (value='r1v1') using SSID (value='...'). Reason code: (value='Unspecified'). Total number of clients: (value='0')
            • Client (mac='7C:7A:91....') on interface (value='r1v1') using SSID (value='...') received an Add Block Acknowledgement (ADDBA) response with status code (value='Status Code 37')
            • Received EAPOL key frame with an invalid reply counter from client (mac='7C:7A:91:...') on interface (value='r1v1')

             

            SSU log is attached.

            • 3. Re: Intel N-7260 very poor performance after 19.XX driver update
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello NikRiaz,

               

              We reviewed the log and the additional details you provided, here are some relevant items for your consideration:

               

              In the log, the signal strength shows 83% and a data rate of 270 Mbps. Under these circumstances, we would expect a drop in the performance.

               

              - Please check if the connection has issues when the PC is closer to the Access Point.
              - Go to the Power options of your laptop, in the Advanced Settings for your Power Plan, and make sure that the Wireless Adapter is set to work at "Maximum Performance" when plugged in and on battery.

               

              From your description, it seems you may be using an enterprise network, with roaming, enterprise authentication, etc. We advise you to redo the wireless profile, matching the network configuration as close as possible. You can actually use Intel® PROSet/Wireless Software intended for IT administrators to create wireless profiles. Please check the following document for more information: Frequently Asked Questions for Enterprise and IT Administrators.

               

              Also, this type of behavior may be caused by recent Windows* updates, have you checked if this started after Windows* updates? You might want to try removing recent Windows* updates and check if this helps.

               

              Regards,
              Jonathan B.

              • 4. Re: Intel N-7260 very poor performance after 19.XX driver update
                NikRiaz

                Thank you for your reply.

                The log was collected while laptop was connected over 5Ghz. There is no performance drop, system works nearly ideal.

                Should I redo log collection on 2,4Ghz?

                Anyway, the signal strength nor reported data rate seems not an issue at all.

                Yes, I can use enterprise network features but I temporary switched to the simple WPA2 encryption for the testing purposes.

                • 5. Re: Intel N-7260 very poor performance after 19.XX driver update
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hello NikRiaz,

                  Please try the actions we recommended already and let us know if they helped

                  - Removing and deleting installed drivers and installing older versions from MS updates, OEM, or generic.
                  - Set Wireless Power options to maximum performance

                  Additionally, here are some actions that may improve connectivity:

                  - Disable the Bluetooth* component of the PC. This may be done with a switch in the chassis or a key combination, you can also do it from Windows* settings.

                  - Go to the Advanced Intel® Wireless Adapter Settings and set 802.11n channel width for band 2.4 to: 20 MHz only.

                  - Try reconfiguring the Wireless profile with the Wireless security options manually set to match the configuration of your network.

                  If the issue persists, provide a new SSU log when the PC is connected to the network with the problem.

                  Regards,
                  Jonathan B.

                  • 6. Re: Intel N-7260 very poor performance after 19.XX driver update
                    NikRiaz

                    I found that on contrary, "Auto" on 2,4Ghz works much smoother than 20Mhz. Speed is OK, great improvement from 1-3 Mbit/s up to 30-35Mbit/s. Connection is not perfect, though, still disconnection every ~30min.

                    Important detail: as soon as first disconnection occurs, connection becomes extremely unstable, connections/disconnections start to repeat constantly. The only way is to disconnect it manually and give it "cool down" for few seconds. Then it works next half of hour.

                    I was also unable to made HP MCM410 work on 40Mhz despite of corresponding "Auto" setting on AP, I achived 40 Mhz on Huawei WS331a AP.

                    Unstable behavior looks absolutely the same on both AP.

                    5Mhz still works perfect.

                    • 7. Re: Intel N-7260 very poor performance after 19.XX driver update
                      NikRiaz

                      I dug out one year old file archive with original Lenovo drivers. While latest 19.50 package has driver version 18.33.6.2, my old one (hopefully stable) has version 18.33.3.2. Performance of 2,4Ghz/40Mhz and 5Ghz connections on old drivers slightly reduced (may be 10-15%) but 2,4Ghz/20Mhz speed seems close to normal (approx 5-8Mbit/s). Connection time on old drivers also much better (almost momentary, while on new one I have to wait up to 5 seconds). Amazing how different these two rather close versions.

                       

                      I also discovered that my WLAN NIC was unbound from NetBT (symptom: unable to browse computers in the Network), returned binding back manually  here: HKLM\CurrentControlSet\Services\NetBT\Linkage. I guess this happened because of multiple drivers re-installation or some bugs in some Intel installer (I tried a lot of them...). May be this detail also affected stability.

                       

                      So far so good.

                      • 8. Re: Intel N-7260 very poor performance after 19.XX driver update
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hello NikRiaz,

                        We appreciate the information you provided and we are glad to know you have found a working configuration for your system.
                        It seems that the latest driver is not always the best option, specially if there are older devices in the environment.

                        Please keep us informed of any change, or if you consider the issue has been resolved.

                        Regards,
                        Jonathan B.

                        • 9. Re: Intel N-7260 very poor performance after 19.XX driver update
                          NikRiaz

                          There are still disconnections with HP MCM410 but work stable with cheapest Huawei. HP keeps silence.

                          Overall, odd. $10 AP works better than corporate $500-one. Corporate Intel NIC causes troubles while noname USB NIC works perfect on both. World is really changed.

                          • 10. Re: Intel N-7260 very poor performance after 19.XX driver update
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Hello NikRiaz,

                            We would like to inform that the new Intel® PROSet/Wireless Software and Drivers for Windows® 10* [19.60.0] has been released. For further troubleshooting please perform a clean installation of this new driver.
                            Remember to remove the existing PROset software and the adapter drivers before installing the new version.

                            If the issue persists, provide a new SSU log when the adapter is connected to the HP access point.

                            Regards,
                            Jonathan B.

                            • 11. Re: Intel N-7260 very poor performance after 19.XX driver update
                              NikRiaz

                              Hello, thank you. I did a clean installation of new driver.

                              There is the same dramatic decrease in speed and latency compare to 18.33.3.2 on 2,4/20. At the moment of writing this post I already get an disconnection (no more 30 mins since new driver installed).

                              Another issue, the NetBT binding has been lost again. I did re-installation carefully so can confirm that is solid bug. Symptom: NetBT reported as "No" despite of implicit settings.  WINS servers reported empty, no computers in File Explorer "Network" node.

                              There are quite a lot manual registry corrections so would be great to fix it too. The full list of affected registry keys here: Virtuozzo | [How To] How do I repair the virtual net...

                              SSU log is attached. Laptop connected to HP MCM410, 2,4/20 that is located in 1 meter distance from laptop.

                              Side note: I have number of MCM410s and tried different F/W (6.X.X). No luck, so It can't be particular physical device.

                              2017-05-17 13_25_07-Speedtest.png2017-05-17 13_13_59-Network Connection Details.png

                              • 12. Re: Intel N-7260 very poor performance after 19.XX driver update
                                Intel Corporation
                                This message was posted on behalf of Intel Corporation

                                Hello NikRiaz,

                                We will need additional details about the environment and the issue, however, we would like to do this privately. Please check your private messages for additional instructions.

                                Regards,
                                Jonathan B.

                                • 13. Re: Intel N-7260 very poor performance after 19.XX driver update
                                  Ascendor

                                  Hey, if there has been any fix to this issue, I would be interested as well, since I am having a very similar setup (Lenovo laptop with similar WiFi chipset, HPE MSM WiFi architecture) and seeing identical log entries.

                                  According to HPE this is a driver issue with the client wifi adapter: http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=mmr_sf-EN_US000005284

                                  • 14. Re: Intel N-7260 very poor performance after 19.XX driver update
                                    Intel Corporation
                                    This message was posted on behalf of Intel Corporation

                                    Hello Ascendor,

                                    If you are using Windows® 10 please make sure you are using the latest updates, including KB4022716, as it may help with this condition. Also, make sure you are using the latest driver from the Computer Manufacturer Support.

                                    If the issue persists, please use Intel® System Support Utility to create a log and attach the resulting file to this thread.
                                    Also, let us know which troubleshooting actions you have tried so far.

                                    Regards,
                                    Jonathan B.