3 Replies Latest reply on May 9, 2017 1:45 AM by Torgrim

    NUC7i5BNH - unidentified device: "Intel High Definition DSP"

    Torgrim

      I just performed a clean install of Windows 10 Pro on a NUC7i5BNH. After installing all drivers included in the latest driver bundle on Intel.com, I'm left with one unidentified device under the device manager cryptically marked as "Intel High Definition DSP". I've tried uninstalling and reinstalling both the Realtek SFX and Intel GFX drivers, but the device is still won't install properly.

       

      All tips are greatly appreciated.

        • 1. Re: NUC7i5BNH - unidentified device: "Intel High Definition DSP"
          spudsong

          I had the same issue with the NUC7i7BNH. Performed a clean Windows 10 install. Installed the NUC7i7BNH driver pack from the support site and had the same driver missing. Also tried reinstalling the graphic and audio drivers which did nothing.

           

          Then once again I wiped the drive and reinstalled Windows 10. This time I didn't install the driver pack. I installed the "Intel Driver Update Utility", ran it and no more missing drivers.

           

          Note: You have to be connected to the Internet to use the Driver Update Utility. When you install Windows 10 it should have installed basic Ethernet drivers to allow access to the Internet via the LAN port on the back of the unit. When running the tool you get a dialog popup for each driver as you would if you were installing them individually. At the finish of some of the driver install dialog it says to restart your computer to finish the install. Uncheck this and select "I will restart my computer later". When all of the drivers are installed the tool will then suggest restarting of which you should do. Also, for some unknown reason the tool installs the chipset drivers last and at the finish it shows the chipset drivers as "Fail". But once rebooted all the drivers are installed as per "Device Manager".

           

          Run the "Intel Driver Update Utility" again after Windows restarts. Mine showed the chipset drivers as "Fail" once again. Inside your "user name/Downloads" folder are the drivers that the tool installed. You can run the chipset drivers from there.

           

          Finally, uninstall the "Intel Driver Update Utility" after updating the drivers. I left it installed and couldn't shut my NUC down. It would just reboot when I selected "Shutdown".

          • 2. Re: NUC7i5BNH - unidentified device: "Intel High Definition DSP"
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Thank you, spudsong for your valuable contribution.

            Torgrim, I hope the workaround provided by spudsong worked for you.

            Please don't hesitate in replying to this thread if you need further assistance.

            Best Regards,
            JC 

            • 3. Re: NUC7i5BNH - unidentified device: "Intel High Definition DSP"
              Torgrim

              Thank you very much, spudsong! This worked fine.

               

              I started to tinker around with the issue based on your solution, and I found out that it's the Realtek driver in the driver bundle I downloaded from the support site that's generating the problem. As long as I install the Realtek driver trough Intel Driver Update Utility, I can install all other drivers from the downloaded driver bundle without any issues. Strange...