8 Replies Latest reply on May 11, 2017 5:15 PM by Intel Corporation

    edision network connection does not work it is wifi enabled

    sanjay23

      For all I have tried, updating the firmware, enabling ssh my edision device can't connect or ping any device on the network, neither any other computer on the internet can ping the edision.

       

      Internally device can ping itself both wlan0 and usb0 addresses, but no other external ip except the gateway itself. Also there is no sshd service running.

       

      I went through to troubleshoot:

      Edison WiFi woes

       

      1) I can configure wifi

      configure_edison --setup

      root@edision:~# wpa_cli -i wlan0 status

      bssid=bc:ee:7b:58:8e:49

      ssid=something

      id=0

      mode=station

      pairwise_cipher=CCMP

      group_cipher=CCMP

      key_mgmt=WPA2-PSK

      wpa_state=COMPLETED

      ip_address=192.168.2.87

      p2p_device_address=92:b6:86:11:94:55

      address=90:b6:86:11:94:55

       

      Here is my wlan0 setting:

      root@edison:~# ifconfig wlan0

      wlan0     Link encap:Ethernet  HWaddr 90:b6:86:11:94:55

                inet addr:192.168.2.87  Bcast:192.168.2.255  Mask:255.255.255.0

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:5 errors:0 dropped:0 overruns:0 frame:0

                TX packets:29 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:960 (960.0 B)  TX bytes:4362 (4.2 KiB)

      2) ping

       

      # gateway ping

      root@edision:~# ping 192.168.2.1

      PING 192.168.2.1 (192.168.2.1): 56 data bytes

      64 bytes from 192.168.2.1: seq=0 ttl=64 time=2.844 ms

      64 bytes from 192.168.2.1: seq=1 ttl=64 time=21.133 ms

       

      #any other fails

      root@edision:~# ping google.com

      PING google.com (216.58.193.110): 56 data bytes

      ping: sendto: Network is unreachable

       

      3) no http server running

      wget localhost fails

       

      Since none of the above works ssh would not work either but I changed lib/systemd/system/sshd.socket to allow incoming ssh connection to try.

       

      Help would be appreciated.