5 Replies Latest reply on May 16, 2017 8:44 AM by Intel Corporation

    Centrino Wireless N 1030 problem with W10 Creators Update and Edge Browser.

    Mooly

      This is an odd issue (to me) and so long story cut short......

       

      Dell Vostro 3750 running W7, then W8.1 and now W10 for last 12 months plus. Following the launch of the 'Creator Update' to W10 I find I am having an intermittent issue accessing certain sites. The sites in question only partially load taking perhaps 20 to 30 seconds to fully complete. The same delay occurs while navigating the sites. Not all sites are affected, and those that are can often be OK initially in a session with the problem striking at random.

       

      The issue ONLY affects MS Edge browser. Using IE and all is OK.

       

      After much troubleshooting and trial and error it appears that the issue only happens when connected wirelessly. If I use a direct wired connection into either the modem or router (they are two separate items) then the issue does not appear.

       

      I have tested this with both clean installs and upgrade installs of W10 and the issue is the same.

      After clean installing W10 I made a disk image to use as a known good start point. W10 was in its basic just installed state. Each time I connect wirelessly the issue appears. Each time I connect via cable the issue does not appear.

       

      I have tried several different driver and driver plus applications and all give the same error. Have also tried older drivers off the Dell site with the same result.

       

      Have also tried connecting to a different router (an older version from my ISP) that I configured as a wireless access point as a test. Same problem.

       

      The issue can be cleared temporarily by either restarting the router, or restarting the PC, or simply closing Edge and leaving it for 30 minutes or so. Closing and reopening Edge in quick succession does not fix things.

       

      All the normal stuff like changing DNS servers and cleaning the DNS resolver cache/temp files etc etc have been tried.

       

      It does seem to be an Creators Edition/Edge/Centrino issue.