5 Replies Latest reply on May 9, 2017 4:35 PM by Intel Corporation

    Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX

    jdchen

      Hey I recently got my hands on the Intel 750 Series 1.2TB NVME U.2 drive. I'm really excited to use it, but I can't seem to get my BIOS to detect it. I've searched most of the support threads on here, and none of the suggestions have worked.

       

      Here is my setup:

       

      Intel i5 6600k

      Asrock Z170 Fatality ITX/AC

      Corsair 2x16gb

      PNY GTX 1080

      Silverstone SG600

      Samsung EVO 850

       

      I've checked the motherboard specs, and it says that the M.2 is NVME compatible and has 4 PCIE 3.0 Lanes. I'm using the Asus Hyperkit adaptor, and I've made sure to also plug in the extra Sata power connector on the mSAS to U.2. All the connections are tight and snug.

       

      The motherboard is updated to the latest BIOS (P7.10). I also tried to use the Driver utility, and it did not detect the drive. Intel SSD data tool also yielded no results. Any suggestion is appreciated!

       

      Thanks,

      jdchen

        • 1. Re: Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Jdchen,

          We understand you have the SSD 750 U.2 drive but it is not detected.
          Now, since you mentioned that the Intel® Driver Utility did not find drivers, we would like you to please try this driver and let us know if this work.

          The driver is the NVMe* driver you need to use this SSD properly. Let us know if it works.

          Regards,
          Nestor C
           

          • 2. Re: Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX
            jdchen

            Hi, sorry for the misunderstanding. I've already tried to install the "Intel SSD Data Center Family for NVMe Drivers", as mentioned in many of the other threads that I googled. The installation fails with the message: "The setup program ended prematurely because of the following error: Device not detected".

            • 3. Re: Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Jdchen,

              Thanks for responding. 
              Based on the whole description and understanding that the drive is not even detected in BIOS, we found the following information from Asus's* website:

              -The motherboard requires the latest BIOS with enabling the [Hyper Kit] option under BIOS\Advanced Mode\PCH Storage for ASUS Hyper Kit. Please refer to each motherboard product download page for details.

              Checking the manual for your computer, on page 59 you will see the settings for advanced mode.

              Another thing to mention is that, even though the adapter is compatible with Z170 chipsets, it is an Asus* branded, so it may work with your system, but we do suggest to you to contact ASRock* to make sure it is fully compatible or if they can provide another adapter.

              We will be waiting for your response.

              Regards,
              Nestor C

              • 4. Re: Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX
                jdchen

                I solved the issue, so I'm posting my solution just in case someone might be in a similar situation.

                 

                As you mentioned, the Asus Hyperkit did not work with Asrock's Ultra M.2 slot. I purchased an Asus Z270i and tested it again. The drive finally showed up in the BIOS after enabling Hyperkit Mode. The drive was not detected unless I enabled Hyperkit mode.

                 

                Thanks again for all the help!

                • 5. Re: Intel 750 1.2 TB U.2 not detected Asrock Fatality Z170 ITX
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hello Jdchen,

                  We are so glad to hear your issue was resolved with some of the recommendations we provided and we thank you for providing your inputs about the resolution of this case. 
                  This will definitely help some other users to find it as a possible solution.

                  Regards,
                  Nestor C