3 Replies Latest reply on Apr 26, 2017 4:17 PM by MartyG

    SR300 Install Problem

    rc6216

      I recently got an Intel RealSense SR300. It installs and works properly on my laptop, but I'm unable to install DCM on my Intel NUC. I've attached a screenshot of the error message. screenshot.jpg

      One thing different I noticed was that the virtual driver didn't install correctly.

      screenshot2.jpg

      I've tried different USB 3.0 ports and a powered USB 3.0 hub, but nothing seems to work.

       

      Model: NUC6CAYH

      Processor: Intel Celeron J3455

      OS: Windows 10 x64

      RAM: 16 GB

       

      Could the processor be the problem? Any help would be greatly appreciated.

        • 1. Re: SR300 Install Problem
          MartyG

          The processor would be a prime cause for suspicion as the cause of the problem, as the SR300 prefers a 6th generation Intel Core 'Skylake' as its official minimum spec.  However, this is not an absolute rule and other types of processor have worked with it (though it becomes more of a lucky dip whether it works or not if a different processor type is used).

           

          Apollo Lake (the architecture of your Celeron J3455) uses Skylake's graphics GPU architecture though, so you would think that this would significantly increase its chances of compatibility with the SR300.

           

          The symptoms you have experienced are more indicative of an issue with the USB ports rather than the processor.  On some PCs, the USB port does not supply the camera reliably with enough power for the camera to be detected, or the camera signal stalls as soon as it connects.  A missing Virtual Driver can also be caused by this.  A powered USB hub is often an instant cure for this in many cases, though not in every case, and I see from your message that you have tried a powered hub yourself and not had success, sadly.

           

          Intel has some guides to troubleshooting camera connectivity and power issues at the top of the front page of the forum.  You may find some useful guidance in those if you have not seen them already.

           

          I would also ask whether you installed the Windows 10 Creators Update (Build 15063) on your NUC?  This has been causing problems with the depth component of SR300 cameras.

           

          Windows* 10 Creators Update Build 15063 Is Not Compatible with Intel® RealSense™ SR300 Camera Driver

           

          Something else caught my eye, though it not necessarily related to your RealSense issues.  In your Device Manager, you have yellow exclamation-mark warning errors in the Other Devices section of it, for the PCI Device and PCI Simple Communications Controller components.  This can indicate that drivers for these components are missing or malfunctioning.  Though if something gets filed into the Other Devices category, it could be more likely because Windows cannot identify what that hardware is, even though it knows that something is present.  From my experience, I believe that these PCI component names are generic names that are given to devices that Windows cannot identify.

           

          It may be worth trying Windows' 'Troubleshooting' interface.

           

          1.  Bring up the Control Panel's troubleshooting window.  You can find this by typing 'troubleshoot' into the text box at the bottom of your Windows screen, next to the button where you shut down.

           

          2.  Go to the 'Hardware and Sound' section and click on the 'Configure a device' option.

          3.  On the next window that appears, click on the 'Next' button to start a scan of your hardware.

          1 of 1 people found this helpful
          • 2. Re: SR300 Install Problem
            rc6216

            Thanks for the reply. I have tried this link but it didn't help with my problem.

             

            Troubleshooting Connectivity or Power Issues with Intel® RealSense™ Cameras

             

            I am running Windows 10 build 14393, so Creators Update is not the problem either.

            I have fixed my driver issues using the Intel Driver Update Utility, but that didn't work either. At this point I think the CPU is probably the cause. I forgot to mention that I also have a RealSense R200 camera which installs successfully, but it has a lower processor requirement (4th Gen). 

            • 3. Re: SR300 Install Problem
              MartyG

              SR300's do sometimes work with a lesser processor than the recommended 6th gen, but the odds decrease the further back you go.  At 5th gen it is 50-50 chance of success at best, and usually none at 4th gen.  Though highly skilled forum contributor jb455 says that third-party re-branded versions of the SR300 such as the Razer Stargazer and Creative BlasterX tend to work with 4th gen in his experience where the official Intel SR300's do not.