8 Replies Latest reply on May 15, 2017 1:03 PM by Intel Corporation

    CPU doesn't go above 800 MHz in Ubuntu 16.04/16.10/17.04, BIOS is 1D1

    RollerGirl

      Hi Community!

       

      I'm trying to get a few Joule 570x up and running on Ubuntu, but running into performance issues.  There isn't a clear example that demonstrates the performance I should expect from the Joule 570x, but I feel like it should be better.  I've run Sunspider 1.0.2 benchmark and compared it to old iPhone 5 (and other old Android phones) and the Joule performs worse.  It's getting about 1500ms or so.  I also check "cat /proc/cpuinfo" and all the cores stay at 799MHz and less. 

       

      Config

      - Ubuntu 16.04 LTS, also tried Ubuntu 16.10 and 17.04 to no avail

      - I've modified the PL1 setting from 4 to 5 to 9 and everything in between... no difference in performance and CPU frequency seems stuck

      - I have a fan and heatsink connected to it.  It's powered by 12v DC power adapter. 

      - BIOS rev is the latest 1D1 iteration.  full string is GTPP1d1a.x64.0143.b30.1703201838

       

      What's the deal?  Is there some method to prove the performance I'm supposed to get?  I've tried two difference Joule 570x and they exhibit the same issue.  Maybe it's the BIOS?? 

       

      Here's a pic of my setup if it helps  

       

       

      Ciao.

      -rg