14 Replies Latest reply on May 11, 2017 5:34 PM by Intel Corporation

    Intel Driver Update Utility installation corrupted after upgrade to Windows Creators Edition and rollback.

    BrazilianJoe

      After upgrading to Windows Creators Edition, my multi-monitor setup was changed, apparently "broken".

      My Device Manager was displaying 4 "Generic Non-PnP Monitor" devices, which didn't exist before. I could verify these nonexistent monitors are a creation of Intel Graphics Driver on Windows Creators Update Edition.

      The desktop extension to my secondary monitor stopped working - it changed to duplicate displays - and I couldn`t use my computer without the secondary screen attached, because the OS was thinking my primary monitor was one of those virtual, nonexistent ones.

       

      I only found similar references about very old  "solutions" - basically roll back to a previous driver version, or upgrade to a more recent, compatible version.

      I tried updating the driver, by opening Intel Driver Update Utility, it updated itself from version 2.6 to version 2.7 before upgrading the driver. It didn't improve matters.

      I tried removing the Non-PnP devices, but they were automatically re-detected and reinstalled. The only way to make them go away was by disabling the Intel Graphics Driver, and running the dedicated GPU, which is not viable for work, because it eats the battery away.

      I rolled back my Windows installation to before Windows Creators Edition.

      Since then, I couldn't open Intel Driver Udate Utility anymore.

      I tried uninstalling it, but it kept looking for a nonexistent chached MSI about IntelProductImprovementProgram.msi. (the irony)

      The uninstallation was always cancelled.

      I tried to use an app uninstaller, and while it removed the installation entry in the installed apps, and removed some registry entries (iobit Uninstaller portable), but now installation still does not work, trying to uninstall a "previous version" of the same msi, which also does not exist in the local disk.

      So the app was not there to be uninstalled, but still has stale accessory .msi information, which block it from being installed.

       

      I should note that I already had the Intel Driver Update Utility installed before, and it worked previously.

       

      From the user's perspective, the problem is clear:

       

      The un/install logic is brittle, prone to breakage.

       

      Windows up/downgrading major versions can remove the cached installation files, and the un/install logic is not capable of downloading updated versions of those .msi from Intel's servers, to be able to complete the un/install procedure.

       

      The installer should be able to download the IntelProductImprovementProgram.msi from Intel's servers, if it is not found in the ProgramData installer cache.

       

      Also, I am trying to remove all traces of the previous installation files, but so far haven't found a full solution.

       

      Intel should also have a KB or script/tool to completely remove all traces of the Intel Driver Update Utility and the bundled installers, so it can be reinstalled in case of corruption.