8 Replies Latest reply on Aug 18, 2017 1:48 AM by MartyG

    RealSense SR300 doesn't work

    NeoChen

      RealSense SR300 worked before.But someday it just can't work again. Tried on RealSense official SDK & Skype, both failed

      But someday it just can't work again.Tried on RealSense official SDK & Skype, both failed

      Tried on RealSense official SDK & Skype, both failed

      SDK info shown as attached

        • 1. Re: RealSense SR300 doesn't work
          MartyG

          It sounds as though your PC may have downloaded the new Windows Creators Update, which causes problems for the Depth part of the camera on SR300 cameras.

           

          Windows* 10 Creators Update Build 15063 Is Not Compatible with Intel® RealSense™ SR300 Camera Driver

          1 of 1 people found this helpful
          • 2. Re: RealSense SR300 doesn't work
            sicconi

            I had the same problem as NeoChen. A couple of days ago I updated Win 10 to the Creator Edition, which actually works pretty well in general.
            A couple of days ago I updated Win 10 to the Creator Edition, which actually works pretty well in general.

            Today I had to run a demo of my code, using my trustworthy SR300. To my disappointment, the demo didn't work. I checked the SR300 with the usual set of code sample in nthe library, but the DCM seemed not to work, although other video tools appeared to see the usual RGB driver (working fine) and the Depth driver (looking steady green, instead of greenish content, but dynamic).

            I checked on the RealSense website where I discovered a more recent version of the DCM, dated April 2017 (vs. Oct 2016). I thought that it would fix the problem. It installed fine, but I was still unable to use the camera with the RS SDK. Long story short, I tried to go back to older versions of DCM (April 2016, then again October 2016, both of which used to work fine), without realizing that the problem was created by the new version of Windows 10.

            Unfortunately, every installation of  DCM forces a firmware update (if I decide to NOT update the firmware the installer refuses to continue) and something must have gone wrong. Now I get an error message stating that one of the two cameras cannot be updated.

            Needless to say, now the SR300 does not work at all. The Windows drivers install normally (Device Manager), the RGB and Depth cameras are listed as before in any video capture application (Zoom, Skype, Kinovea, ...) but the video stream from the camera is now black.

             

            Did I brick my SR300? Is there any way to restore its functionality?

            I promise that I will then closely monitor this forum waiting patiently for a sw fix that makes the SR300 work again with Win 10 Creator Ed....

             

            Thank you!!!
            Roberto

            • 3. Re: RealSense SR300 doesn't work
              MartyG

              You can update the firmware separately from the DCM. The link below explains how to locate the firmware installer on your PC.

               

              Re: How to upgrade the firmware for a number of camera?

               

              Regarding updating the driver files without the firmware: a process for skipping the DCM that has worked for me (though admittedly not for everyone) is as follows.

               

              If you already have a firmware on the camera, a way to get the latest RGB, Depth and Virtual drivers for the camera is to go into the Device Manager, right-click on each of these drivers and select Uninstall til there are no drivers listed for your camera.  Pull the camera out of the USB 3.0 port, wait a couple of seconds and re-insert the camera into the USB port. 

               

              Windows 10 should then automatically re-download the latest SR300 drivers from the internet instead of having to do it through the DCM installer (emphasis on 'should' since, like I said, it doesn't work for everyone).

               

              If the cause of your problems is the Creators Update though, then installing fresh drivers is unlikely to resolve your camera issues.

              • 4. Re: RealSense SR300 doesn't work
                sicconi

                Marty, thank you for posting the link to locate and launch the FWupdateSR300.exe file. After fiddling with the command line options to get familiar with the process I managed to force the update of a previous version of the firmware (10/2016) that I knew worked well with the camera. The update went fine, telling me that the camera was still "alive" and able to handshake with the system to install upgrades.

                Knowing that the Win 10 Creator Edition has a problem with the SR300 waiting to be corrected, I tried to see if I could at least use the camera as a plain RGB camera, testing it with Skype, Zoom, Kinovia, etc. No such luck, the video was still "black", whilst the Depth view would look solid green.

                Following a suggestion from you from a different post, I uninstalled the three drivers in Device Manager (RGB, Depth and Virtual - except that I could not find one labeled Virtual Driver, but found an "Unknown Device" in "Other Devices that I presumed was a failed installation of the Virtual Driver. I forced a refresh, but nothing changed, the SR300 RGB still not producing any video.

                I decided to try Xilnik's suggestion to prevent Windows' automatic drivers update mechanism, both the the Advanced System Settings and at the Registry level, to see if WIndows was bringing in new/incompatible video drivers for the camera.

                I rebooted, but the situation still did not change. I tried to install the most recent version of the DCM, dated 4/217. But installation would abort complaining about some camera error. I did the trick again with FWupdateSr300.exe, this time with the latest version of the firmware. Upgrade went fine, but the camera would still refuse to produce any video.

                At this point I remembered another post of yours citing a suggestion by Intel staffer Jorge to remove the RSDCM_SR300 folder, that btw. was only partially populated because of the failed installation of DCM for SR300. I re-launched DCM for SR300, latest version, and this time the installation went through correctly, with no firmware upgrade (already done manually at the previous step - I can tell now because I can hear the two sounds of the two cameras (RGB. Infrared) being disconnected, firmware updated, USB reconnected).

                In Device Manager the SR 300 RGB driver showed as "USB Camera", unlike the other one (Intel Realsense (TM) Camera SR 300 Depth", but my videoconferencing apps finally showed video coming from the camera. The Intel Realsense (TM) Camera SR 300 Virtual Driver finally showed up correctly, listed in the Imaging Devices section.

                I uninstalled the "USB Camera" driver, refreshed the list in Device Manager and this time the correct name would show up (Intel Realsense (TM) Camera SR 300 RGB) and both the RGB and the Depth cameras appeared to be operational.

                 

                I tried launching the camera viewer sample app from the RealSense Library collection, and the button finally enabled to select the SR 300 camera made me hopeful that DCM would work.

                Sure enough, I tried a few samples from the library, and all of them work fine!!!!

                 

                This installation cost me most of the night and part of the morning to fix, but it shows that the SR 300, with the 4/2017 DCM and the RealSense SDK can work in Win 10 Creator Edition, as long as the interference of Windows trying to install different (incompatile?) drivers for the camera is prevented.

                Thank you to Marty, Xilnik, Jose, Jorge, ... for all the suggestions, that combined helped me get out of this situation. I am sure that somebody more expert than me can simplify the steps and create a replicable procedure for others to deal with the recently discovered incompatibiliy with Win 10 Creator Edition.

                1 of 1 people found this helpful
                • 5. Re: RealSense SR300 doesn't work
                  MartyG

                  Awesome feedback, Sicconi.  Thanks so much for providing such detail 

                  • 6. Re: RealSense SR300 doesn't work
                    mlharmon

                    Today I downloaded a Windows 10 driver update that appears to have resolved this issue:  "Intel - Image - 5/8/2017 12:00:00 AM - 4.2.159.18".  I advise everyone to check for updates and install the driver offered.

                     

                    Mark

                    • 7. Re: RealSense SR300 doesn't work
                      mladen

                      Suppose Intel should pay you some money in this case as u provided them so much useful info and did most of the work supposed to be done by them.

                      m

                      • 8. Re: RealSense SR300 doesn't work
                        MartyG

                        Kindness to others is its own reward.