7 Replies Latest reply on Jun 6, 2017 7:26 AM by Intel Corporation

    Iris 540/550 - Mass Effect Andromeda Problem

    MikeFromCanada

      Currently Mass Effect Andromeda does not run correctly on any computer with an Iris 540 or 550 GPU.

      So far we've tested on a Surface Pro 4 (i7 w/ iris 540) and two MacBook pros (running Windows 10) with Iris 540 and 550.

       

      All loading screens take forever, but once the game gets to a point where 3D graphics are rendered, it is smooth and responsive.

      The problem is loading screens can take upwards of an hour to complete, and there are a lot of them in this game.

       

      It appears to be a driver problem, since removing the latest Intel drivers and defaulting back to the Windows 10 basic VGA driver actually improves load time dramatically.

        • 1. Re: Iris 540/550 - Mass Effect Andromeda Problem
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi MikeFromCanada,

          I understand Mass Effect Andromeda game does not run properly with Intel® Iris 540 and 550 graphics.

          I would like to replicate and help you on the resolution of this issue , please fill out the following form as complete as possible:

          https://communities.intel.com/thread/77761

          To attach a file, you must click "Use Advanced Editor" in the top right corner of the response box, then the "attach" option will appear in the bottom right corner of the response box.

          Allan.

          • 2. Re: Iris 540/550 - Mass Effect Andromeda Problem
            MikeFromCanada

            Ok, I've gathered the requested information:

             

            Category

            Questions

            Answers (N/A if not applicable)

            Description

            Provide a detailed description of the issue

             

            When trying to play Mass Effect Andromeda with the Iris 550, the game sits at a black screen for about 10 minutes after launching. Eventually the intro video plays extremely slowly, and then the title screen comes up and runs normally. After starting a game, another loading screen appears that takes about 15-20 minutes, then loads into the game which runs normally. The game continues to run fine after these two extremely long loads.

             

            If I remove the Intel Iris drivers and try to launch the game using the generic VGA driver in Windows, the game loads to the main menu very quickly, in about 15 seconds.

             

            Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")

            Always (100%): x

            Often (51-99%):

            Sporadic (20-50%):

            Very Sporadic (<20%):

            Hardware (HW)

            Brand and Model of the system.

             

            2016 13" MacBook Pro with Touchbar

             

            Hybrid or switchable graphics system?
            ie Does it have AMD or NV graphics too?

             

            No

             

            Make and model of any Displays that are used to see the issue (see note2 below).
            LFP
            = Local Flat Panel (Laptop panel)
            EFP = External Flat Panel (Monitor you plug in)

             

            LFP built in laptop display

             

            How much memory [RAM] in the system (see note2 below).

             

            16 GB

             

            Provide any other hardware needed to replicate the issue.
            ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

             

            None

             

            Hardware Stepping (see note1 below).

             

            Software (SW)

            Operating System version (see note2 below).

             

            Windows 10

             

            VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

             

            Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

             

            21.20.16.4627

             

            SW or Apps version used to replicate the issue.

             

            Origin with latest version of Mass Effect Andromeda

             

            Configurations

            Single display, clone, or extended (see note2 below).

             

            Single Display

             

            Display resolution & refresh rate setting of each display (see note2 below).

             

            2560 x 1600

             

            AC or DC mode, i.e. is power cable plugged in or not?

             

            Plugged in

             

            How to repro

            Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
            A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

            1. Launch Mass Effect Andromeda
            2. Black screen will appear and look like the game has frozen, but if you wait 5-10 minutes the game will load and the intro video will play very very slowly
            3. Main menu runs normally, start new game and loading screen will take 15-20 minutes to load
            4. Game runs normally after this

            ...

            • 3. Re: Iris 540/550 - Mass Effect Andromeda Problem
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi MikeFromCanada,

               

              Thank you for taking the time and communicate this to us.

              Please bear in mind that Apple has requested that all questions regarding Apple systems and software be addressed directly with Apple support. I will forward this information to the appropriate department for further review but in the meantime, I recommend checking the link below for troubleshooting assistance on your Apple computer.

               

              MacBook - Official Apple Support

               

              Allan.

              • 4. Re: Iris 540/550 - Mass Effect Andromeda Problem
                Ronald_Intel

                Hello MikeFromCanada,

                 

                I would like to let you know that Intel and Bioware are jointly investigating root cause and we’ll provide any updates as they come.

                Thank you for reporting this issue to us.

                 

                Kindest Regards,

                Ronald M.

                • 5. Re: Iris 540/550 - Mass Effect Andromeda Problem
                  Ronald_Intel

                  Hello MikeFromCanada,

                   

                  We released a new driver 15.45.4678 today, and I was wondering if you could give it a try and let us know if it makes any difference with Mass Effect Andromeda.

                  Thank you for your assistance.

                   

                  Kindest Regards,

                  Ronald M.

                  1 of 1 people found this helpful
                  • 6. Re: Iris 540/550 - Mass Effect Andromeda Problem
                    FliesWithWind

                    I can confirm that the new driver solved the problem of long loading times.

                     

                    Great job!

                    • 7. Re: Iris 540/550 - Mass Effect Andromeda Problem
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hello FliesWithWind,

                      I am glad to hear the latest graphics drivers version 4678 has fixed this issue. Thank you for taking the time and update this post.

                      Allan J.