2 Replies Latest reply on Apr 17, 2017 2:35 PM by Intel Corporation

    Intel Edison-unable to connect WIFI.....

    Neuroastronaut

      I have tried Intel Edison half year ago, and the Wifi was unable to connect. It took me too much time to figure out why through searching on the internet for solution, and nothing could help me, so I gave up. Recently I found the board and wanna gave it a chance. But I still stuck in this step: Setting up Wifi...!!!...Already flash with the firmware..

      My environment is Windows 10, tool is Putty.  (Poky (Yocto Project Reference Distro) 1.7.3 myname ttyMFD2)

      Firmware version: 201606061707

       

      [Method 1]

      Here's what I run:

      configure_edison --wifi

       

      Result:

      Initiating connection to XXX. Please wait...

      Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

      Not connected. Something went wrong.

       

      [Method 2]

      Follow this http://www.intel.com/content/www/us/en/support/boards-and-kits/000006202.html

       

      Result:

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

      <4>Failed to initiate sched scan

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

      <3>CTRL-EVENT-SCAN-RESULTS

      <3>WPS-AP-AVAILABLE

       

       

      [Method 3]

      Follow this https://communities.intel.com/thread/58680

       

      Using Arduino IDE--

      File>Examples>WiFi>WiFiWebClient. You will need to change the lines:

      char ssid[] = "yourNetwork"; //  your network SSID (name)

      char pass[] = "secretPassword";  // your network password

       

      Result:

      Same as in  [Method 1]

       

       

      Anyone please help me?

      I think it would be a waste to not use the board, but it took me too much time setting up the environment.

       

      Thank you so much:)