9 Replies Latest reply on Apr 13, 2017 2:09 PM by Intel Corporation

    SR300 installer asking for firmware update, then failing

    EyalKatz

      Trying to install SR300, this camera worked fine on another computer. On this computer the installer is asking for firmware upgrade, then failing. Subsequent installs keep failing also.

      I have another SR300 camera from the other computer, trying to install it also, and it won't let me unless I do the firmware upgrade.

      What should I do?

       

      This is a new and powerful computer, windows 10, usb3,

       

      Eyal

       

       

      install1.png

      install2.png

        • 1. Re: SR300 installer asking for firmware update, then failing
          EyalKatz

          Uploading also the log file, it might have info about what happened with the install,

          Eyal

          • 2. Re: SR300 installer asking for firmware update, then failing
            MartyG

            If the camera works on another computer and the machine having the trouble meets RealSense's specification for the SR300 (minimum 6th generation Skylake processor, Windows 10, USB 3.0) then the cause of installation failure is often the USB ports.  On some machines, they may not be able to stably supply enough power to the camera for it to be detected by the installer. 

             

            It is a USB  issue, not a power supply issue - there have been people with powerful enterprise Xeon workstations with 600W power supplies that have had this issue.  Many people have had their camera detection problem instantly cured by plugging their camera into a powered USB hub instead of directly into the PC's USB port.  Powered hubs, which run off the mains point, can be found for about $15 on stores such as Amazon by searching for 'powered hub usb 3.0'. 

             

            Before you consider that option though, as you have an external USB camera, you may be able to install the RealSense drivers without using the DCM installer if you follow this process:

             

            1.  Open the Device Manager and go to the Imaging Devices section, where the RealSense drivers should be listed.  There should be three of them - RGB, Depth and Virtual Driver.  People with camera detection problems sometimes only have the first two, and the Virtual Driver is missing.  This can cause DCM installation to fail.

             

            2.  On each of the RealSense drivers in this section, right-click on it and select Uninstall until you have no RealSense drivers listed under the Imaging Devices section.

             

            3.  Ensure that you are connected to the internet.  Then unplug the camera from the USB port, wait a couple of seconds and plug it back in.  Windows 10 should then automatically download and install the RealSense drivers over the internet over the next 5 to 10 seconds, putting them back in your Imaging Devices list and restoring the Virtual Driver if it had been missing.

            • 3. Re: SR300 installer asking for firmware update, then failing
              EyalKatz

              When I first plugged in the camera, the automatic windows installer said that it's installing a driver for Senz3D.

              Does this make any sense? Could be a clue.

              After deleting the automatically installed drivers, and trying again, I get the same results.

               

              Now I'm trying and I can see the RGB camera, but not the Depth camera.

              • 4. Re: SR300 installer asking for firmware update, then failing
                MartyG

                The Senz3D was the 2013 predecessor of RealSense and is a different camera.  There was a new camera called the Senz3D BlasterX released recently though, which is an SR300-compatible camera.  So perhaps Windows thought you had a Senz3D BlasterX camera connected.

                 

                Could you tell me the make and model of your PC please, and the processor it uses if possible.  That might provide further clues.

                 

                Edit: never mind - I looked in the log you kindly supplied.  Intel Xeon CPU E3-1230 v5.  It's Skylake architecture, so should be fine with the SR300.

                • 5. Re: SR300 installer asking for firmware update, then failing
                  EyalKatz

                  Why would the firmware upgrade fail?

                  Could it be that it is trying to install the firmware of the wrong Creative camera?

                  What about the camera where the firmware install failed, would it be possible to fix that?

                  • 6. Re: SR300 installer asking for firmware update, then failing
                    MartyG

                    In the majority of cases, if your PC meets the camera's spec - as yours does - then the problem is with the USB ports and their inability to supply power to the camera reliably enough for it to be detected by installers such as the DCM.  RealSense cameras are very sensitive to the state of the USB port.  Using a mains-powered hub to plug your camera into is usually the most successful solution.

                     

                    It's pretty much a matter of luck whether a particular PC will have USB ports that can satisfy the camera's needs.  That is why it can work perfectly on one PC but not another one that also meets the minimum specification.

                    • 7. Re: SR300 installer asking for firmware update, then failing
                      EyalKatz

                      I think I have a theory why it doesn't install:

                       

                      - When I plugin the camera to usb, Windows automatically installs the wrong driver, the one for the Senz3D BlasterX VF0810. (I trid again and I can see this installed in the device manager)

                       

                      - Then when I try to install the sr300 driver from intel (using this file: intel_rs_dcm_sr300_3.3.27.5718 ), it detects the wrong camera drive and forces me to re-install the firmware.

                       

                      - If I select to proceed to re-install the firmware, it fails and then I can't use the camera

                       

                      - Then I plugged in another identical camera. This time i don't want to re-install the firmware. Trying the Intel installer again, it will not proceed until I choose to re-install the firmware. I decide not to do it.

                       

                      - I am looking at the device manage and see installation of the Senz3D BlasterX VF0810 driver. I uninstall it.

                       

                      - Now I try to install the Intel driver again, and it tell me:

                       

                      "The installer failed to detect an Intel® RealSense™ 3D camera on this system. The installation was terminated."

                       

                       

                      My conclusion:

                       

                      1. The problem is the Windows detection of the camera when plugging it in the usb.

                      2. If we can make Windows detect it correctly (and identify it as SR300, and not as Senz3D BlasterX VF0810), the rest will work fine

                       

                      How can we make Windows detect the usb came and identify it corrcetly, such that the Intel driver intaller will also see that we have indeed SR300 camera?

                       

                      • 8. Re: SR300 installer asking for firmware update, then failing
                        EyalKatz

                        Trying on another computer, I see that it does work correctly when identified as Senz3D BlasterX VF0810 when plugging into the usb port.

                         

                        This is the only difference is that on the computer where it works:

                        - Go to the settings/devices page

                        - you can see in the "connected devices" both:

                        - Senz3D BlasterX VF0810

                        - AND also another one called "Virtual RealSense device"

                         

                        When I unplug and plug again on the good computer, I see it install the Senza3D first, and then the "Virtual RealSense device".

                         

                        On the other computer, I can see just "Senza3D", and no "Virtual RealSense device", and then i can't install the driver.

                         

                        (I also tried the same camera where the firmware uprade failed, and it still works on the other computer!)

                         

                         

                        So the remaining issue is -- how can we make it install that "Virtual RealSense device" when plugging the camera to usb?

                        • 9. Re: SR300 installer asking for firmware update, then failing
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hi Eyal,

                          That's a weird issue, did you check the documents in the community? I think that there are some articles that might be helpful for you:

                          It can be an issue with the chipset drivers, so please make sure that they are up to date, check this article: https://communities.intel.com/community/tech/realsense/blog/2017/01/23/update-chipset-drivers-to-optimize-intel-realsense-camera-connectivity

                          You can also try to install the DCM manually, to do this follow the next guide: https://communities.intel.com/community/tech/realsense/blog/2017/03/20/new-articles-on-how-to-install-and-troubleshoot-realsense-camera-drivers

                          It can also be a power issue with your USB port, take a look at this article: https://communities.intel.com/community/tech/realsense/blog/2017/02/13/troubleshooting-connectivity-issues-with-intel-realsense-cameras

                          I hope you find this information useful.

                          Have a nice day.

                          Regards,
                          Leonardo R.