8 Replies Latest reply on Apr 7, 2017 10:38 AM by Intel Corporation

    NUC7i3 Win10 WakeOnLan do not wake from power off

    ssabb3

      I am happy with my NUC7I3BNH and I'm running Win10 on it. I have the latest 3/3 2017 BIOS installed and the latest NIC drivers for both WAN and LAN. I have turned off fast-boot in bios.

      I have enabled "wake from power off", "wake by magic packet" etc under properties. I have set all wake options in the BIOS except wake from s5 by timer.

      -> But cannot wake the NUC7 from power off.

      I have a lot of computers that all wake from power off, however none of them uses win10. All of them wake up from power off by sending them their mag.pack.

       

      I think this is either due to win10 or the bios.

      Any hints to give me on this?

       

      /sebastian

        • 1. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello ssabb3,

           

          I would like to gather more information regarding your configuration, so please provide the following report;

          Intel® System Support Utility report; Download Intel® System Support Utility. Once done attach it.

           

          To attach a file, you must click "Use Advanced Editor" in the top right corner of the response box, then the "attach" option will appear in the bottom right corner of the response box.

           

          Regards,

          Amy.

          • 3. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Thanks for the file.

             

            I would like to confirm if you followed the steps below to set the configuration;

             

            Wake-on-LAN

            1. Go to Device Manager.
            2. Expand the Network Adapters section.
            3. Right-click the adapter in use and click Properties.
            4. Click Advanced tab.
            5. Select Wake on Magic Packet from the Property list.
            6. Expand the Value section and select Enabled.
            7. Click Power Management tab.
            8. Select the check box for Allow this device to wake the computer.
            9. Click OK.

             

            Also, could you please let me know what are the options you have enabled in the BIOS regarding the Wake-on-LAN? This is just to confirm the configuration since you are up-to-date with the drivers.

             

            Regards,

            Amy.

            • 4. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
              ssabb3

              Bios-settings

              ----------------------

              image1.JPG

              i disabled and enabled deep s4/s5 to see if it made a difference but no difference, the system does not wake from power off.

              image5.JPG

              when enabling "wake from s5" I have to set a recurring time/date, but regardless thge system do not wake from power off by sending magicpack in win10.

              image6.JPG

              And in windows:

              -----------------------

              image7.JPG

              image2.JPG

              /Seb

              • 5. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Seb, thank you very much for the pictures.

                 

                 I have been doing some research based on this situation, and I found out that this is related to Windows® 10. This is due to the shutdown state that Windows® 10 introduces, Microsoft changed the default behavior of how the computer responds to Wake-on-LAN events for this operating system. At this stage there is a workaround for this, please find it below;

                 

                How to enable Wake-on-LAN in Windows 10

                http://www.thewindowsclub.com/wake-on-lan-windows-8 

                 

                Please give it a try, and let me know how it goes.

                 

                Regards,

                Amy.

                • 6. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
                  ssabb3

                  I am afraid I already have disabled fastboot so either win10 ignores that setting or somethin else.

                  I did a powercfg -h off in an elevated propmt, this removed the fastboot-option from the GUI under "choose what my power buttons do".

                  I though of making a picture of the disabled fast startup option and didnt see the option, so I had to do a powercfg -h on and reboot and the option was once more available.

                  It was turned off, verified by the registry setting HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" HiberbootEnabled set to 0.

                   

                  Reading System Power States (Windows)  states at the bottom of the page that;

                  Wake-on-LAN behavior

                  The wake-on-LAN (WOL) feature wakes the computer from a low power state when a network adapter detects a WOL event (typically, a specially constructed Ethernet packet).

                  WOL is supported from sleep (S3) or hibernate (S4). It is not supported from fast startup or soft off (S5) shutdown states. NICs are not armed for wake in these states because users do not expect their systems to wake up on their own.

                   

                  Note  WOL is not officially supported from soft off (S5). However, the BIOS on some systems may support arming NICs for wake, even though Windows is not involved in the process

                   

                  So as long as windows goes to s5, it is the bios that need to support s5. If windows has enabled fast boot it goes to hibernation/s4 in which case I assume it is windows responsibility to wakeonlan.

                  And I have enabled all s-states in BIOS (see previous images) that I can and all the options that I can in windows (allow wake-timers, allow wake from lan using mag pack under network adapter properties) to make it happen from either s4 or s5.

                   

                  I use the WAke on LAN freeware to send the magik packet. I will double check the config I made there and get back.

                  /Seb

                  • 7. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
                    ssabb3

                    So, I reinstalled & re-entered WOL data into the WakeOnLAN software, and now the NUC7I3BNH wakes from S5/power-off state. Either I typed something wrong the first time, or something changed (ip or something) but now it works.

                     

                    So, Confirming than wake from lan from power-off works, and probably the only settings that are important then are the BIOS settings and the correct IP-address, subnetmask & hostid to send the magic packet.

                    And if one wants to wake it from S3 or S4, the windows settings need to be changed to allow network adapter to wake the computer on magic packet.

                    My interest was only in waking from S5 so I am done. It works, if you type all net-stuff correctly and know how WOL works.

                    /Seb

                    • 8. Re: NUC7i3 Win10 WakeOnLan do not wake from power off
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Seb, I am glad to hear that the Intel® NUC is working.

                       

                      Thank you for sharing your outcome.

                       

                      Regards,

                      Amy.