3 Replies Latest reply on Mar 31, 2017 5:31 PM by Intel Corporation

    Intel Edison static IP working connection to Ubiquity rocket M5 in bridge mode

    Electrumpet

      Dear all,

       

      For my project I am working on the Edison with mini breakout powered by battery (7,4V) on J21 and wirelessly (WiFi) connected to the Ubiquity rocket M5 with a powerful antenna.

      AM5G16AirMax Sector 5G-16-120: 5 Ghz 16 dBi 120 degrees 2x2 MIMO

       

      I use it to make a very powerful WiFi network which I can use on stage. The antenna is a sector antenna and thus looks explicitly in a certain direction. It also functions in the 5 GHz band which is not very populated...

      In my configuration I use it in bridge mode which means that the rocket does not function as a router but directly funnels the signal through to the computer through ethernet. It is like a computer to computer connection.

       

      This makes connecting to it hard with the Edison. I cannot use the standard setup tool since that works with DHCP and the rocket in bridge mode does not hand out IP addresses. So I have to go for the static option.

      I had it connected in the past using this post:

      Configuring Edison for a static IP address ...

       

      I had been lucky then though. Since I had a new Edison to configure I had to follow the steps again...

      I followed the lines of the script:

       

      DiegoV_Intel
      Juiste antwoord door DiegoV_Intel op 9-dec-2015 8:31

      Hello DaveFer,

       

      Try with the steps below:

      • Connect to wireless network using connman. Run the following commands in the Edison's console:
      1. systemctl start connman 
      2. systemctl enable connman 
      3. connmanctl 
      4. enable wifi 
      5. scan wifi 

       

      • Wait for the scan completed message and then run the following command:
      1. services 

       

      • A list of the available networks will be displayed with the following format:

                <network name> <service name>

      • Then run the following commands:
      1. agent on 
      2. connect <service name> 

       

      • At this point you will be asked for the passphrase. Enter the network password and then run the following command:
      1. exit 

       

      • Now you should be connected to the network. After a successful connection gather the gateway, netmask and broadcast information with the following commands:

          For gateway information:

      1. netstat -nr 

       

          For netmask and broadcast information:

      1. ifconfig wlan0 

       

      >>>>>NOW HERE I HAVE A PROBLEM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

      >>>>>Since the Rocket does not hand out an ip address I get no ip address, no net mask and no gateway. None the less I went on and did also the next step:

       

      • Now proceed to configure and set the static IP address using the service, gateway and netmask gathered with the following command:
      1. connmanctl config <service name> --ipv4 manual <ip address> <netmask> <gateway> 

       

      >>>>>although I did not get any information from ifconfig wlan0 I forced the <ip address> <netmask> and <gateway> anyway in the same network as the network that I had chosen for the Rocket - computer ethernet connection. If I subsequently pinged the ip address nothing happened though.

      >>>>>I also did the step of creating the /etc/network/interfaces file for which the procedure is in the original post.

      >>>>>If I then rebooted the Edison, there was no connection. Repeating the connman procedure would give errors and after the 'services' command service names that had a lot of zero's in them would show up.

      >>>>>So I decided to start from scratch. I deleted the /etc/network/interfaces file that I had just created and I also got rid of all the entries in the /etc/wpa_supplicant/wpa_supplicant.conf file, leaving only this in that file:

      ctrl_interface=/var/run/wpa_supplicant

      ctrl_interface_group=0

      config_methods=virtual_push_button virtual_display push_button keypad

      update_config=1

      fast_reauth=1

      device_name=Edison

      manufacturer=Intel

      model_name=Edison

      >>>>>So I restarted, was ready to start the procedure again but then saw in connmanctl when I asked for 'services' that the Edison seemed to be connected to the Rocket!!!

      >>>>>A much bigger present was the fact that after rebooting the Edison the Edison kept connecting to the Rocket.

      >>>>>I am not sure what happened but it seems that when the wpa_supplicant.conf file does not have any network entries that the latest connman entry will be used. I checked the file later and there were no network entries added... I think I got lucky the first time I tried this because I did it on a fresh image on which I did not already try configure_edison --setup or the setup tool.

       

      My main reason for posting is to help others with a similar problem. Maybe there is somebody as well with a deeper insight who can clarify this behaviour. And I am curious where connman stores/gets that network information and if it is possible to have more then one network that will be searched for when starting up the Edison...

       

      Best, Hans.

       

        • 1. Re: Intel Edison static IP working connection to Ubiquity rocket M5 in bridge mode
          Electrumpet

          For some reason the second half of my post is only visible for a second. I copied some html code which is probably the reason.

          • 2. Re: Intel Edison static IP working connection to Ubiquity rocket M5 in bridge mode
            Electrumpet

            Dear all,

             

            Another try at my post...

             

            For my project I am working on the Edison with mini breakout powered by battery (7,4V) on J21 and wirelessly (WiFi) connected to the Ubiquity rocket M5 with a powerful antenna.

            AM5G16AirMax Sector 5G-16-120: 5 Ghz 16 dBi 120 degrees 2x2 MIMO

             

            I use it to make a very powerful WiFi network which I can use on stage. The antenna is a sector antenna and thus looks explicitly in a certain direction. It also functions in the 5 GHz band which is not very populated...

            In my configuration I use it in bridge mode which means that the rocket does not function as a router but directly funnels the signal through to the computer through ethernet. It is like a computer to computer connection.

             

            This makes connecting to it hard with the Edison. I cannot use the standard setup tool since that works with DHCP and the rocket in bridge mode does not hand out IP addresses. So I have to go for the static option.

            I had it connected in the past using this post:

            Configuring Edison for a static IP address ...

             

            I had been lucky then though. Since I had a new Edison to configure I had to follow the steps again...

            >>>>>I followed the lines of the script:

             

            Try with the steps below:

            • Connect to wireless network using connman. Run the following commands in the Edison's console:
            1. systemctl start connman 
            2. systemctl enable connman 
            3. connmanctl 
            4. enable wifi 
            5. scan wifi 

             

            • Wait for the scan completed message and then run the following command:
            1. services 

             

            • A list of the available networks will be displayed with the following format:

                      <network name> <service name>

            • Then run the following commands:
            1. agent on 
            2. connect <service name> 

             

            • At this point you will be asked for the passphrase. Enter the network password and then run the following command:
            1. exit 

             

            • Now you should be connected to the network. After a successful connection gather the gateway, netmask and broadcast information with the following commands:

                For gateway information:

            1. netstat -nr 

             

                For netmask and broadcast information:

            1. ifconfig wlan0 

             

            >>>>>NOW HERE I HAVE A PROBLEM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

            >>>>>Since the Rocket does not hand out an ip address I get no ip address, no net mask and no gateway. None the less I went on and did also the next step:

             

            • Now proceed to configure and set the static IP address using the service, gateway and netmask gathered with the following command:
            1. connmanctl config <service name> --ipv4 manual <ip address> <netmask> <gateway> 

             

            >>>>>although I did not get any information from ifconfig wlan0 I forced the <ip address> <netmask> and <gateway> anyway in the same network as the network that I had chosen for the Rocket - computer ethernet connection. If I subsequently pinged the ip address nothing happened though.

            >>>>>I also did the step of creating the /etc/network/interfaces file for which the procedure is in the original post.

            >>>>>If I then rebooted the Edison, there was no connection. Repeating the connman procedure would give errors and after the 'services' command service names that had a lot of zero's in them would show up.

            >>>>>So I decided to start from scratch. I deleted the /etc/network/interfaces file that I had just created and I also got rid of all the entries in the /etc/wpa_supplicant/wpa_supplicant.conf file, leaving only this in that file:

            ctrl_interface=/var/run/wpa_supplicant

            ctrl_interface_group=0

            config_methods=virtual_push_button virtual_display push_button keypad

            update_config=1

            fast_reauth=1

            device_name=Edison

            manufacturer=Intel

            model_name=Edison

            >>>>>So I restarted, was ready to start the procedure again but then saw in connmanctl when I asked for 'services' that the Edison seemed to be connected to the Rocket!!!

            >>>>>A much bigger present was the fact that after rebooting the Edison the Edison kept connecting to the Rocket.

            >>>>>I am not sure what happened but it seems that when the wpa_supplicant.conf file does not have any network entries that the latest connman entry will be used. I checked the file later and there were no network entries added... I think I got lucky the first time I tried this because I did it on a fresh image on which I did not already try configure_edison --setup or the setup tool.

             

            My main reason for posting is to help others with a similar problem. Maybe there is somebody as well with a deeper insight who can clarify this behaviour. And I am curious where connman stores/gets that network information and if it is possible to have more then one network that will be searched for when starting up the Edison...

             

            Best, Hans.

            • 3. Re: Intel Edison static IP working connection to Ubiquity rocket M5 in bridge mode
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Hans,

               

              Thanks for your interest in the Intel® Edison™ Platform.

               

              I'm glad to know that you fixed your issue by your own! And thanks for sharing your results in such a detailed manner.

               

              Now, regarding an explanation of the strange behavior of Connman. I personally don't have too much experience with Connman, but maybe your questions could be answered by looking through the Connman documentation https://01.org/connman/documentation .

               

              Please let me know if any questions come up, have a nice day!

               

              Best Regards,
              -Jose P.