1 2 3 Previous Next 32 Replies Latest reply on Mar 2, 2010 8:23 PM by freak77power

    Is it possible to reflash SSD with same firmware

    freak77power

      I need to reflash my both Intel X25-M with the latest firmware but tool doesn't let me cause it's already running latest version. Reason why is that under Windows 7 Raid 0 of these two scores only 5.9. I thought that SATA controller on my x58 motherboard went bad, so i got a new motherboard and same thing! I think something wrong is going with drives and they probably need to be reflashed, that might fix a problem. Just to say that Windows 7 always scored 7.9 before.

        • 1. Re: Is it possible to reflash SSD with same firmware
          ambizytl

          If you are doing RAID, TRIM will not function with firmware and you will get that low score. The SSD Toolbox, used for manual TRIM or scheduling TRIM, will not work in a RAID environment:

           

          Installation Requirements

          ·      A Microsoft Windows* operating system; Windows XP, Windows Vista* or Windows 7 (32-bit or 64-bit versions)

          ·      .NET Framework 2.0

          ·      Disk Defragmenter is turned off (Windows Vista* or Windows* 7) or not running (Windows XP).

          ·      At least 10 MB of free space on your drive

          ·      A non-RAID configuration

          ·      A non Dynamic Disk configuration

          • 2. Re: Is it possible to reflash SSD with same firmware
            freak77power

            I can switch to IDE mode to flash firmware. All i need to force same firmware again. As I said Windows 7 x64 WEI scored 7.9 always with my SSD Raid 0 configuration and things started messing up a month ago now it scores only 5.9 no matter what with RAID on or off. Tried also ACHI on single SSD and it's still stuck at 5.9. My last attempt would be to reflash these drives with latest firmware, and maybe there is switch in command line to force same. If this doesn't help i will ditch SSDs, technology is immature.

            • 3. Re: Is it possible to reflash SSD with same firmware
              ambizytl

              The SSD will score 7+ when new and go down if not TRIMMED.

               

              RAID does make a difference with regard to TRIM.

              • 4. Re: Is it possible to reflash SSD with same firmware
                Einride

                I would not be in a hurry to condemn Intel SSDs based on a WEI score--even a big decline in WEI score.  I put together six systems, one with Raid, and ,every time after the install initial WEI was 5.9 for Data Transfer.  After a time of testing and installing other stuff, WEI jumped to 7.8 for single and 7.9 for Raid.  Also, the graphics score went from 5.9 to 7.4.  Early on I thought that the change was due to eventually overclocking the processor from 2.6 to 4.0.  But I re-tested that later at CPU 2.6 and found no change in Data Transfer and Graphics--or even CPU score.  So, something else changed.

                 

                I ran other tests on the hardware and did not see any difference tracking the WEI scores.  So, maybe the WEI process is influnced by some other factor.

                 

                Here is an AS SSD test on a Raid0 array, 2xIntel G1 80GB that produces a WEI sub-score of 7.9.  This is using the Win7 default Raid driver iaStorV.  Give this test a try.  Your scores should be better than mine.  But, if, not, then you should be able to see where yours is having problems.

                 

                as-ssd-bench SSD 2.26.2010 10-33-36 AM Raid SSD on WCB iaStorV.png

                • 5. Re: Is it possible to reflash SSD with same firmware
                  ambizytl

                  I am not condemning anything, just stating that TRIM will not work in a RAID environment and that will affect the SSD over time, as it affects all SSD's that never get TRIMMED, unless one takes measures to "clean" the SSD.

                   

                  Benchmark results do not always reflect what the average user does. RAID 0 is to me a waste, unless you like to look at benchmark tests.

                  • 6. Re: Is it possible to reflash SSD with same firmware
                    freak77power

                    test.jpg

                    As you can see drives are totally messed up. SSD is really not good investment.

                    • 7. Re: Is it possible to reflash SSD with same firmware
                      freak77power

                      So i disabled Raid and switched to IDE, reinstalled Windows 7. I installed Intel ToolBox and WTF says doesn't support trimming on this SSD?

                       

                      Is it possible to do trim at all?

                      • 8. Re: Is it possible to reflash SSD with same firmware
                        Einride

                        Must be AHCI for Trim--you used IDE.  There is a thread in this forum with a link to a Microsoft article that shows how to enable AHCI in Win7 with a single registry edit.  Then you have to restart, change bios to use AHCI, and restart.  I have used it.  It works

                         

                        But first, while in IDE mode, try the optimizer in the Toolbox.  I believe that will work.  You do have G2 SSD, right.  Optimizer will not work on G1.

                        • 9. Re: Is it possible to reflash SSD with same firmware
                          vavabavava

                          okay, I have an answer.

                           

                          Don't try to do any serious things yet.

                           

                          I used to get 7.8 WEI with 160G2 and after a fresh OS installation it got stuck with 5.9.

                          I did reinstallation and it was still stuck at 5.9

                          and I changed the drivers for SATA controller from msahcl.sys  to any of RST drivers and the WEI was changed back to 7.7 (slightly less)

                          I was trying to figure out what was causing this....

                          c:\windows\performance\winsat\datastore\

                          there's disk assessment file.

                           

                          with the score of 5.9 i get this message

                           

                          <AvgThroughput kind="Sequential Read" units="MB/s" ioSize="65536" score="7.5">255.08917</AvgThroughput>

                          <AvgThroughput kind="Random Read" units="MB/s" ioSize="16384" score="7.9">227.35000</AvgThroughput>

                          <Responsiveness Kind="AverageIORate" units="ms/IO" score="6.0" factor="0.0">3.53000</Responsiveness>

                          <Responsiveness Kind="GroupedIOs" units="units" score="1.9" factor="1.0">19.05191</Responsiveness>

                          <Responsiveness Kind="LongIOs" units="units" score="1.9" factor="1.0">108.41583</Responsiveness>

                          <Responsiveness Kind="Overall" units="units" score="1.9" factor="1.0">2065.52908</Responsiveness>

                          <Responsiveness Kind="Cap" Reason="FAILED">TRUE</Responsiveness>

                           

                          with the score of 7.8 or 7.7 i get this message

                          <AvgThroughput kind="Sequential Read" units="MB/s" ioSize="65536" score="7.5">257.93583</AvgThroughput>

                          <AvgThroughput kind="Random Read" units="MB/s" ioSize="16384" score="7.9">229.59000</AvgThroughput>

                          <Responsiveness Kind="AverageIORate" units="ms/IO" score="7.7" factor="0.0">1.27000</Responsiveness>

                          <Responsiveness Kind="GroupedIOs" units="units" score="7.0" factor="0.0">10.84208</Responsiveness>

                          <Responsiveness Kind="LongIOs" units="units" score="7.9" factor="0.0">2.88768</Responsiveness>

                          <Responsiveness Kind="Overall" units="units" score="7.5" factor="0.0">31.30847</Responsiveness>

                          <Responsiveness Kind="Cap" Reason="PASSED">FALSE</Responsiveness>

                           

                          th

                          but

                          wit

                           

                          so the difference was changing the driver (*.sys) file.

                          I am not sure why it was casuing this but updating the driver with intel rst driver fixed it somehow.

                           

                          The next thing I tried was to change C-states in the bios menu, I turned it off and did reinstallation of windows 7

                          since then, I always get 7.8 with msahcl.sys driver.

                          results are

                           

                          <WinSPR>
                          <DiskScore>7.8</DiskScore>
                          </WinSPR>
                          - <Metrics>
                          - <DiskMetrics>
                          <AvgThroughput kind="Sequential Read" units="MB/s" ioSize="65536" score="7.6">266.90833</AvgThroughput>
                          <AvgThroughput kind="Random Read" units="MB/s" ioSize="16384" score="7.9">246.14000</AvgThroughput>
                          <Responsiveness Kind="AverageIORate" units="ms/IO" score="7.9" factor="0.0">1.09000</Responsiveness>
                          <Responsiveness Kind="GroupedIOs" units="units" score="7.0" factor="0.0">10.86463</Responsiveness>
                          <Responsiveness Kind="LongIOs" units="units" score="7.9" factor="0.0">2.69431</Responsiveness>
                          <Responsiveness Kind="Overall" units="units" score="7.5" factor="0.0">29.27264</Responsiveness>
                          <Responsiveness Kind="Cap" Reason="PASSED">FALSE</Responsiveness>
                          </DiskMetrics>

                           

                          hope this helps..

                          • 10. Re: Is it possible to reflash SSD with same firmware
                            Einride

                            Yes, indeed.  I was about to recommend to Carl2 changing the Raid driver to RST.  Then he posted that he had changed to non-Raid.  Carl2 might have been using the Matrix driver, which has always been flaky with SSDs.

                             

                            The jury is still out on what is triggering this change in WEI--and performance.  But I do not think it the SSDs themselves.

                             

                            Carl2, you should get the Intel Rapid Storage Controller (RST) driver.  Works with single or Raid, provides better performance, and--possibly--will fix your problem, if you still have it.  Look at Stationdrivers.com, under Drivers, Intel, Matrix Storage Controller.  RST is the replacement for the Matrix driver, with "enhancements" for SSDs.  Get RST version 9.5.6.  For Raid, the RST package installs a separate RST User Interface in the Start Menu.  Use this to enable the write-back cache, which will perk up IO performance.

                             

                            Message was edited by: Einride

                            • 11. Re: Is it possible to reflash SSD with same firmware
                              freak77power

                              I guess since i have Intel X25-M SSD toolbox doesn't support trimming or anything on it. Thanks for everybodies help. I took out this junk and threw it to garbage. I am running two Raid 0 setups with WD Raptor HDDs and i am happy.

                              • 12. Re: Is it possible to reflash SSD with same firmware
                                ambizytl

                                The drive isn't garbage, nor is the SSD Toolbox. TRIM does not work in a RAID environment.

                                 

                                One SSD is not fast enough for you? Well, if you really threw it away, the joke is on you since you not only threw away the SSD, but all the money you paid.

                                 

                                Anyway, you made some retailer happy.

                                • 13. Re: Is it possible to reflash SSD with same firmware
                                  freak77power

                                  I disabled RAID, enabled ACHI and tried to do Trim. Intel X25-M 80Gb is not supported by SSD Toolbox to do Trim on it. I just gave up on this thing. It's in my garbage box, maybe i will pull it out if Intel releases new firmware. I am planning to get some Laptop, will install it there and try to trim it under Linux Ubuntu 64.

                                  • 14. Re: Is it possible to reflash SSD with same firmware
                                    ambizytl

                                    Did you have Disk Defragmenter disabled or turned off for the SSD? Did you look at the readme for SSD Toolbox to see if there was something conflicting with your setup?

                                     

                                    With a properly setup SSD, G2 drive, TRIM should work either automatically or via SSD Toolbox.

                                    1 2 3 Previous Next