2 Replies Latest reply on Feb 28, 2010 1:27 AM by Kunal.natta

    DX58SO not booting, nothing happens

    locriology

      Hi everyone,

       

      I have a brand new system (all new parts) running a DX58SO with a Core i7 920 processor.  I have everything installed and plugged in correctly (this has been checked a thousand times).  There is a light on on the motherboard.  But when I press the power button, nothing happens.  No beeps, spinning fans, not even for a second.  I am certain the problem is not the power supply because I have tried three different ones, and all have the same behavior.  I have also tried manually shorting the power switch pins to test the case power switch - still nothing happens.  I've also removed the video card, RAM, hard drive, optical drive, and everything else unnecessary.

       

      My suspicion is that the motherboard is faulty, but I wonder if anyone has any ideas I have not yet thought of.  Thanks so much for all your help!

       

      Kyle

        • 1. Re: DX58SO not booting, nothing happens
          Boyet

          Try this link. It is assumed to be solved and is a similar situation as what you have now.

          1 of 1 people found this helpful
          • 2. Re: DX58SO not booting, nothing happens
            Kunal.natta

            See, the basic troubleshooting you have done like checking whether the processor fan is spining or not or whether the power supply is connected properly or not and if the components are working fine on a different system or not...as you checked the power supply and it seems that it is also working fine...i think u shd give these details to intel customer service along with your system information like ram fsb and processor sspec number and also that the processor fan is not spining and the you have changed the smps....i am sure they will issue a work order number wherein you will be able to send this motherboard for replacement...and one more advice, dnt forget to give your address details also...