8 Replies Latest reply on May 12, 2017 5:26 PM by Shimpei

    DCM install failed

    Hiroshi_Aso

      I tried Depth Camera Manager (DCM) Build Number: 2.1.27.2853 (110MB)  installer.

      But it was failed.

      1. error code:1603

          file:intel_rs_sdk_runtime_ia32_dcmservice_r200_2_1_27_2853.msi

      2.os :windows10 8Gbyte

      3.3D camera device :R200

       

      Please advice this problem.

        • 1. Re: DCM install failed
          MartyG

          Could you tell me the make and model number of the PC you are using the camera with please?  Thanks!

           

          Looking through past cases of people with this error, causes can include:

           

          - Having an incompatible processor chip; or

          - Needing to plug the camera into a mains-powered USB hub instead of plugging it directly into the PC.

          • 2. Re: DCM install failed
            Hiroshi_Aso

            PC spec. is below.

            1.Processor Intel(R) Core(TM)i5-6500 CPU@3.20Ghz

            2.RAM 8GB

            3.OS Windows 10.Pro

            4.PC-MK32MZDT(NEC)

             

            Rearsense SDK Essential can work

            but DCM can't be installed.

             

            Thank you,

            Aso

            • 3. Re: DCM install failed
              MartyG

              Your processor is a 6th generation Skylake architecture, so there's no problem there.  Your PC meets the specification for the camera.

               

              The correct order of installation is to install the DCM first and the Essentials SDK second.

               

              Another person recently had a problem with using that most recent DCM with their R200.  I recommended that they install the previous R200 DCM that came before that one.  Clicking on this link will launch the download of that DCM automatically.

               

              http://registrationcenter-download.intel.com/akdlm/irc_nas/9026/intel_rs_dcm_r200_2.1.24.6664.exe

               

              I also note that you mentioned the Essentials SDK (also known as '2016 R3').  Essentials will not work with the R200 camera, as the final SDK to support the R200 was '2016 R2'.  I recommend uninstalling Essentials and then downloading and installing 2016 R2 SDK using this link, which again starts the download automatically.

               

              http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/9078/intel_rs_sdk_offline_package_10.0.26.0396.exe

              • 4. Re: DCM install failed
                Hiroshi_Aso

                1.intel_rs_dcm_r200_2,1,24.6664.exe

                  Firmware Installing is failed and terminated. (Firmware update is failed).

                 

                Please inform the detailed procedure of update Firmware of R200.

                Thank you,

                Aso

                • 5. Re: DCM install failed
                  MartyG

                  There is a procedure that can force the camera's firmware to update.

                   

                  Re: The installer failed to detect an Intel(R) RealSense 3D camera on this system.

                  • 6. Re: DCM install failed
                    Hiroshi_Aso

                    I tried, but DCM instaration was failed.

                    – uninstalling SDK

                    – uninstalling DCM

                    – uninstalling all three R200 drivers in the DeviceManager

                    – unplug the R200

                    – reboot

                    – reopen the DCM installation

                    – plug the R200

                    – terminated.( same error occured)

                     

                    Do you know another action for this problem?

                    Is this Hardware or Firmware problem of the R200?

                    • 7. Re: DCM install failed
                      MartyG

                      Your problem seems to be with the firmware installation.  On the page that you got your list of steps from ("The installer failed to detect an Intel(R) RealSense 3D camera on this system"), that person solved their installation problem using a mains-powered hub instead of plugging the camera directly into their PC's USB port.  From your description, it sounds like you may have the same problem as that person. 

                       

                      As your PC meets the specification for RealSense, your symptoms strongly suggest that the camera is not being detected properly during the firmware installation process.  Purchasing and using a mains-powered hub with your camera may be your best chance of success.

                      • 8. Re: DCM install failed
                        Shimpei

                        Hi.

                        I met same troubles, and now fixed it.

                         

                        Setup files is below.

                          (1) intel_rs_dcm_r200_2.1.27.2853.exe

                          (2) intel_rs_sdk_offline_package_10.0.26.0396.exe

                         

                        At first time installing (1), it was failed with error code 1603, and it was happend at extract [Microsoft Visual C++ 20xx Redistributable(xNN)].

                         

                        So, I uninstalled VisualStudio and those packages, after that I could install (1), (2) and now I can use my R200 camera.

                         

                        >MartyG

                        Thanks for your information about R200's Essentials SDK ver.