1 2 Previous Next 22 Replies Latest reply on Apr 11, 2017 5:22 PM by Intel Corporation

    Drone does not work

    Soubhi

      Hi

       

      I have Intel Aero Drone. I went over all the instructions and tried to arm the motor using the remote control but nothing happened. No response at all. I connected to drone AP using my phone and tried to control the drone using Qgroundcontrol app. I could change the flight mode but nothing more worked. The arm command always rejected.

      I updated the OS, BIOS, FPGA and PX4 to lasted version but nothing changed.

      How can I figure out whether the problem is in hardware or software?

       

      Another question, In the released notes, you mentioned that dronekit is available in the OS. I tried to connect using dronekit but I got exceptions when I tried to execute:

      vehicle = dronekit.connect('udpin:127.0.0.1:14550') 

      I got exceptions like :

      Exception in message handler for HEARTBEAT. 
      mode 65536 not available on mavlink definition.
      PREFLIGHT FAIL : MAG #0 UNCALIBRATED.
      ......

      But when I tried to connect using mavlink-routerd like :

      mav = mavutil.mavlink_connection('udpin:127.0.0.1:14550') 

      It works perfectly and I get HEARTBEAT packets.

      I am really confused why it cannot connect using dronekit. Is it possible to be related to the first issue so that dronekit cannot connect to drone?

      I hope you can help me to solve that problem as soon as possible.

      Soubhi.

        1 2 Previous Next