1 2 Previous Next 25 Replies Latest reply on Mar 29, 2017 12:54 PM by Intel Corporation

    Unable to connect intel centrino n135 wifi card to Intel galileo gen2

    mishra007

      Hi friends!

      FGT

      Today I got all the accessories for setting up wifi card on my intel galileo gen 2.I have fixed everything on intel galileo as explained in sergey malinov's blog. I even got as far as setting SSID and password in supplicant.conf file of intel galileo gen2.However I am stuck in the stage wherein I have to modify the /etc/network/interfaces file to let galileo gen 2 to connect to my wifi router automatically as soon as I power it up.

      Here are the pics.Kindly help me step by step so that I can
      1)Run the wlan0 by using ifup wlan0

      2)Set galileo gen 2 to connect to my wifi router automatically everytime it boots up.

      IMG_20170318_155957.jpg

      IMG_20170318_161444.jpg

      errors that it is showing:

      ifup.png

      and when I do- vim /etc/network/interfaces it starts creating a directory in vim! I am baffled!

      Also I could see the driver for n135 in list of firmware.

      firm.png

        • 1. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
          FGT

          Hi mishra007,

           

          Sorry, I can't help, I don't have such an adapter. I've always used the much more cheaper ESP8266 for wifi.

           

          Fernando.

          • 2. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hello mishra007,

             

            Thanks for reaching out!

             

            The N135 is actually the wireless card that I use with my Galileo. I used to set up the wireless interface by following Sergey's guide when I used the uclibc image but with the latest eglibc image (which can be downloaded from https://software.intel.com/en-us/iot/hardware/galileo/downloads) this is not necessary. I use connman to set the interface up. These are the steps I take from a fresh flash of the image:

             

            systemctl start connman
            connmanctl
            enable wifi
            agent on
            scan wifi
            services
            #Check for the service name of your network and copy it
            connect SERVICE_NAME_XXXXXXXXX
            #Enter the network's password
            quit

             

            You can check the screenshot below of my Galileo's output during this process.

             

            galileo.JPG

             

            I hope this information helps you,
            Pedro M.

            • 3. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
              mishra007

              Intel Corporation wrote:

               

              Hello mishra007,

               

              Thanks for reaching out!

               

              The N135 is actually the wireless card that I use with my Galileo. I used to set up the wireless interface by following Sergey's guide when I used the uclibc image but with the latest eglibc image (which can be downloaded from https://software.intel.com/en-us/iot/hardware/galileo/downloads) this is not necessary. I use connman to set the interface up. These are the steps I take from a fresh flash of the image:

               

              systemctl start connman
              connmanctl
              enable wifi
              agent on
              scan wifi
              services
              #Check for the service name of your network and copy it
              connect SERVICE_NAME_XXXXXXXXX
              #Enter the network's password
              quit

               

              You can check the screenshot below of my Galileo's output during this process.

               

              galileo.JPG

               

              I hope this information helps you,
              Pedro M.

              Hi pedro!

              THanks for replying but,when I run- systemctl start connman -- it just takes forever to run it! Here is the snapshot-systemctl.png

              Currently I have connected intel galileo gen 2 with my router using an ethernet cable.And when I run that above command it shows multiple IPs assigned.For instance I have set static IP to my galileo using the arduino sketch prescribed by FGT long time back.And it was working perfectly fine.However when I run systemctl start connman,firstly it just keeps running forever,I mean it doesnt return any prompt(# symbol) and secondly,another IP gets assigned to my galileo(192.168.0.104). It is just strage,any idea what might be wrong?It has already taken 3-4 days!

              sc1.xcf

              Also when I ssh to 192.168.0.104,it results in a succesful connection.Now when I run connmanctl,it gets run. However scan wifi commands results in failure.I am attaching the pics below-
              sc2.png

              • 4. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                That is unexpected. I believe, this might be related to the image, therefore, I'd suggest you to download the image from https://software.intel.com/en-us/iot/hardware/galileo/downloads and set up your SD card as explained in https://software.intel.com/en-us/get-started-galileo-linux-step1 then try the steps above again. 

                Let me know.
                Pedro M.

                • 5. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                  mishra007

                  Intel Corporation wrote:

                   

                  That is unexpected. I believe, this might be related to the image, therefore, I'd suggest you to download the image from https://software.intel.com/en-us/iot/hardware/galileo/downloads and set up your SD card as explained in https://software.intel.com/en-us/get-started-galileo-linux-step1 then try the steps above again.

                  Let me know.
                  Pedro M.

                  You want me to download latest yocto pocky image right?210MB one?

                  • 6. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                    FGT

                    Hi mishra007,

                     

                    mishra007 wrote:

                     

                    Intel Corporation wrote:

                     

                    That is unexpected. I believe, this might be related to the image, therefore, I'd suggest you to download the image from https://software.intel.com/en-us/iot/hardware/galileo/downloads and set up your SD card as explained in https://software.intel.com/en-us/get-started-galileo-linux-step1 then try the steps above again.

                    Let me know.
                    Pedro M.

                    You want me to download latest yocto pocky image right?210MB one?

                     

                    I'd try with that one too, and I'd avoid using or downloading anything else, i.e. use the last image "as is" (without downloading any sketch to the Intel Galileo, in particular), which I think is exactly what Pedro M. suggested/did/exemplified above.

                     

                    HTH,

                     

                    Fernando.

                    • 7. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                      mishra007

                      FGT wrote:

                       

                      Hi mishra007,

                       

                      mishra007 wrote:

                       

                      Intel Corporation wrote:

                       

                      That is unexpected. I believe, this might be related to the image, therefore, I'd suggest you to download the image from https://software.intel.com/en-us/iot/hardware/galileo/downloads and set up your SD card as explained in https://software.intel.com/en-us/get-started-galileo-linux-step1 then try the steps above again.

                      Let me know.
                      Pedro M.

                      You want me to download latest yocto pocky image right?210MB one?

                       

                      I'd try with that one too, and I'd avoid using or downloading anything else, i.e. use the last image "as is" (without downloading any sketch to the Intel Galileo, in particular), which I think is exactly what Pedro M. suggested/did/exemplified above.

                       

                      HTH,

                       

                      Fernando.

                      Hi Fernando!

                      Thanks for replying! I download the fresh image as suggested by Mr Pedro and flashed it onto another sd card.Now when I run systemctl start connman,it results in success. I am able to follow all his steps until -- connect SERVICE_NAME_name_of_my_network. It throws this error-

                      connman.png

                      PS:GotOurOwnWifi is the name of my network

                      • 8. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi mishra007,

                        You are almost there, now, instead of entering the command connect SERVICE_NAME_GotOurOwnWifi, look for GotOurOwnWifi after entering the command services and check the ID next to it, it should look like this:

                        GotOurOwnWifi wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX

                        Copy that ID and enter the command connect wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX, now this should work for you.

                        Pedro M.

                        • 9. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                          mishra007

                          Intel Corporation wrote:

                           

                          Hi mishra007,

                          You are almost there, now, instead of entering the command connect SERVICE_NAME_GotOurOwnWifi, look for GotOurOwnWifi after entering the command services and check the ID next to it, it should look like this:

                          GotOurOwnWifi wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX

                          Copy that ID and enter the command connect wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX, now this should work for you.

                          Pedro M.

                          Thanks for help I will try it once again. And FGT,can you kindly send me that arduino code once again,I mean the one that you sent me for setting static ip to intel galileo long time back.Actually my arduino IDE for intel wasnt working when I moved the folder containing intel arduino IDE to one of the window partitions(as my linux partition is almost full now)-- so I deleted it and installed a fresh and now I dont have your code!Damn should have saved it!. Sorry for the trouble!
                          But now it shows some error +111 or something in relocate_script.sh .I mean wtf!

                          • 10. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                            FGT

                            Hi mishra007,

                             

                            mishra007 wrote:

                             

                            Intel Corporation wrote:

                             

                            Hi mishra007,

                            You are almost there, now, instead of entering the command connect SERVICE_NAME_GotOurOwnWifi, look for GotOurOwnWifi after entering the command services and check the ID next to it, it should look like this:

                            GotOurOwnWifi wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX

                            Copy that ID and enter the command connect wifi_0cd229205aa3c_XXXXXXXXXXXXXXXXXXXXXX, now this should work for you.

                            Pedro M.

                            Thanks for help I will try it once again. And FGT,can you kindly send me that arduino code once again

                            ...

                            Sure,

                             

                            I suggest you try first to solve your wifi related issues first, because I think fixed IP set by the sketch may be in conflict with connman operation. Hopefully, it is not the case, but just to avoid possible "noise" I suggest you follow all the suggestions Pedro M. and maybe other Intel people provides before you use a sketch for modifying ethernet interface settings.

                             

                            For setting a fixed IP in the latest yocto image you should have only one line in your setup function:

                             

                            system("ifconfig enp0s20f6 <your_fixed_ip> netmask 255.255.255.0");

                             

                            Please tell me in case you have issues with this setting.

                             

                            HTH,

                             

                            Fernando.

                            • 11. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              I agree with Fernando, we should finish with the Wi-Fi issue before proceeding further. Just to clarify, you can also use the command suggested by Fernando directly on Linux, you would only need to remove the system(""), so the command would look like this:
                               
                              ifconfig enp0s20f6 <your_fixed_ip> netmask 255.255.255.0
                               
                              If the reason why you were using a sketch is because you need to run the command every time on boot, perhaps you'd be interested in reading this document: https://communities.intel.com/docs/DOC-111103.
                               
                              I hope this helps.
                              Pedro M.

                              • 12. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                                mishra007

                                Intel Corporation wrote:

                                 

                                I agree with Fernando, we should finish with the Wi-Fi issue before proceeding further. Just to clarify, you can also use the command suggested by Fernando directly on Linux, you would only need to remove the system(""), so the command would look like this:

                                ifconfig enp0s20f6 <your_fixed_ip> netmask 255.255.255.0

                                If the reason why you were using a sketch is because you need to run the command every time on boot, perhaps you'd be interested in reading this document: https://communities.intel.com/docs/DOC-111103.

                                I hope this helps.
                                Pedro M.

                                Hi pedro!

                                              Ok,I installed the latest arduino IDE from arduino website and went on to further install add-on files for i586(i.e galileo). But now when I connect my galileo gen and try to flash the scannetwork code,I get the following error.In fact I get this error regardless of the code. I even checked if the file exists or now,but amazingly it does exist.I am simply baffled as to why it is throwing such an error.

                                2017-03-24-084605_1366x768_scrot.png

                                Btw,this is the kind of error that I got when I tried installing the i586 package in arduino IDE for my gen 2.

                                2017-03-24-090803_1366x768_scrot.png

                                I tried following your steps,to create a service routine in systemd/system directory. I named it staticip.service. But it still isnt able to set the static ip(192.168.0.110) to my galileo upon start. /home/root/static_ip.sh script works flawlessly though when I execute it! So I guess there is some problem with the way I have defined my service routine.

                                I am attaching the pics below.Also I have already made the /home/root/static_ip.sh executable.
                                I will summarize what I did,so that it become easy for you to follow-
                                1)Created a executable shell script in /home/root by the name static_ip.sh that has command to set static ip.
                                2)Then created a .service file in /lib/systemd/system directory by the name staticip.service

                                3) Issued the command systemctl enable staticip.service

                                4) Reboot

                                2017-03-24-173116_1366x768_scrot.png

                                • 13. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Try with the following:

                                  static_ip.sh:

                                  #!/bin/sh
                                  ifconfig wlp1s0 192.168.10.12 netmask 255.255.255.0

                                  static_ip.service

                                  #!/bin/sh
                                  [Unit]
                                  Description=Sets static ip on boot
                                  Requires=wpa_supplicant.service
                                  After=wpa_supplicant.service
                                  [Service]
                                  ExecStart=/home/root/static_ip.sh
                                  Type=idle
                                  [Install]
                                  WantedBy=basic.target

                                  I tried this and it worked for me. Let me know how it goes for you.
                                  Pedro M.

                                  • 14. Re: Unable to connect intel centrino n135 wifi card to Intel galileo gen2
                                    mishra007

                                    Intel Corporation wrote:

                                     

                                    Try with the following:

                                    static_ip.sh:

                                    #!/bin/sh
                                    ifconfig wlp1s0 192.168.10.12 netmask 255.255.255.0

                                    static_ip.service

                                    #!/bin/sh
                                    [Unit]
                                    Description=Sets static ip on boot
                                    Requires=wpa_supplicant.service
                                    After=wpa_supplicant.service
                                    [Service]
                                    ExecStart=/home/root/static_ip.sh
                                    Type=idle
                                    [Install]
                                    WantedBy=basic.target

                                    I tried this and it worked for me. Let me know how it goes for you.
                                    Pedro M.

                                    Hi Pedro!

                                    Thanks a lot for replying.I got it working after some trial and error.I changed the location of my executable bash script from /home/root to /usr/bin and then changed the ExecStart=/usr/bin/static_ip.sh and now it is working flawlessly! THanks a lot!

                                    1 2 Previous Next