3 Replies Latest reply on Mar 14, 2017 1:17 PM by Intel Corporation

    on Edison, with OpenCV, function imshow() results in error "cannot open display"

    M.Hawana

      Hello, I'm hoping someone can shed some light on an issue I'm seeing when I'm running an  OpenCV program using the  Edison development board.

      I ran a tutorial of OpenCV (using C++ Visual Studio). I'm successful with running the tutorial application by uploading it to Edison, and I can read images, process them and generate output images. After my program completes, to examine my images, I use the web browser on my host.  That all works fine (though a bit cumbersome).

       

      However, I want to change my program to see if I can have it create a window and display the image itself. So, I added this line to my program

                 imshow( imageName, image );

       

      but now, when I run this program on Edison,  I get an error :

         "(izzy.jpg:1179): Gtk-WARNING **: cannot open display: "

       

      I don't think this is an OpenCV issue, rather my guess it's an environment issue of my Linux (i'm not sure).

      (FYI:  to learn what my edison sw version is I did:  

          % configure_edison --version

            159

      )

       

      Any help on this issue is much appreciated. Thank you.

       

      Intel® EdisonSupport Community