14 Replies Latest reply on Apr 19, 2017 12:34 AM by Ev_R

    Aero - USB3 OTG port is functional in USB2 mode only

    Ev_R

      Hello,

      I'm trying to connect USB3 devices via USB3 OTG port:

       

      I have a self-powered USB3 hub connected to the USB3 OTG port with USB3 cable (SS Micro A <-> SS Micro B, see attached).

      When I attach a mouse and keyboard - they run properly. But any USB3 device attached to the hub, including  USB3 DiskOnKey, are not recognized at all.

      When I run 'dmesg'  - there are no logs whatsoever, when USB3 devices is plugged in or out. And the devices are not listed with 'lsusb', 'lsblk' or similar commands.

      Even more- USB3 DiskOnKey is not even recognized in BIOS as a boot device, so I thinkg it could be on BIOS level.

       

      At the end I managed to connect a Depth camera via R200 USB3 interface, and it is working properly (albeit via a 2nd self-powered USB3 hub), but is this the only way to connect USB3 devices to the board ?

      During my attempts to make it work I also upgraded the BIOS from 01.00.03 to the latest version posted ( capsule-01.00.12-r0.core2_64.rpm), but the results are the same - USB3 devices are not recognized.

       

      I tried to look up the documentation but could find any indications that OTG port does not support USB3 protocol.

       

      Q: Does the USB3 OTG is configured to run in USB3 mode by default ? If yes - what are the settings in BIOS that control its behavior ?

           If USB3 is currently not supported for OTG port - please update on ETA for this to be functional.

       

      I tested it with two types of powered USB3 adapters and also two almost identical Aero  boards ( BIOSes 1.0.03 and 1.0.04) and none of the configurations recognized USB3 on OTG port.

      Aero boards s.n: IC00934 and IC00623.

       

      Any help will be appreciated,

       

      BR,

      Evgeni