13 Replies Latest reply on May 15, 2017 1:46 PM by Astounding

    NUC7i3BNK DisplayPort over USB Type-C Not Working?

    JesseDG

      Hello.

       

      • Purchased the NUC7i3BNK  (the short, 7th gen i3 NUC), to power a pair of 2k ASUS displays.
        • Paired with 16GB stick of ram and NVME drive, running Arch Linux (on off-chance that's relevant).
        • This is for programming only, so the underpowered graphics should still be enough for this purpose.
      • Setup is as follows:
        • nuc ~> hdmi-out ~> monitor1   (works, although xrandr detects it as a displayport monitor for some reason)
        • nuc ~> displayport over usb type-c ~> monitor2   (monitor is not detected whatsoever, using dp over type-c adapter)

       

      After purchasing the NUC and looking over the spec sheet closer I noticed that this generation has removed the mini-displayport connector in favor of DP over the USB Type-C port.

      If I had known this at the time of purchase I would have opted for something else, possibly one of the prior generation, but since it was already coming I went and purchased a cable to go from that output to a full-size displayport input on the monitor.

       

      After having it not work and thinking it was DOA (monitor was not detected whatsoever) I ended up returning it to the manufacturer, and bought two other cables from different manufacturers, doing the same thing, one in adapter form, one in cable form.

      The latter has yet to arrive, but the former has and unfortunately is giving me the same result as the original cable.  For clarity's sake, here are links to the NUC, monitors, and two of the three cables I purchased (link broke for the original cable).

       

       

      The NUC specs say it does DP 1.2 over USB Type-C, and the monitor specs say it takes DP 1.2 fullsize in... I don't know what else I'm expected to do to get this to work besides having bought the cable to connect the two.

      I've sunk nearly $100 into cables now, trying to get this system to work with the second monitor... which is rediculous considering this was supposed to be a cheap little compact system that I could chuck an NVME drive into and drive my two monitors with, and easily take to work and back if needed.

       

      I don't have any other devices that would let me test the adapter, but the chances of two from different brands being DOA has to be very, very low.

      Have investigated BIOS updates for the device... says its running the 0036 revision, the latest one shown on the download page.

       

      Any help with this would be greatly appreciated... haven't been able to find anything online about people having similar issues... seems nobody is really trying to do dual displays with these NUC systems, despite the advertising push for that use-case.

      After having sunk this much time and money into it, would much rather get the issue solved than have to get rid of it on eBay or wherever and take an even greater loss on the system.

       

      (thank you for getting this far through my less than concise description of the issue here, by the way)