4 Replies Latest reply on Mar 20, 2017 4:00 PM by Intel Corporation

    Intel HD 3000 not stretching / black bars problem


      I have windows 10 64 bit with intel HD 3000 graphics and nvidia gt740m on a laptop.

      Until yesterday i was playing in 4:3 aspect ratio in a game (counter strike) and everything was fine (stretched). Today when i logged in the game it had black bars. Nothing changed since yesterday, i just logged off at night and logged back in today.

      Here is my update history. http://prntscr.com/eg0di0

      I am searching on the issue for multiple hours and still haven't found a fix. My nvidia control panel doesn't have a display tab so i can change scaling option from the intel control panel. Also because my intel hd is 3000 thats the control panel i get with the latest driver i can install. http://prntscr.com/eg0j34 Do you see were it says scaling? There i have maintain display scaling or scale fullscreen on all resolutions. This prevents the black bars from appearing on desktop. But when i launch csgo they appear. If i keep the intel control panel on the laptop screen (i am using a monitor for my main display) when i launch csgo the option in the scaling field changes to "Maintain Aspect Ratio". If i try to change it back, when i click on the control panel or alt tab to it, it changes back to the options i had selected before.

      If i play the game on Windowed Fullscreen, then csgo doesn't magically override my display settings and i can play on 4:3 stretched, but the input lag is too big.

      I have tried reinstalling drivers, updating them, messing around with different resolutions even changing some registry values (https://www.reddit.com/r/GlobalOffensive/comments/4hneko/black_bars_issues_on_windows_10/d2r21ki/) but nothing works. And yesterday everything was just fine! I installed HRC also and tried it but when i press the hotkey to change to the lower resolution the same problem (black bars) appear on my desktop also. Which means by default it changes to maintain aspect ration in the intel control panel. I can see some correlation there but i can't figure out a way to find it.

      Only workaround is to hit Ctrl+Alt+f11 which the hotkey for panel fitting http://prntscr.com/eg2lco 2 times and then it stretches. Meaning, on the intel control panel on my laptop screen the scaling field (which magically changed to "maintain aspect ratio" when i launched to game) changes back to maintain display scaling. Problem with this is it changes the whole screen resolution so i have to change it back when i quit the game.

      Any ideas? Do you know were i can find something similar to override application settings as show here? http://prntscr.com/eg0p0q (i cant get the above control panel to show). Do you think its a driver issue? I have the latest. Or maybe intel/microsoft/valve changed something internally in 1 night? If so can something be done or its an old model and intel just dont care anymore?

        • 1. Re: Intel HD 3000 not stretching / black bars problem
          Al Hill

          Sorry, but HD3000 graphics are not supported on Windows 10Supported Operating Systems for Intel® Graphics Products


          If you want to try the latest Microsoft driver for HD 3000 graphics for Windows 10,you can find it here:  Microsoft Update Catalog


          However, you should be using the drivers provided by the manufacturer of your laptop, as it has switchable graphics and they may have modified the drivers for such.


          You should also check if Windows 10 is supported on your laptop.



          • 2. Re: Intel HD 3000 not stretching / black bars problem

            In the second link you provided first on the list is the driver. Is that the latest? i am using the one. Also in the last updated the first is updated on an earlier date than the following 2. Any explanation?


            Also a little off topic question.

            If i can disable nvidia Optimus from the BIOS, will i be able to manage the display options from the nvidia control panel and get the full menu instead of only "3d Settings"? Also, if i can disable, i know it will consume more power but will i get some increased performance (and possible black bars fix) on my games?

            If i disable Optimus, can i reenable it later on?

            • 3. Re: Intel HD 3000 not stretching / black bars problem
              Al Hill

              Yes, appears to be the latest.


              I cannot explain the dates.  Additionally, that is a Microsoft site.


              For any management of your switchable graphics, you must ask the manufacturer of the laptop.



              • 4. Re: Intel HD 3000 not stretching / black bars problem
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello all,


                bananas, Doc is right; from our end there are no drivers available for Windows® 10 and the Intel® HD Graphics 300. I recommend sticking with the supported operating systems which in this case are the following;

                • Windows 7*
                • Windows 8*
                • Windows 8.1


                Check the link provided above for more information on the supported operating systems.


                Regarding your second input, the best place to get more answers for your switchable graphics is your computer manufacturer.