2 Replies Latest reply on Mar 9, 2017 7:10 PM by Intel Corporation

    82599ES 10-Gigabit connected to 1G port

    agn82kv

      I have a 10G 82599ES intel card on Ubuntu 14.04.5 LTS , details below :

      description: Ethernet interface

      product: 82599ES 10-Gigabit SFI/SFP+ Network Connection

      vendor: Intel Corporation

      physical id: 0

      bus info: pci@0000:86:00.0

      logical name: eth8

      version: 01

      serial: 90:e2:ba:c8:52:1c

      width: 64 bits

      clock: 33MHz

      capabilities: pm msi msix pciexpress bus_master cap_list rom ethernet physical fibre

      configuration: autonegotiation=off broadcast=yes driver=ixgbe driverversion=3.15.1-k firmware=0x61b50001 latency=0 link=no multicast=yes

      resources: irq:64 memory:fb180000-fb1fffff ioport:e020(size=32) memory:fb204000-fb207fff memory:fb580000-fb5fffff memory:fb900000-fb9fffff memory:fb80000

       

      Other side is 1G port , i see link is not getting detected when cable is connected

      root@blrvbng03:~# ethtool eth9

      Settings for eth9:

              Supported ports: [ FIBRE ]

              Supported link modes:   10000baseT/Full

              Supported pause frame use: No

              Supports auto-negotiation: No

              Advertised link modes:  10000baseT/Full

              Advertised pause frame use: No

              Advertised auto-negotiation: No

              Speed: Unknown!

              Duplex: Unknown! (255)

              Port: Other

              PHYAD: 0

              Transceiver: external

              Auto-negotiation: off

              Supports Wake-on: d

              Wake-on: d

              Current message level: 0x00000007 (7)

                                     drv probe link

              Link detected: no

      root@blrvbng03:~#

       

      Try setting the speed to 1000 and auto negotiation also, but failing

       

      root@blrvbng03:~# ethtool -s eth9 autoneg on

      Cannot set new settings: Invalid argument 

        not setting autoneg                     

      root@blrvbng03:~#

      root@blrvbng03:~# ethtool -s eth9 advertise 0x020

      Cannot set new settings: Invalid argument

      root@blrvbng03:~#

       

      How i can resolve this issue ?

       

      Thanks,

      Agnel.