3 Replies Latest reply on Mar 1, 2017 12:29 PM by Intel Corporation

    Playing Fallout Shelter causes Display driver stopped responding and has recovered

    Wally_

      Hello,

       

      I had no problem with graphics until I started play Fallout Shelter . After playing this game some time (cca 20 hours) it started crash (TDR) about every 5 minutes. I tried many version of driver (including latest Beta 15.45.4614) and with all drivers I have same behavior and I can reproduce it at 100%. On other computers (including different Intel graphic card) same game does not crash.

       

      My configuration:

      Asus Zenbook UX305CA

      CPU: Intel Core M5 6Y54 Skylake,

      OS: Windows 10 14393

      GPU: Intel HD Graphics 515

      RAM: 8GB

       

      I forced Windows to do BUG CHECK instead of resetting driver so I have also minidump and I can provide it (or test other things). Here is some info from WinDbg:

       

      DUMP_CLASS: 1

      DUMP_QUALIFIER: 400

      BUILD_VERSION_STRING:  10.0.14393.693 (rs1_release.161220-1747)

      SYSTEM_MANUFACTURER:  ASUSTeK COMPUTER INC.

      SYSTEM_PRODUCT_NAME:  UX305CA

      SYSTEM_SKU:  ASUS-NotebookSKU

      SYSTEM_VERSION:  1.0     

      BIOS_VENDOR:  American Megatrends Inc.

      BIOS_VERSION:  UX305CA.300

      BIOS_DATE:  06/08/2016

      BASEBOARD_MANUFACTURER:  ASUSTeK COMPUTER INC.

      BASEBOARD_PRODUCT:  UX305CA

      BASEBOARD_VERSION:  1.0     

      DUMP_TYPE:  2

      BUGCHECK_P1: ffffda89a3a5d010

      BUGCHECK_P2: fffff80d9ae42f60

      BUGCHECK_P3: 0

      BUGCHECK_P4: 1

      FAULTING_IP:
      igdkmd64+12f60
      fffff80d`9ae42f60 4055            push    rbp

      DEFAULT_BUCKET_ID:  CODE_CORRUPTION

      CPU_COUNT: 4

      CPU_MHZ: 5e8

      CPU_VENDOR:  GenuineIntel

      CPU_FAMILY: 6

      CPU_MODEL: 4e

      CPU_STEPPING: 3

      CPU_MICROCODE: 6,4e,3,0 (F,M,S,R)  SIG: 8A'00000000 (cache) 8A'00000000 (init)

      CUSTOMER_CRASH_COUNT:  1

      BUGCHECK_STR:  0x116

      PROCESS_NAME:  System

      CURRENT_IRQL:  0

      ANALYSIS_SESSION_HOST:  WALLY-I5

      ANALYSIS_SESSION_TIME:  02-26-2017 19:25:34.0257

      ANALYSIS_VERSION: 10.0.14321.1024 amd64fre

      STACK_TEXT: 
      ffff9c01`dab7b748 fffff80d`989fba88 : 00000000`00000116 ffffda89`a3a5d010 fffff80d`9ae42f60 00000000`00000000 : nt!KeBugCheckEx
      ffff9c01`dab7b750 fffff80d`989fb1ac : fffff80d`9ae42f60 ffffda89`a3a5d010 ffff9c01`dab7b859 00000000`00000000 : dxgkrnl!TdrBugcheckOnTimeout+0xec
      ffff9c01`dab7b790 fffff80d`9ba277b5 : ffffda89`a3a5d010 00000000`001687d0 00000000`00000009 fffff80d`9889909d : dxgkrnl!TdrIsRecoveryRequired+0x1ac
      ffff9c01`dab7b7c0 fffff80d`9ba83842 : ffffda89`a814b000 00000000`00000002 ffffda89`a814b000 ffffda89`a814d000 : dxgmms2!VidSchiReportHwHang+0x4c1
      ffff9c01`dab7b8c0 fffff80d`9ba62b87 : 00000000`00000002 00000000`0000e5ac 00000000`001687d0 00000000`00000001 : dxgmms2!VidSchiCheckHwProgress+0x20772
      ffff9c01`dab7b930 fffff80d`9ba0a4b4 : ffffda89`a8714550 ffffda89`a814d000 ffffda89`a8714558 00000000`00000002 : dxgmms2!VidSchiWaitForSchedulerEvents+0x337
      ffff9c01`dab7b9f0 fffff80d`9ba6ec1f : ffffda89`aa273700 ffff9c01`dab7bb50 ffffda89`aa273700 ffffda89`00000000 : dxgmms2!VidSchiScheduleCommandToRun+0x3d4
      ffff9c01`dab7bb00 fffff80d`9ba6ebe0 : ffffda89`a814d500 ffffda89`a814d000 00000000`00000080 fffff80d`9ba6eb60 : dxgmms2!VidSchiRun_PriorityTable+0x2f
      ffff9c01`dab7bb50 fffff801`33c86729 : ffff9c01`d7580180 fffff801`33dd3adf 00000000`00979189 ffffda89`a814e7c0 : dxgmms2!VidSchiWorkerThread+0x80
      ffff9c01`dab7bb90 fffff801`33dd3bb6 : ffff9c01`d7580180 ffffda89`a814e7c0 fffff801`33c866e8 00000000`00000000 : nt!PspSystemThreadStartup+0x41
      ffff9c01`dab7bbe0 00000000`00000000 : ffff9c01`dab7c000 ffff9c01`dab75000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


      STACK_COMMAND:  kb

      CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
          fffff80133cee9bd - nt!MiInsertNonPagedPoolOnSlist+45d
      [ f6:c2 ]
      1 error : !nt (fffff80133cee9bd)

      MODULE_NAME: memory_corruption

      IMAGE_NAME:  memory_corruption

      FOLLOWUP_NAME:  memory_corruption

      DEBUG_FLR_IMAGE_TIMESTAMP:  0

      MEMORY_CORRUPTOR:  ONE_BYTE

      FAILURE_BUCKET_ID:  MEMORY_CORRUPTION_ONE_BYTE

      BUCKET_ID:  MEMORY_CORRUPTION_ONE_BYTE

      PRIMARY_PROBLEM_CLASS:  MEMORY_CORRUPTION_ONE_BYTE

      TARGET_TIME:  2017-02-26T16:22:34.000Z

      OSBUILD:  14393

      OSSERVICEPACK:  693

      SERVICEPACK_NUMBER: 0

      OS_REVISION: 0

      SUITE_MASK:  784

      PRODUCT_TYPE:  1

      OSPLATFORM_TYPE:  x64

      OSNAME:  Windows 10

      OSEDITION:  Windows 10 WinNt TerminalServer SingleUserTS Personal

      OS_LOCALE:

      USER_LCID:  0

      OSBUILD_TIMESTAMP:  2016-12-21 07:50:57

      BUILDDATESTAMP_STR:  161220-1747

      BUILDLAB_STR:  rs1_release

      BUILDOSVER_STR:  10.0.14393.693

      ANALYSIS_SESSION_ELAPSED_TIME: 1608

      ANALYSIS_SOURCE:  KM

      FAILURE_ID_HASH_STRING:  km:memory_corruption_one_byte

      FAILURE_ID_HASH:  {ad110d6a-3b33-2c0a-c931-570eae1ba92d}

       

      fffff80d`9ae30000 fffff80d`9b8e0000   igdkmd64 T (no symbols)         

          Loaded symbol image file: igdkmd64.sys

          Image path: \SystemRoot\System32\DriverStore\FileRepository\igdlh64.inf_amd64_463164d40c3d26ce\igdkmd64.sys

          Image name: igdkmd64.sys

          Browse all global symbols  functions  data

          Timestamp:        Fri Nov 11 20:21:37 2016 (58261A41)

          CheckSum:         00A918F0

          ImageSize:        00AB0000

          Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4

        • 1. Re: Playing Fallout Shelter causes Display driver stopped responding and has recovered
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Wally_,
           
          Thank you for contacting the Intel community.
           
          This error shows that there was a time-out error accessing the Video card. This can be caused by software (drivers or applications) or hardware (GPU, RAM or Motherboard). Please bear in mind that since driver version 15.40.22.4424 this issue was resolved, all drivers since that date include this fix. You already tried known good working drivers, so I would suggest trying the following:
           
          Uninstall the Beta driver; please see Uninstalling the Intel® Graphics Driver and Intel® Display HDMI/Audio Driver
           
          Once the Beta driver is uninstalled, go ahead and install the driver version 4590 manually, please check how to Manually Install an Intel® Graphics Driver in Windows® 10 and Windows 8*/8.1*
           
          NOTE: The driver or software for your Intel® component might have been changed or replaced by the computer manufacturer. We recommend you work with your computer manufacturer before installing our driver so you don’t lose features or customizations.
           
          Ensure that your Microsoft* operating system is up to date and as well the Microsoft* .NET Framework software. Some issues (such as the stopped responding/successfully recovered error message) can be fixed with a simple update to the systems .NET Framework* software. This software is available from the Microsoft Web site.
           
          If the issue persists contact your computer manufacturer and install their latest driver, uninstall the Intel® generic driver and install the driver from ASUS. Original Equipment Manufacturers (OEM) may have customized the generic Intel® Drivers to match their specifications or requirements.
           
          All OEMs should have access to newer Intel® graphics driver versions that contain this fix.
          https://www.asus.com/us/Notebooks/ASUS-ZenBook-UX305CA/HelpDesk_Download/
          NOTE: This link is being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.
           
           
          Best regards,
           
          Ivan.
           

          • 2. Re: Playing Fallout Shelter causes Display driver stopped responding and has recovered
            Wally_

            Hello Ivan (intel_corp),

             

            thank you for general answers. But what I need is technical solution how to find where is problem. You mentioned some type of drivers that should I try. But I tried all you mentioned, detaily:

             

            20.19.15.4364 (From Asus page you mentioned)

            20.19.15.4474 (From Asus)

            21.20.16.4550 (these are automatically installed by Windows Update)

            21.20.16.4614 (beta manually installed from Intel side)

            And all have same behavior - graphic driver reset after few minutes of playing. All! That means installing driver from Asus did not helped, installing latest beta did not helped, installing from Windows update did not helped. So my private bet that problem is somewhere in graphic driver regarding to Skylake chipset. It somehow possible to diagnose which call to hardware stuck? Or if you don't know it, can you direct me where could I ask question leading to real solving this issue?

             

            Of course, it can be also hardware problem, but when it is hardware problem, typically there is problem with more different applications (not my case, I have problem only with this game). And also I run HW tests and all passed OK (even this Download Intel® Processor Diagnostic Tool). Do you have some tips what to try to confirm that this is (or is not) problem in hardware?

             

            And about Microsoft* .NET Framework: can you explain me, how framework working strictly in user space can affect kernel driver or hardware except bug in driver? I don't think this update can help in this TDR. But for to be sure: computer is up to date with latest updates released from Windows update.

             

            Thanks for help

            Vaclav

            • 3. Re: Playing Fallout Shelter causes Display driver stopped responding and has recovered
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Wally_,
               
              Thank you for the information, please bear in mind that our latest driver have already address this issue, this issue has been resolved since the driver update mentioned above, since this is a Laptop, your best contact support at this point is with your system manufacturer as they are more familiar with your system and how all the components interact with each other.
               
              Normally we don’t have all the equipment from all of our partners to replicate this issue with this specific system you have, so you will need to ask Asus for them to try to replicate the issue with a system similar like yours and see if they get the same problem, if they don’t experience this behavior you should request a replacement directly from them.
               
              I sent you a private message.
               
              Best regards,
               
              Ivan.