9 Replies Latest reply on Jun 3, 2017 6:33 AM by Parapele

    Unigine benchmarks and 15.45.14.4590 driver bugs with DX9 API

    Parapele

      Hello everyone! It's me again. First of all, driver 15.40.28.4501 don't have any of these problems.

       

       

      Category

      Questions

      Answers (N/A if not applicable)

      Description

      Provide a detailed description of the issue

      Unigine Tropics Demo, Heaven Benchmark, Valley Benchmark suffers from UI corruption in DX9, additionally Unigine Tropics has graphical bugs

      Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")

      Always (100%): x

      Often (51-99%):

      Sporadic (20-50%):

      Very Sporadic (<20%):

      Hardware (HW)

      Brand and Model of the system.

      custom GIGABYTE H110M-S2H i3-6100

      Hybrid or switchable graphics system?
      ie Does it have AMD or NV graphics too?

      only HD 530

      Make and model of any Displays that are used to see the issue (see note2 below).
      LFP
      = Local Flat Panel (Laptop panel)
      EFP = External Flat Panel (Monitor you plug in)

      SAMSUNG SyncMaster 204B

      How much memory [RAM] in the system (see note2 below).

      8Gb DDR4 2133

      Provide any other hardware needed to replicate the issue.
      ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

       

      Hardware Stepping (see note1 below).

       

      Software (SW)

      Operating System version (see note2 below).

      Windows 10 10586

      VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

      1034.0

      Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

      21.20.16.4590

      SW or Apps version used to replicate the issue.

      Tropics Demo v1.3

      Heaven Benchmark 4.0

      Valley Benchmark 1.0

      Configurations

      Single display, clone, or extended (see note2 below).

      single display

      Display resolution & refresh rate setting of each display (see note2 below).

      1280 X 1024 75 Hz

      AC or DC mode, i.e. is power cable plugged in or not?

      desktop

      How to repro

      Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
      A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

      Run benchmark with DX9 API. open Settings and fast switch between tabs.

       

      Here links

       

      http://www.techspot.com/downloads/downloadnow/5802/?evp=8c3c7cadcb1dea4e457420dbce64a320&file=1

      https://assets.unigine.com/d/Unigine_Heaven-4.0.exe

      https://assets.unigine.com/d/Unigine_Valley-1.0.exe

       

      What can be interesting for dev. team, is that capture this bug was not easy. I was able to record on video only one bug in Tropics Demo. For some reason on screen can be bug, but on records nothing! Inbuilt tools MSI Afterburner not can capture bugs. Only old PrintScreen saves day.

      What i see on screen (PrintScreen)

      https://i.imgur.com/OYMxTGi.jpg           https://i.imgur.com/pp3t4jN.jpg

      What Afterburner captures

      https://i.imgur.com/E9rrx2l.jpg               https://i.imgur.com/TJ3PgM9.jpg

       

      Just more PrintScreen bugy pix

      https://i.imgur.com/uByu4wH.jpg

      https://i.imgur.com/2Ynd4ts.jpg

      https://i.imgur.com/kKybecl.jpg

      https://i.imgur.com/vOxtzs6.jpg

      https://i.imgur.com/IXslTwf.jpg

       

      Right at that time UI flickers for me.

      https://gfycat.com/WatchfulOrderlyIndigobunting

       

      Here only one type of bug was record on video, for me some textures flickering

      https://gfycat.com/MadBouncyGrouper