1 Reply Latest reply on Feb 27, 2017 11:53 AM by Intel Corporation

    nuc6i7kyk: disable speedstep

    Cosmoi

      I am looking for hopefully a straight-forward answer to this.

      For the Intel NUC we bought: nuc6i7kyk

       

      we want to disable Intel Speedstep but this is not clear how to do.

      Turboboost off does not imply Speedstep off.

       

      Bottom line is we have performance issues with our PCI device via Thunderbolt

      and expansion chassis from Sonnet Tech but only when going at slower rates.

       

      Have played around with power settings in bios and Windows 10 as well and no luck.

       

      Our devices have historically had issues with Speedstep enabled.

      CPUZ does not report much difference between high and slow data rate

      but the clock is still changing.

        • 1. Re: nuc6i7kyk: disable speedstep
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello :

          In regard to your inquiry, the option to disable speed step on the BIOS is under the tab that says “power”, then look for “enhanced Intel® speed step® technology” .

           


          Now, remember that the performance depending on the expansion devices being used might not be as expected, some of them are not fully compatible or they might not work at all, this is just to let you know in the case the problem remains even after disabling speed step. Please make sure the drivers are properly installed and up to date.

          Here is the link where you will find all the drivers for the NUC:

          https://downloadcenter.intel.com/product/89187/Intel-NUC-Kit-NUC6i7KYK

          Any further questions, please let us know.

          Regards

          Alberto