1 2 3 Previous Next 44 Replies Latest reply on Mar 5, 2010 6:37 AM by Carl2

    Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?

    Carl2

      I have just put the SSD in the computer a Gateway FX6801, formatted the drive, and with the cloning software supplied with the SSD I transfered the Win7 installation from the original Hatachi hard drive to the SSD.  The bios is set to AHIC, the computer boots from the SSD and everything works fine.  The load time hasn't improved, 1 min 20 sec which I feel is long and the main reason I changed to SSD.  The Win 7 performance for the drive is 5.9 which is the same as the original Hatachi drive. I'd posted this at another forum I am a member of and two replies I recieved were I should Install Win 7 rather than clone.  The recovery software for the computer will only install on the original hard drive so I'd have to buy Win 7 and then try to install the drivers that want to install on the Hatachi drive.  Also I am not sure what firmware the disk has, pretty sure I saw it some where in the computer but I can't find it again.

      Carl2

        • 1. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
          ambizytl

          As for the firmware, go to Device Manager, click on Disk drives, double-click your drive and go to Details, and then under Property from the pull-down menu select Hardware Ids and you will see your firmware. The latest firmware is 02HD and previous was 02HA--if you don't have either, you definitely need to update firmware for TRIM. Actually, you should go with latest, 02HD firmware.

           

          You could try running the Optimizer from SSD Toolbox and see if that helps your WEI, providing you have TRIM firmware.

           

          Do you have default msahci driver for AHCI?

          • 2. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
            Carl2

            Thank you, downloaded and installed the firmware.  Next I downloaded the toolbox.  I could not install the toolbox, a problem with the windows installer. After reading the documentation I disabled the disk defragmenter, since I couldn't find Netframework I downloaded and installed it which said it was already installed. I tried the run instead of save with the same results. The toobox still will not install.  I hope you can offer some advice on this also.

            Carl2

            • 3. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
              ambizytl

              Now that you installed the latest firmware, have you run the WEI test?

               

              Do you have the default AHCI driver from Windows 7, msahci installed? Is your SSD detected as an ATA device or SCSI? Is your SSD a non-dynamic disk configuration? Are you running RAID?

               

              You don't need NET Framework as Windows 7 has the requirement.

               

              You may have had a bad download. Try downloading the SSD Toolbox again by saving it and then click run from where you downloaded it--I suggest moving it to desktop and run it from there.

              • 4. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                Carl2

                I"ve run the WEI test, I think you are saying Win Experience Index, what I refer to as the Performance index.  Ran it again after update still 5.9.  Under the IDE ATA /ATAPI controllers I have: ATA channel 0, ATA channel 1, Intel(R) ICH SATA AHCI controller, Standard AHCI 1.0 Serial ATA controller,.

                The driver for the Intel ICH10R AHCI is iaStor.sys.

                The driver for the Standard AHCI 1.0 has four listed: atapi.sys,ataport.sys, msahci.sys and pcidex.sys.

                  The SSD was formatted 64bts and the setup was a basic volume, the bios was set to AHCI when the disk was put in,  It is labled D:. No problem seeing it once it was formatted.

                  I tried downloading again to the desktop as suggested.  The windows installer could not be accessed.

                Carl2

                • 5. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                  ambizytl

                  I don't understand why you have those two AHCI controllers. I only have the Standard AHCI 1.0 Serial ATA controller with Windows 7 default msahci driver. TRIM does NOT work with that Intel driver you have: iastor.sys

                   

                  About your alignment, here is something I copied from somewhere: To check that your partition is aligned correctly, go to your start menu and in the run box type msinfo32 and run it. Click on components => storage => disks and check what the partition starting offset is for your SSD. If it isn't divisible by 4096, then it's not aligned correctly (ie if you get any number that isn't a whole number, then it's not aligned).

                   

                  I think the main issue is having that Intel controller and driver--TRIM will not pass to Intel driver, so you are not having TRIM enabled unless you run the Optimizer and you haven't been able to do that. Why do you have that Intel AHCI controller and the Standard AHCI controller? Seems like a conflict to me having both those AHCI controllers.

                   

                  The reason your WEI result is so low is because your drive needs to be TRIMMED.

                  • 6. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                    ambizytl

                    I believe the problem is you cloned your Windows 7 from a system that had the Intel AHCI controller and there is the problem. I believe you should uninstall that Intel AHCI controller.

                    • 7. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                      ambizytl

                      In addition to the above, in case you need guidance uninstalling that Intel AHCI controller: right-click on the Intel AHCI controller and click Uninstall.

                      • 8. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                        Carl2

                        The SSD partition ofset is 32.256 bytes

                        I just checked the bios, the Onboard Sata Mode has three choices: Ide, Raid and AHCI.

                        I had a raid volume in the computer earlier, again a clone, got the same performance I'd say with the original drive, raid and the SSD.

                        To use the Intel Storage Matrix the bios has to be set to raid which allows you to use the matrix to set up a raid array. The raid array will use AHCI.  I'm fairly certian the iaStor.sys is the driver needed for raid.  I'd had raid in the past, not much improvement but I was unable to see or use unraided drives.  With a raid array on this computer I can see and use the regular hard drive.

                        I also read something stating the SSD should be placed in a low number port, it's now at port 5 and the original is at port 0. I should try changing these two around. I should try downloading and installing the toolbox in this computer.

                        Carl2

                        • 9. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                          ambizytl

                          Are you doing RAID? If not, you should set the BIOS to AHCI and use the msahci driver along with the Standard AHCI controller. At this point, I don't know what you are doing. I already spoke about your cloning and how that is probably why you have that Intel controller, which is what I said should be uninstalled.

                           

                          When you spoke of ports in a previous post, you only mentioned ports 0 and 1. Again, are you doing RAID? TRIM will not pass through in a RAID environment.

                          • 10. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                            Carl2

                            I've just ordered Windows 7 and a Sata cable.  Perhaps this will speed up the process when it arrives.  I should be able to install the drivers from the Win 7 upgrade disk.  I had tired raid in the past, removed the drives and replaced them with the SSD so I now have SSD as an OS and the Harachi drive with an OS. The bios is set to AHIC. Not using Raid.

                            Carl2

                            • 11. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                              ambizytl

                              Ah, so you have an Hitachi HDD loaded with an OS and an Intel SSD loaded with a cloned OS from the Hitachi drive. So why was/is there a need to have two drives loaded with same OS?

                               

                              As I said previously, you should uninstall the Intel controller from the SSD drive and that just might solve your problem. You could have tried it before ordering another Windows version.

                              • 12. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                                Carl2

                                Just looking at the Device manager, view- devices by connection and I have the Hatachi drive, the SSD, and the DVD.  I'm worried about all 3 0f these devices not working once I uninstall the drivers.  I agree it seems that the SSD should be moved to Standard AHCI which contains the correct driver for the SSD, msahci.sys.  I'm really unfamiliar with this, I'd think it would be unplug from the motherboard and plug in at the standard input connectors.  In bios for Advanced chipset features I have Intel EIST, Intel XD Bit, Intel VT  all are enabled. Not sure what any of these are.

                                Carl2

                                • 13. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                                  ambizytl

                                  First, the only reason you have the Intel controller is because you cloned the OS from your Hitachi drive. I don't see why you can't uninstall the Intel SATA AHCI controller--you don't need it.

                                   

                                  Look in the manual for your motherboard for explanations of those BIOS questions. Intel VT is probably Intel Virtual Technology. You should read the motherboard manual and learn more about the BIOS.

                                   

                                  If you are not using Virtual Technology, disable it. Here is an excerpt from the SSD Toolbox readme:

                                   

                                  System Configuration Requirements for Intel SSD Toolbox

                                  ·      Virtualized Environments are not supported

                                  ·      Drives detected under Microsoft Windows* as SCSI are not supported

                                  • 14. Re: Intel X25-M Mainstream SSDSA2M160G2R5  160Gb ?
                                    Carl2

                                    Tried your suggestion, I uninstalled the driver for the Intel controller, restarted and recieved a notice to restart for changes to take effect. Restarted again and still recieved notice. Used restart later and checked the device manager, The drivers for the Intel controller changed, it now has 4 drivers the same as the Standard AHCI controller.  Had to go into bios and check yes to resetting changes, for the reset notice to stop.  The Toolbox still will not install.  Disabled Intel VT in bios, toolbox not installing.

                                    Carl2

                                    1 2 3 Previous Next