1 Reply Latest reply on Feb 23, 2017 2:20 AM by homebrewpc

    BIOS updating problem - DH61BE board

    homebrewpc

      I have a DH61BE board that is listed as needing a bios update to support Ivy Bridge. I have both a Sandy Bridge, currently installed and an Ivy Bridge which I wanted to install. I updated to bios v48 as it is listed as required to then update to v99 to then update to v120. I got to v48 fine. When trying to update to v99 it said it update fine. However, it will not longer get past the bios splash screen. I can hit F2 to enter the bios but it simply will not boot.

       

      I first tried bios recovery mode by removing the jumper and putting v109 on a USB stick. When I power it up, nothing is displayed on screen. The light on the USB mouse pulses. I waited 30min and nothing.


      I then tried bios recover slightly differently by unplugging the power cord and removing the CMOS battery for a minimum of 30min per this page: BIOS updating problem - DH61BE board . The result was the same as the above.

       

      I then put the jumper back and tried the F7 method. It will start but fail, saying something about "FW Update full buffer"

       

      This v99 seems to be giving many people problems, why has it not been fixed? How do I resolve this situation?

       

      Please, any help is greatly appreciated.