13 Replies Latest reply on Mar 8, 2017 3:12 PM by Intel Corporation

    Skull Canyon won't boot.  No LED, no Boot Screen

    Ryan_M

      This is my second Skull Canyon (first was warrantied last fall).  It has been working without issue until freezing while doing my taxes (so nothing too taxing on the system /bad pun) the other day.

       

      I powered down and turned back on.  I was able to get into Windows but within a minute or two it froze again

      Trying to turn on again would result in Windows trying to go into Automatic Repair, but freezing on that screen

      The power LED no longer turns on, and I don't get to the boot screen to even try to get into the BIOS/Boot Menu.  The fan would go full blast for about 15-20 seconds, before rebooting and running continuously

       

      Things I have tried:

       

      Pulling security jumper to restore BIOS (It was on the most recent BIOS).  Nothing ever appeared on the screen

      Tried with each stick of RAM individually, and with no RAM

      Tried with no RAM/SSD

       

      No difference in any of the tests above, and not Post beep codes either.

       

      Any suggestions?  Or is it time for another warranty replacement?