3 Replies Latest reply on Feb 28, 2017 6:59 AM by Intel Corporation

    NUC6 Skylake recurrent system freezes for devices with S/N G*SY63, bad batch?

    mgcrea

      We have a few hundreds Skylake (NUC6i3, NUC6i5) devices out there in production (mostly store/pos displays).

       

      We've have encountered very strange total system freezes (Ubuntu 16.04.2 LTS, Mesa 13) that totally locks the device, issue is not easily reproducible (happens ~4h after boot, not every day) on ~15% of our fleet.

       

      We tried the max_cstate patch (forcing cstate 1) but we kept having freezes. We tried to update to kernel 4.8, same issues.

       

      Finally while investigating, we discovered that all devices that were having freezes (cross clients) have a S/N that starts with GESY63 or G6SY63, we have a lot of GESY61 devices in our fleet and none has crashed yet.

       

      Related issues with some more info:

       

      - https://bugzilla.kernel.org/show_bug.cgi?id=194621

      - kernel - Troobleshoot 16.04 inexplicable total system freeze 4 hours after reboot on several NUC6i5 - Ask Ubuntu