1 2 3 Previous Next 60 Replies Latest reply on Nov 2, 2017 11:15 AM by Wibble

    NUC6i7KYK HDMI audio glitch

    Wibble

      I have a very strange audio issue that I'd like advice on.

      I recently replaced my NUC DC3217BY with the NUC6i7KYK. The computer sits under my TV for media playback, video calling, and gaming.

      My TV is a Panasonic plasma from 2008 with Full HD resolution. The surround amp is a Marantz NR1601 (HDMI1.4a) with 7.1 surround.

      Windows is set up to output 7.1 with 24-bit audio @ 96kHz. This setting is common between the two NUCs.

      For media, I stream YouTube or Netflix, play video files using VLC, and play DVDs/Blu-Rays using WinDVDPro.

      With my DC3217BY I used WinDVDPro11, on the NUC6i7KYK I use WinDVDPro12. The drive is a Pioneer BDR-XU03 connected to one of the rear USB3.0 ports of the NUC.

       

      The DC3217BY setup was flawless. It is only nearly flawless with the NUC6i7KYK.

      I can play everything, but when I open WinDVDPro12 to play a DVD or  Blu-Ray, I notice the PCM indicator on my amp blinks off for about half a second every 10-20 seconds with an accompanying break in audio from the speakers. There is no issue with the video playback at all.

      If I close WinDVDPro, the audio glitch continues on the same cadence regardless of what programs I open or what media I play.

      The only way to get it to stop is either to put the computer into and out of standby or select a different audio playback device from the Windows 10 volume dialogue and then switch back to HDMI.

       

      While WinDVDPro is open, if I change audio output to the headset jack or my Bluetooth headphones, there is no glitching on those outputs. When I revert to HDMI, the glitching resumes.

       

      I have downloaded the Intel Driver Update Utility. However, when it scans my computer it keeps throwing up the same software and drivers as out-of-date. Attempts to install recommended versions fail. The graphics driver and the audio driver, however, are up-to-date. The chipset, Thunderbolt and a couple of others (including CIR) are flagged as wrong (I am not using the Thunderbolt port yet, the CIR seems to work without issue).

      I have tried to run the HDMI v2.0 firmware update, but it will not install until I connect a HDMI v2.0 compliant device, which I do not have.

       

      I don't believe I can blame WinDVDPro for the glitching as all it has to do is decode the audio and video from any disc that is playing, which it does correctly with all my other audio devices and there is no issue with the video at any point.

      The fact that the issue starts when WinDVDPro starts is suspicious, but closing WinDVDPro does not fix it (I have to adjust audio output or put the computer to sleep).

      The HDMI cables are all 1.4 high-speed and are 3' or 4' in length, so signal distortion does not seem likely (and anyway, audio is fine with every program except WinDVDPro).

      My Marantz receiver is compatible with the audio settings I have.

       

      Are there any known incompatibilities with HDMI audio that I can investigate?

      Why doesn't the driver update utility work correctly to update all the drivers it says are outdated?

       

      I have tried altering the settings for audio in Windows, but no sample rate or dynamic range bit-depth has any different effect. I have tried changing the way WinDVDPro works with audio from the DVD/Blu-Ray discs, but again no change.

        • 1. Re: NUC6i7KYK HDMI audio glitch
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Wibble,

           

          I would like to gather more information in regard to your system, this will help to address this matter in the most accurate way. So please respond to the following;

           

          To attach a file, you must click "Use Advanced Editor" in the top right corner of the response box, then the "attach" option will appear in the bottom right corner of the response box.

           

          Regards,

          Amy.

          • 2. Re: NUC6i7KYK HDMI audio glitch
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            In regard to your second question, t he issue you pointed out with the Intel® Driver Update Utility is under investigation, an upcoming version will show some improvement. We are working on additional fixes, which we hope to have ready soon.

             

            Regards,

            Amy.

            • 3. Re: NUC6i7KYK HDMI audio glitch
              Calvinz

              Amy,

               

              I am also encountering the same issue as mentioned by Wibble. HDMI audio keeps breaking randomly where video signal remains consistent.

               

              NUC : NUC6i7KYK

              OS: Windows 10 Pro 64 bit

              HDMI cable : Panasonic HDMI2.0 4k compliant cable

              AV Receiver : Onkyo TX-NR636

               

              I have tried the following but it did not resolve the problem

               

              1. Updating to latest display drivers

              2. Perform HDMI 2.0 firmware update from Intel product download page

              3. Changing to different HDMI inputs on the AV receiver

              4. Changing to different HDMI cables

              5. Booted on ubuntu live image

              6. Configured BIOS to use HDMI as primary display output

               

              I'm attaching the SSU report as well.

              • 4. Re: NUC6i7KYK HDMI audio glitch
                Wibble

                The cable is a Monster HDMI cable. I do not know the model number.

                It is the same as was used with my previous NUC without issue. I used it with my Panasonic Blu-Ray player when I still had that (the NUC consolidated all my entertainment devices into one).

                Please see the system information attached as instructed.

                 

                Also, the username is required to be unique, but my name is Alex (just to make correspondence more personable).

                • 5. Re: NUC6i7KYK HDMI audio glitch
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Sure Alex. 

                   

                  Based on your report, all your drivers seem to be up to date. 

                   

                  Could you please try installing the WinDVD Pro 12 Service Pack 1 Patch? Here you can find it; Corel WinDVD Pro Updates 

                   

                  Let me know how it goes.

                   

                  Regards,

                  Amy.

                  • 6. Re: NUC6i7KYK HDMI audio glitch
                    Wibble

                    I think the version I bought and installed already had the patch applied as the specific download simply tells me I already have it and kicks me out of the installation process then and there.

                    The periodic break in audio persists.

                    • 7. Re: NUC6i7KYK HDMI audio glitch
                      Wibble

                      In fact, to shed a little more confusion on the issue, I noticed some more behaviour...

                      When playing a DVD, I could open the playback audio devices and 'Configure' the Marantz output. I changed it to stereo (although any other option does the same) and noticed that the glitching stopped. I then changed it back to 7.1 and the audio continued to play without issue.

                      I closed WinDVDPro and opened it again to play the disc and the glitching started. This time, I used the Windows 10 volume meter to change the output to S/PDIF (nothing connected so no audio output) and then back to Marantz. The glitching stopped.

                      I know this contradicts my first description, which caught me off-guard.

                      Then I put in a Blu-Ray, but no amount of changing audio settings during playback would remove the glitching.

                      I do have to change my A/V setup this evening (new cable TV box), so I shall experiment with the cabling just to be sure whether that is contributing to the issue.

                      • 8. Re: NUC6i7KYK HDMI audio glitch
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Thanks for letting me know that.

                         

                        Please share your results, I am really interested on the outcome.

                         

                        Regards,

                        Amy. 

                        • 9. Re: NUC6i7KYK HDMI audio glitch
                          Wibble

                          Unfortunately, changing the HDMI cabling had no effect on the issue.

                          • 10. Re: NUC6i7KYK HDMI audio glitch
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Alex, thank you for sharing your results.

                             

                            Please let me review this, I will keep you updated as soon as possible.

                             

                            Regards,

                            Amy.

                            • 11. Re: NUC6i7KYK HDMI audio glitch
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Calvinz,I just wanted to let you know that we are currently reviewing this case, and since you have a very similar situation your information was already added to this research. At this stage, I do not have an update, but I will let you know via this thread as soon as I have more information,

                               

                              I also noticed that you are running BIOS version 041, and we have BIOS 042. So, please proceed updating that version to the latest, find file below.

                              BIOS 042; 

                              Download BIOS Update [KYSKLi70.86A] 

                               

                              Update instructions;

                              F7 BIOS Update Instructions for Intel® NUC 

                               

                              Regards,

                              Amy.

                              • 12. Re: NUC6i7KYK HDMI audio glitch
                                Wibble

                                Actually, thinking about it (although I can't attest I'm 100% right here...) between my first post and my update and using the audio settings to correct the DVD glitching, I performed an upgrade to the BIOS. Can't recall which one came on the computer. I upgraded not long after my first post so that would have been reflected in the diagnostics I uploaded.

                                I wonder whether this had an effect on the ability of the volume settings to change the glitching behaviour...

                                I could swear the characteristics in my first post were correct at the time of press...

                                • 13. Re: NUC6i7KYK HDMI audio glitch
                                  Calvinz

                                  Amy,

                                   

                                  I had tried to update the NUC firmware to the latest available (BIOS 042) but the issue still persists. However there are some findings from myself where I noticed the audio dropouts are far lesser when I'm running on 1920x1080(60p) resolution compared to 3840x2160(60p). And I had tested the HDMI going through a intermediary powered HDMI switch which further helped but not entirely.

                                  • 14. Re: NUC6i7KYK HDMI audio glitch
                                    cvare

                                    Calvinz, can you try something for me first?  Sorry, I'm one of the supervisors in customer support.

                                     

                                    Can you try using Media Player Classic first before we go out and get the paid application?  We test everything on MPC (according to this setup: http://www.intel.com/content/dam/support/us/en/documents/boardsandkits/Configure-Surround-Sound.pdf ), so if it's still having issues with that, then we know it's not the software.

                                     

                                    Also, one more thing, just to confirm, does the glitch happen on any other piece of software?

                                    1 2 3 Previous Next